Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 11-24-2001, 06:01 AM   #1
vfx-3d
Junior Member
 
Join Date: Nov 2001
Posts: 3
Angry Fxp 1mb -ok 15mb -failed

There's something really strange going on ... I don't know if this is FlashFXP specific ...

here is my log:

Works
=====

227 Entering Passive Mode (24,186,210,119,13,109).
PORT 24,186,210,119,13,109
STOR 1MBtest.txt
150 Opening data connection for 1MBtest.txt.
RETR 1MBtest.txt
150 Data connection accepted from 208.59.177.224:1999; transfer starting for 1MBtest.txt (1000000 bytes).
226 File received ok.
226 Transfer ok
Transferred: 1MBtest.txt 1,000,000 bytes in 17.17 (56.89 KB/Sec)


Does not work
=============

TYPE I
PASV
227 Entering Passive Mode (24,186,210,119,16,56).
PORT 24,186,210,119,16,56
STOR 15mbtest.txt
150 Opening data connection for 15mbtest.txt.
RETR 15mbtest.txt
150 Data connection accepted from 208.59.177.224:1999; transfer starting for 15mbtest.txt (15000000 bytes).
226 Transfer ok

// FlashFXP does not recognize the transfer has been finished ...
// It stays idle ... but the file has been transfered successfully.
// so it does not upload the next file ...

I hope someone can explain this to me.

Thanks in advance,

-Lars
vfx-3d is offline  
Old 11-24-2001, 11:16 AM   #2
vfx-3d
Junior Member
 
Join Date: Nov 2001
Posts: 3
Default

It's not FlashFXP specific. IglooFTP, SmartFTP and CuteFTP Pro all handle it the same way, which means one of the two ftp servers is misconfigured and does not fully support fxp the way FlashFXP expects it.

The only thing that bothers me is that FlashFXP detects that the transfer is finished (226 Transfer OK), but waits for something else ... perhaps you could FlashFXP simply wait for 226 Transfer OK and nothing else.

-Lars
vfx-3d is offline  
Old 11-24-2001, 02:33 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

If you look at the first and then second sample, you will see the second sample only has 1 transfer complete reply. When doing a FXP there should be 2 transfer complete replies.

FlashFXP is still waiting on the ftp server to send the transfer complete reply.
bigstar is offline  
Old 11-24-2001, 04:31 PM   #4
vfx-3d
Junior Member
 
Join Date: Nov 2001
Posts: 3
Default

Yes, I haven't noticed that before.
Could you please add a function to FlashFXP that allows you to turn the 2-Reply-Check off and only waits for one confirmation?

I noticed that "bug" on several servers ....

Thanks,

-Lars
vfx-3d is offline  
Old 11-24-2001, 05:14 PM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,838
Default

hmm..it could be that 2nd site is timing out that's why you don't get transfer ok from it..
i'm pretty sure that in this situation if you do hard abort site will not reply too..you'll have to reconnect.

i don't htink it's such a good idea to consider trasnfer complete based only on 1 transfer complete msg..
MxxCon is offline  
Old 11-24-2001, 07:02 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally posted by vfx-3d
Yes, I haven't noticed that before.
Could you please add a function to FlashFXP that allows you to turn the 2-Reply-Check off and only waits for one confirmation?

I noticed that "bug" on several servers ....

Thanks,

-Lars
If FlashFXP attempts to transfer the next file before the previous one is finished the transfer will be incomplete.

The best solution is to fix the ftp server. not break the ftp client.
bigstar is offline  
Old 11-25-2001, 09:19 AM   #7
stat
Junior Member
 
Join Date: Nov 2001
Posts: 5
Default

I have the exact same problem when FXPing between two sites... it works fine for smaller files but if I'm sending large files, it sends fine and the reciever will send back a message saying "transfer was ok" but it's as though the sender connection times out and actually disconnects you, although you don't see it and the FXP is still going. Once the transfer finishes, it sits there and if you want to transfer the next file, flashfxp then realizes that we've been disconnected and reconnects to the sender site and sends the next file.

I know this has nothing to do with FlashFXP but it's just strange.. both sites are glFTPd sites and I can't figure out why this happens. I'm also connecting through a proxy if that makes any difference.. I've tried enabling and disabling "send noops during transfer" but nothing.. could it be maybe that winproxy is "timing me out" or something? strange.
stat is offline  
Old 11-25-2001, 09:57 AM   #8
SuRf3R
Junior Member
 
Join Date: Nov 2001
Posts: 1
Default It could be the proxy thing...

My site is the one that the files are being FXP'd to in that example. I'm running BulletProof FTP v2.15 on a Win2K server that is behind a proxy. I've had other strange problems with this site being behind a proxy before, that I did not have without the proxy in the picture.

I'm gonna setup an FTP server on the proxy itself to bypass the forwarding and address translation issues that the proxy causes. I'll post when I find out if that's the problem....
SuRf3R is offline  
 

Tags
150, 15mbtest.txt, 1mbtest.txt, connection, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:41 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)