Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-15-2004, 06:52 AM   #1
NorLan
Senior Member
 
Join Date: Sep 2003
Posts: 110
Default 1+1=5 ??

hy guys - io reinvents some funny counting methods - look at groups users and all users i have on my site - no users is in two groups same time


[13:51:37] [L] site groups
[13:51:37] [L] 200- Name Description Users
[13:51:37] [L] 200- xxxxxxxxxx New Group 0
[13:51:37] [L] 200- FULL New Group 0
[13:51:37] [L] 200- NoGroup Default Group 2
[13:51:37] [L] 200- SiteOP Administrators 5
[13:51:37] [L] 200 groups Command successful.
[13:51:47] [L] site users
[13:51:47] [L] 200- Name Group Flags Home
[13:51:47] [L] 200- anonymous NoGroup 3AX
[13:51:47] [L] 200- xxxxxxxx SiteOP 1MTH /
[13:51:47] [L] 200- NorLan NoGroup 1MTH
[13:51:47] [L] 200 users Command successful.
NorLan is offline   Reply With Quote
Old 05-15-2004, 08:04 AM   #2
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

The usercounter in the groupfiles is changed when "site adduser/deluser/chgrp" is called. Any scripts that change groups for users, or adduser/deluser, have to edit the groupfiles themselves.

For example, my ioGui.iTCL script that allows u to copy an existing user, doesn't update the usercounter in the groupfile, so if u copy 100 users and then delete them, the counter will be at -100 or so.
ADDiCT is offline   Reply With Quote
Old 05-15-2004, 09:05 AM   #3
NorLan
Senior Member
 
Join Date: Sep 2003
Posts: 110
Default

no script is installed thats why i am posting
NorLan is offline   Reply With Quote
Old 05-15-2004, 09:25 AM   #4
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

In default installation group counters are skewed..
darkone is offline   Reply With Quote
Old 05-15-2004, 01:30 PM   #5
NorLan
Senior Member
 
Join Date: Sep 2003
Posts: 110
Default

an when does they fit ?!

on my "bigger" server - i have 476 users when i count all shown beside site groups -- but in fact they should be close to 400 ... seems to be a reason addict said (scripts ioA ionED)

not really necessary those numbers for any reason except my own curiosity but just a lille disturbing.

what should i do to get right numbers when i set up a new server ?
NorLan is offline   Reply With Quote
Reply

Tags
200-, users, [135137], [135147], [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:50 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)