Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 03-22-2002, 09:24 AM   #16
cmf_2
Junior Member
 
Join Date: Mar 2002
Posts: 10
Default

Hi leblanc!

Well my site is a RaidenFTPd, and i was trying others RaidenFTPd as well as glFTPd´s.

I have some scripts installed in my server to do some automated tasks like you says.

I will try what you told me, but i don´t have php´s scripts installed in my server.

I think the problem is with my NAT router Vicomsoft Internet Gateway, but not sure.

bigstar was point me with another trick to try also.

I will do some workaround and then i will post the results.

At this point, one things is sure, FlashFXP is not the problem, it´s working as usual, like early versions.

cmf.
cmf_2 is offline  
Old 03-22-2002, 11:26 AM   #17
cmf_2
Junior Member
 
Join Date: Mar 2002
Posts: 10
Default

Ok guys,

This is my workaround to this apparently problem with site to site transfers.

Well i suspect the problem is with CONTRL Connection and open NAT Ports at my NAT Router. Recall i´m behind a NAT Router like is Vicomsoft Internet Gateway, may be one of you are behind a NAT router.

I notice that FXP works fine when it doesn´t take more than 2 minutes. That 2 minutes is the time i have set up to NAT Ports to remaind open.

So past that time CONTROL Connection doesn´t not arrive anymore thru NAT Router since that Port was closed for security reason.

I think that´s the problem, although i´m still working on that.

cmf.
cmf_2 is offline  
Old 03-22-2002, 12:49 PM   #18
cmf_2
Junior Member
 
Join Date: Mar 2002
Posts: 10
Default

Just confirmed!

NAT Router was dropp CONTROL Connection Port when they expires. This NAT Router just closed unused opened NAT Port for security reason. It gives each opened NAT Port a time to remain open, when time expires and not activity on that port then, this NAT Router closed it.

Keep in mind that not all NAT Router work as the same way. My early NAT Router was WinRoute and i don´t notice this behaivor.

I just set it up to a more bigger time (30 minutes), and all FXP session were finished correctly.

So take care about it.

If you get something like us, then suspect if in the middle there´s a device that blocking or closgin opened ports.

Hope this solve your troubles also.

cmf.


Keep good work going on...
cmf_2 is offline  
Old 03-23-2002, 04:23 PM   #19
rGb
Junior Member
 
Join Date: Mar 2002
Posts: 5
Default

I've got a similar problem...

I've got 2 computers. The first is a windos 2000 pro. box, the second is a redhat linux 7.2 box running ProFTPD. Both computers are connected to the internet via the DSL-router Linksys BEFSR41. I have the port range 60000-65535 forwarded to the ftp-server in order to make passive ftp work correctly. Further on, my ftp uses port 6384, so the ports 6383 & 6384 are also forwarded to the ftp-server. ProFTPD is configured to accept data-connections from foreign ip addresses, of course.

If I try to initiate a fxp-transfer from some ftp-server to my own ftp-server (using FlashFXP 1.4.3 build 835 on the win2000 box) everything is working smoothly.

If a friend of mine tries to initialize the same fxp-transfer from his win98 box using version 1.2 of FlashFXP, about 3 files á 20mb transfer correctly. However, FlashFXP won't continue transfering any further files after the fourth has been transmitted. It hangs at the end of the transfer and he gets two messages that say "226 Transfer complete.". FlashFXP will only continue sending the files if he presses the "Abort"-button once and then tries to transfer the queue again. Playing with the "Alternative (FXP) site to site method" doesn't help at all.

The strange thing is, that I have no problems with the same transfer and exactly the same settings, while my pal has. By the way, I have no possibility to set connection timeouts in my router-settings.

If nobody knows help, i'll go through the hard work of analyzing the TCP/IP dump of the transfer
rGb is offline  
Old 03-24-2002, 02:12 AM   #20
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

Quote:
Originally posted by rGb
I've got a similar problem...

If I try to initiate a fxp-transfer from some ftp-server to my own ftp-server (using FlashFXP 1.4.3 build 835 on the win2000 box) everything is working smoothly.

If a friend of mine tries to initialize the same fxp-transfer from his win98 box using version 1.2 of FlashFXP, about 3 files á 20mb transfer correctly.
why is your friend not using the latest version of FlashFXP? That would be the first thing to try.
Linkster is offline  
Old 03-24-2002, 06:00 AM   #21
rGb
Junior Member
 
Join Date: Mar 2002
Posts: 5
Default

I told him to do so already, he had no time -.-
rGb is offline  
Old 04-04-2002, 08:16 AM   #22
LittleFart
Junior Member
 
Join Date: Apr 2002
Posts: 25
Default

well i had the same problem, but i solved it, i enabled "close unused ftp connections during transfer" (in the transfer tab under options) and it worked fine for me on serv-u and glftpd boxes
LittleFart is offline  
Old 04-04-2002, 08:18 AM   #23
rGb
Junior Member
 
Join Date: Mar 2002
Posts: 5
Default

Okay thanks.. i never thought of *enabling* that
rGb is offline  
Old 04-04-2002, 09:05 AM   #24
cmf_2
Junior Member
 
Join Date: Mar 2002
Posts: 10
Default

LittleFart,

I´m not sure what happens with DATA CONNECTION port if you close CONTROL CONNECTION port that becomes idle most the time.

I´m not sure if that feature in FlashFXP is closing that idle port (CONTROL CONNECTION), i will give it a try.

But keep in mind if the port is closed, when you are transfering between site-to-site, how site knows about that event?

Further, how site send a transfer complete and where? I assume server send transfer complete at that port was arranged in ftp session, but now it´s closed. What happen then?

Once again, i will give it a try and see what happen. And i just told early, most NAT Router closes iddle NAT port for security reason. It´s the main problem with this thread folks.


cmf.
cmf_2 is offline  
Old 04-04-2002, 10:21 AM   #25
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

"close unused ftp connections during transfer"

FlashFXP will disconnect any FTP connection that isn't necessary to transfer the current file in the queue.

Basically if you queue some files from a site on the left and then a site on the right and transfer, FlashFXP will disconnect the right site, transfer the files on the left, and then reconnect to the right site to transfer the files. otherwise the connection to the site on the right will idle until it's time to transfer the files.
bigstar is offline  
Old 04-22-2002, 11:54 PM   #26
kingkong
Junior Member
 
Join Date: Apr 2002
Posts: 14
Default

you know, mine did the same thing...until...
1. Transfer file on drag and drop (enabled)
2. Noops DURING TRANSFER(DISABLED)


works fine now. I think it was the noops thing.
kingkong is offline  
Old 04-23-2002, 12:37 AM   #27
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sending noops during transfer is a catch 22, it can sometimes solve problems but also create new ones.

This option should only be enabled if you are having timeout problems during transfers, and if you immediately notice new problems it should be turned back off.
bigstar is offline  
Old 04-23-2002, 04:04 PM   #28
mhe
Junior Member
 
Join Date: Dec 2001
Posts: 8
Default

cmf: thanx for solving my problem!

Some costumers were complaining their transfers were stalled at 100% (when the FTP server normally gives them a directory listing).

The problem was a 300second timeout of TCP ports on the hardware router.. Changed it to 3600s.. Not sure if this might affect anything else?

Sidenote: this is (was) not a flashfxp related problem.. Several (all?) ftp clients had the same problem.. I suspected Guildftpd at first.
mhe is offline  
Old 04-23-2002, 04:19 PM   #29
cmf_2
Junior Member
 
Join Date: Mar 2002
Posts: 10
Default

mhe,

I think you solved this issue increasing that value like you made.

Remeber that serious NAT router closes those idle port for security reason.

So be aware of that, you increase that value in 1 hour. So your router will keep that opened port idle by 1 hour.

I don´t think it will affect other things.

Good luck!

cmf.
cmf_2 is offline  
Old 05-04-2002, 05:52 AM   #30
GuYoMe
Junior Member
 
Join Date: May 2002
Posts: 1
Default

I got exactly the same pb than the others but i've got a few precisions to make :

First it's a random bug, sometime it works sometime not...
Second the bug doesn't appear un cuteftp pro (never) so it must be fixable.
Last the bug appears more often when using a proxy to make transfers...

That's all for my contribution, ThX for fixing this really shitty bug that makes me go to cuteftp pro shitty interface....(pleaz fix it, i love Flashfxp)
GuYoMe is offline  
 

Tags
226, complete, hangs, start, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:28 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)