Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 01-16-2002, 02:32 PM   #1
revilino
Junior Member
 
Join Date: Jan 2002
Posts: 11
Default I cannot fxp with xp on port21

I have tried many times fxping on port21 from server to server
but it only works with passive mode
not with nonpassive mode
hmm but when i start on win98 it works on both passive and nonpasive is this a xp bug or flashfxp
bug i know more people with da problem
tnx hope someone can helpe me with that problem
revilino is offline  
Old 01-16-2002, 02:47 PM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

sounds like you have the xp firewall enabled?
Linkster is offline  
Old 01-16-2002, 04:25 PM   #3
revilino
Junior Member
 
Join Date: Jan 2002
Posts: 11
Default

jeps i have disabled it m8
revilino is offline  
Old 01-16-2002, 06:00 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Do you have a router/firewall which uses NAT? that would explain why you can't fxp on port 21 ftp servers.

The only solution is to disable NAT.
bigstar is offline  
Old 01-17-2002, 09:06 AM   #5
revilino
Junior Member
 
Join Date: Jan 2002
Posts: 11
Default

NOpez i dont have used a firewall or router
when i boot on win98 there is no problem m8
revilino is offline  
Old 01-17-2002, 01:32 PM   #6
revilino
Junior Member
 
Join Date: Jan 2002
Posts: 11
Default

i have found the problem it was xp internetsharing
i have turned it off and use sygate now
everything works fine
revilino is offline  
Old 01-17-2002, 04:19 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I believe xp internetsharing uses NAT, Can anyone confirm this?
bigstar is offline  
Old 01-17-2002, 07:50 PM   #8
Fusion
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 542
Default

Yes, it does. I'll try to dig out the exact text that covers this.
Fusion is offline  
Old 01-17-2002, 08:38 PM   #9
exseven
Member
FlashFXP Registered User
 
Join Date: Dec 2001
Posts: 43
Default

ICS does use NAT

=)

"Internet Connection Sharing (ICS) is a simple package consisting of DHCP, NAT, and DNS"

Page 314 of Windows2000 Network Infrastructure Administration

ISBN 1572319046
exseven is offline  
Old 01-25-2002, 05:24 AM   #10
JS022681
Junior Member
 
Join Date: Jan 2002
Posts: 3
Default NAT

hmm, i c, im wondering, how do u disable ICS, i don't know if i have it enabled, but that could be the solution to my NAT problem as well, thanks
JS022681 is offline  
Old 01-25-2002, 05:39 PM   #11
exseven
Member
FlashFXP Registered User
 
Join Date: Dec 2001
Posts: 43
Default

id one computer connected to another then that computer to the internet?
b/c that would be using ICS
i think its teh only way to use ICS b/c u need 2 i/o devices to use it
exseven is offline  
 

Tags
passive, port21, problem, server, works

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:00 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)