Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 01-17-2004, 07:54 AM   #1
DUde3451
Junior Member
 
Join Date: Jan 2004
Posts: 2
Default Passive mode

Cant connect using passive mode.

FlashFXP v2.1 (924)
Windows 2000


Passive means i must accept connection from internet or what?
How can i check if i can then (But i know i could before)?


SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. But we're in ASCII mode
REST 0
350 Restarting at 0
PWD
257 "/" is your current location
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (194,126,101,78,192,122)
Data Socket Error: Connection refused
List Error
DUde3451 is offline  
Old 01-17-2004, 11:49 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Passive mode
The FTP client connects to the FTP server, this works great if the client is behind a firewall.

Active Mode
If you're not behind a firewall or can configure your firewall to accept incoming connections then you can use Active Mode. Active Mode is sometimes required when the FTP server is behind a firewall.
bigstar is offline  
Old 01-18-2004, 06:37 AM   #3
DUde3451
Junior Member
 
Join Date: Jan 2004
Posts: 2
Default

Well i looked and i think its only that site have problems with passive mode maybe...
But 1 more question when u select to whatever use or dont use passive mode in FlashFXP there is 3 conditions USE / DONT USE / and something when button is not fully pressed, with dark background... what this means?
DUde3451 is offline  
Old 01-19-2004, 03:43 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

grey checkmark means default value from preferences
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-22-2004, 10:42 PM   #5
Nitz
Junior Member
 
Join Date: Jan 2004
Posts: 2
Default

* FlashFXP v2.0, build 905, unregistered
* OS - WinXP
* Running behind NAT/router - Netgear RP614
* Running firewall - No
* Running Antivirus - AVG
* Network - Cable

I'm having the same problem as DUde3451

Quote:
Data Socket Error: Connection refused
I dunno, could I get some actual help as to how I might fix the problem?
I opened port 21 and port 20. I tried binding the sockets to my ip address. I opened every port imaginable and I still can't get it working.

Oh yeah, I tried taking it out of passive mode too but it just says:

Connected to 66.***.***.*** Port 67
220 Serv-U FTP-Server v2.5f for WinSock ready...
USER mason
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX Type: L8
PWD
257 "/c:/program files/abyss web server/htdocs" is current directory.
TYPE A
200 Type set to A.
PORT 192,***,*,*,13,46
530 Only client IP address allowed for PORT command.
LIST
150 Opening ASCII mode data connection for /bin/ls.
426 Data connection closed, transfer aborted.

Any help would be greatly appreciated
Nitz is offline  
Old 01-22-2004, 11:43 PM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

Nitz, you couldn't be possibly be using build 905 unregistred becuase:
1)build 905 is absolete and no longer supported
2)it's been way more than 30days since the release of build 905. so you either must buy flashfxp to continue to use it OR stop using it.
Quote:
I tried binding the sockets to my ip address.
...
PORT 192,***,*,*,13,46
530 Only client IP address allowed for PORT command.
you bound to the wrong adddress. you enteresed your lan ip instead of internet ip.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-23-2004, 08:11 AM   #7
Nitz
Junior Member
 
Join Date: Jan 2004
Posts: 2
Default

Impossible's a pretty big word
First of all:



and



I was always under the impression that a thirty day trial began the day you installed it and ended thirty days later. Which gives me 29 days.

Thanks MxxCon, that fixed my problem. I had tried using my IP assigned address beforehand but I guess I had used it wrong in combination with other options

I'll check back in later about the evaluation thing
Nitz is offline  
Old 01-23-2004, 11:55 AM   #8
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

mxxcon just meant you should really be using the new version...i can't believe you had that old version lying around, or found some place to download it.
Linkster is offline  
Old 01-27-2004, 07:25 AM   #9
dez93_2000
Junior Member
 
Join Date: Jan 2004
Posts: 1
Default same thing

Hi guys. I'm having the same problem as Nitz was. I got my ip from whatsmyip.com & put it in with 'bind sockets to this address' ticked. How do i open ports 20 & 21, and will they do the trick? Cheers all,
Dez

{{EDIT: just tried in the proxies section: set to type 6, input details & set port to either 20 & 21, neither worked. suspect this isn't how you open ports 20 & 21 but i thought i might as well mention i tried it before anyone responds}}
dez93_2000 is offline  
Old 01-28-2004, 08:48 AM   #10
preacher1
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2004
Posts: 4
Default Re: Passive mode

Quote:
Originally posted by DUde3451
Cant connect using passive mode.

FlashFXP v2.1 (924)
Windows 2000


Passive means i must accept connection from internet or what?
How can i check if i can then (But i know i could before)?


SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. But we're in ASCII mode
REST 0
350 Restarting at 0
PWD
257 "/" is your current location
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (194,126,101,78,192,122)
Data Socket Error: Connection refused
List Error
I have a similar problem on my FTP since my host changed their ftp server program:

150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
List Error
QUIT
preacher1 is offline  
Old 01-28-2004, 08:53 AM   #11
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default Re: Re: Passive mode

Quote:
Originally posted by Preacher
I have a similar problem on my FTP since my host changed their ftp server program:

150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
List Error
QUIT
In your case it looks like you're not using passive mode.
In order for me to help you I would need to know details about your internet connection and the 3 lines prior to the lines you posted above.
bigstar is offline  
Old 01-28-2004, 09:50 AM   #12
preacher1
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2004
Posts: 4
Default

This is what I get in Passive Mode:

230-Welcome to the Picture FTP of www.fappin.com
230 User preacher logged in.
SYST
215 Windows_NT version 5.0
CWD \screenshots
250 CWD command successful.
PWD
257 "/screenshots" is current directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (212,130,75,230,11,241).
Data Socket Error: Connection refused
List Error

And this is what I get without Passive Mode:

230-Welcome to the Picture FTP of www.fappin.com
230 User preacher logged in.
SYST
215 Windows_NT version 5.0
CWD \screenshots
250 CWD command successful.
PWD
257 "/screenshots" is current directory.
TYPE A
200 Type set to A.
PORT 10,0,0,2,18,228
500 Invalid PORT Command.
LIST -al
150 Opening ASCII mode data connection for /bin/ls.
425 Can't open data connection.
List Error

I am using Registered FlashFXP 2.1 Build 924
Windows XP Pro
Using the builtin XP firewall (I turned it off and tried logging on, and got the same result)
Antivirus I am using is F-Prot
And I am on ADSL
preacher1 is offline  
 

Tags
ascii, connection, mode, passive, type

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
Deleted Profile On Flash rouil General Discussion 0 04-02-2005 09:03 PM
cant browse a directory MiSiL General Discussion 5 03-11-2005 07:44 AM


All times are GMT -5. The time now is 05:59 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)