Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 09-21-2003, 04:41 PM   #1
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default Possible solution to dropped connections after transfer

I found the following information which may resolve dropped connections which occur after a transfer has completed.


** On Windows NT:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\TcpIp\Parameters\

KeepAliveTime
Key: Tcpip\Parameters
Value Type: REG_DWORD - Time in milliseconds
Valid Range: 1 - 0xFFFFFFFF
Default: 7,200,000 (two hours)
Description: The parameter controls how often TCP attempts to verify that an idle connection is still intact by sending a keep alive packet. If theremote system is still reachable and functioning, it will acknowledge the keep alive transmission. Keep alive packets are not sent by default. This feature may be enabled on a connection by an application.

KeepAliveInterval
Key: Tcpip\Parameters
Value Type: REG_DWORD - Time in milliseconds
Valid Range: 1 - 0xFFFFFFFF
Default: 1000 (one second)
Description: This parameter determines the interval separating keep alive retransmissions until a response is received. Once a response is receive, the delay until the next keep alive transmission is again controlled by the value of KeepAliveTime. The connection will be aborted after the number of
retransmissions specified by TcpMaxDataRetransmissions have gone unanswered.


** On Win 9x, these parameters are to be created under

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VxD\MSTCP

The KeepAliveTime determines how often a keep alive packet is sent to a TCP/IP socks. The default is two hours, which is too long. It is recommended that this value be set between 60000
and 300000 (1 to 5 minutes). Make sure that the "decimal" radio button is selected prior to typing this number into the Data field in the Registry Editor.

You will need to reboot windows for this new setting to take effect.

Please let us know if this solves your problem.
bigstar is offline  
Old 09-29-2003, 01:07 AM   #2
slo_mike
Junior Member
 
Join Date: Feb 2003
Posts: 24
Default

Those registry values don't exist in Windows XP Professional. I searched the entire registry and the only thing I could find similar was a DWORD called KeepAliveTimeout which was already set to 0.
slo_mike is offline  
Old 09-29-2003, 01:11 AM   #3
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

make them yourself.

but just to report to you bigstar that still hasn't helped my problem
MidKnight is offline  
 

Tags
alive, connection, connections, default, keepalivetime

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.7.0 Known bugs darkone Bug Reports 6 12-10-2002 07:21 PM


All times are GMT -5. The time now is 03:10 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)