Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 03-31-2003, 04:43 AM   #1
pascal
Junior Member
 
Join Date: Mar 2002
Posts: 2
Default problem: connecting with ssl through router

I have the problem, that i couldn´t connect to my ftp server with ssl (AUTH-TLS), but only through a router, otherwise (direct dial up) it works! At the router there isn´t any firewall rules installed, only NAT.

thx in advance

ftp client: FlashFXP beta 909 #5
ftp daemon: glftpd 1.29.1_Linux+TLS

status window:
WinSock 2.0
Connecting to xxxxx
Connected to xxxxx -> IP=xxxxx.xxxxx.xxxxx.xxxxx PORT=21
220 xxxxx (glftpd 1.29.1_Linux+TLS) ready.
AUTH TLS
234 AUTH TLS successful
Negotiating SSL/TLS session...
Connection failed (Connection timed out)
pascal is offline  
Old 03-31-2003, 06:16 AM   #2
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

if you trying to connect to yourself, use IP Masq
MidKnight is offline  
Old 03-31-2003, 12:57 PM   #3
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default Re: problem: connecting with ssl through router

Quote:
Originally posted by pascal
I have the problem, that i couldn´t connect to my ftp server with ssl (AUTH-TLS), but only through a router, otherwise (direct dial up) it works! At the router there isn´t any firewall rules installed, only NAT.

thx in advance

ftp client: FlashFXP beta 909 #5
ftp daemon: glftpd 1.29.1_Linux+TLS

status window:
WinSock 2.0
Connecting to xxxxx
Connected to xxxxx -> IP=xxxxx.xxxxx.xxxxx.xxxxx PORT=21
220 xxxxx (glftpd 1.29.1_Linux+TLS) ready.
AUTH TLS
234 AUTH TLS successful
Negotiating SSL/TLS session...
Connection failed (Connection timed out)
Some routers are actively monitoring connections to port 21 (in order to translate PORT commands) It might be that router phreaks out, when it triest to parse ssl handshake. Check your router manual, if there is option to turn the feature off.. or ask the siteop to move site to another port.
darkone is offline  
 

Tags
1.29.1_linux+tls, ftp, problem, router, xxxxx

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ident Server Unable To Listen on port 113 bionic General Discussion 1 10-20-2004 05:33 PM


All times are GMT -5. The time now is 09:05 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)