Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 02-09-2003, 12:44 AM   #1
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Unhappy 425 Can't build data connection: No route to host. and more...

Hey fellas!


As the Subject ses, "425 Can't build data connection: No route to host." is my problem.

First of all, thx to the flashfxp develop team for including my suggestion of a variable Identd Port number to choice, this helped me to get Identd working througth the router!

Again I guess my router is again the problem, so after i connected a server nothing happens or that new error message occures!

Even if I turn off the router firewall and disable any special features flashfxp doesnt list (List -aL) files after i successfully connected.

SmartFTP, the ugly other, does, but why?

REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 192,168,1,235,7,46
200 PORT command successful.
LIST
...
than the client disconnects me cos of a time out and nothing is listed .. !

If anybody can help that might be great.

I already tried active/passive connecting and almost any of the connection/filelisting options, SmartFTP lists files even with List -aL without any delay of time.


... no clue, this got me stuck, ...i already tested an old flashfxp version but this doesnt do either ...and once a time ago it did? !

http://www.longshine.de/produkt/Router/883r-dsl-4f.htm

i guess a "WAN-to-LAN" or "LAN-to-WAN" setting is needed, but even if i turn off firewall it doesn work and SmartFTP does, with a enabled router firewall and a windows firewall!

...windows 2000 pro overhere;



greetings ... and peace not war ;op
ferkel is offline  
Old 02-09-2003, 12:52 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

it's not a bug so
moved to correct forum

paste status log from smartftp and flashfxp to see differences
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-09-2003, 02:40 AM   #3
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Default

50 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
Connecting IP Repeater "repeater.smartftp.com" ...
IP Repeater returned: "xxx.xxx.xxx.xxx"
PORT xxx,xxx,xxx,xxx,x,x
200 PORT command successful.
Opening data connection IP: xxx.xxx.xxx.xxx PORT: 1030.
LIST -aL
150 Opening ASCII mode data connection for directory listing.


btw, someone knows about that repeater.smartftp.com **** thing? damn SmartFTP but it lists files with LIST -aL,
...in ACTIVE MODE, passive doesnt work! ?(

hell

bye thx for help so far
ferkel is offline  
Old 02-09-2003, 04:48 AM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

go to preferences, Proxy/Firewall/Ident tab, check "Bind sockets to this address" and enter your ip there
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-09-2003, 05:49 AM   #5
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Default

hey m8

which one, i enterd my network IP the dhcp server of the router gave me, 192.168.1.235 but still nothing happens, ...

257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 192,168,1,235,12,22
200 PORT command successful.
LIST
421 Timeout (58 seconds): closing control connection.



was that IP correct or the real/external ones or ?

thx so far!
ferkel is offline  
Old 02-09-2003, 06:16 AM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

not your local ip..your 'real/external one'
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-09-2003, 06:36 AM   #7
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Thumbs up

THANKS A LOT IT WORKS! )
ferkel is offline  
Old 02-11-2003, 05:55 AM   #8
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Default damn lol :o)

...hey fella, i rebooted my system ...and now the same damn problem lol:


REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 2xx,xxx,xxx,xxx,6,71 <--- My adsl IP; [x] sockets..
200 PORT command successful.
LIST


nothing happens even if I enabled the [x] bind sockets to this IP (my dynamic adsl ones of course) ...

The connecting to a server works damn fast, less than a sec every connection/auth methods goes by ...but than LIST, and the time out!

I checked again my router and my local firewall, everything seems to be enabled ... I already tried with a diabled firewall and a clean system - nothing works so i bet its a problem with this damn router again.

so far,

greetings.
ferkel is offline  
Old 02-11-2003, 08:51 PM   #9
Jesper
Senior Member
 
Join Date: Dec 2001
Posts: 119
Default

I've seen this issue a couple times, in some cases, it is fixed by telling FFXP that site using NAT/Non routeable IP
Jesper is offline  
Old 02-12-2003, 09:43 AM   #10
ferkel
Junior Member
 
Join Date: Dec 2002
Posts: 13
Default

)

...yea, ok close that topic i did another setup of my system withou tthe router now;

...everything works, ...


thx guys 8)
ferkel is offline  
 

Tags
firewall, list, port, router, time

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:33 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)