Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 12-10-2002, 11:22 PM   #1
kid_a
Junior Member
 
Join Date: Dec 2002
Posts: 4
Angry Cannot get directory listing

Hello,

I can't seem to get a directory listing for my server. I am behind a Linksys router, which I've set to forward port 420 to my computer. Once I try to connect from a remote computer, I can get past everything except the directory listing.
I have turned on Passive Mode and that doesn't work either. What else can I do?

PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 161,38,93,111,15,144
200 Port command successful.
LIST
150 Opening data connection for directory list.
425 Cannot open data connection (10060).
kid_a is offline  
Old 12-10-2002, 11:39 PM   #2
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

are you trying to connect to your own local server?, if so turn on NAT in FlashFXP options for your site
MidKnight is offline  
Old 12-11-2002, 01:51 AM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Why port 420?

The simple solution would be to check passive mode in FlashFXP. Since it's enabled by default I have to wonder why you disabled it?

OR

You need to open a range of ports, depending on your ftp activity the more the better. I recommend starting with 10 and opening more later if needed. When deciding on the port number it must be a port above 1024, most ftp servers will reject attempts from lower port numbers. I use 7000-7010 and that works well for me.

Now that you have the port forwarding configured on the firewall you need to configure FlashFXP. Options -> Preferences > Firewall Tab. Check the option "Limit local port range to" and enter the same range of ports that you entered in your router 7000-7010.

If you still encounter problems you may need to use the "Bind sockets to this address" option, in the address field you need to enter the IP address assigned to you by your isp.
bigstar is offline  
Old 12-11-2002, 02:13 AM   #4
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

Doh!, ignore my post, i never read the first properly, sorry.. anyway bigstar has this one covered
MidKnight is offline  
Old 12-12-2002, 05:22 AM   #5
kid_a
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default

Thanks bigstar I will try that tonight, but the thing is.. I can log in , so connecting is not a problem... I just can't get a directory listing when I try it from my school for example.

However I have a friend across the Pacific who can log in and view files just fine, yet another friend in california gets the same error I do. I think it's something to do with two firewalls...

PS: When passive mode is on it can't get past the "entering Passive mode" command.
kid_a is offline  
Old 12-12-2002, 07:34 AM   #6
aCe2k
Member
FlashFXP Registered User
 
aCe2k's Avatar
 
Join Date: Jun 2002
Posts: 58
Default

That sounds more like the ftp-server is configured with the wrong ip.. as you kindly pasted: 161.38.xx.xxx
If the server is on a LAN then this will cause an error as the local maskin has a unic lan ip like 192.168.x.x and then when you connect using that 161.38.x.x ip, passiv mode isn't able to open a port for that ip. Kinda hard to explain this good, but say the server has 192.168.1.1 and you try to open a passiv mode port using 161.38.xx.xxx:<port>, what your really doing is trying to open a connection with his router and not ftp-server, as the router is the one with the 161.x ip .. and the one trying to figure out what to do with it. If it doesn't know... you'll get a connection failed / timeout error.

But then again.. can this be case here?
Yes, if using Passiv Mode
If using some router/wingate/proxy/firewall application/server then problems like this can allso happen as bigstar stated.

What i do:
Disable everything and try, if it works, aktivate 1 element
Still working, one more.. and so on until something stops working, and you've found you source.
If disabling everything isn't work, then the problem isn't you!
Remeber, even try bypassing your router, and try.
aCe2k is offline  
Old 12-12-2002, 05:47 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally posted by kid_a
Thanks bigstar I will try that tonight, but the thing is.. I can log in , so connecting is not a problem... I just can't get a directory listing when I try it from my school for example.

However I have a friend across the Pacific who can log in and view files just fine, yet another friend in california gets the same error I do. I think it's something to do with two firewalls...

PS: When passive mode is on it can't get past the "entering Passive mode" command.
Sure it does.. It sounds exactly like a firewall problem. FTP uses two connections.

1. Control Connection
2. Data Connection (List / File Transfer)

Obviously you're unable to establish the data connection.
bigstar is offline  
Old 12-13-2002, 11:41 PM   #8
kid_a
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default confusing

My server is behind a router at home, and the connection details I posted in the beginning were from flashfxp i tried at my college. I'm sure they're behind a firewall too. How do I fix this IP issue then?

Many thanks
kid_a is offline  
Old 12-15-2002, 09:17 PM   #9
aCe2k
Member
FlashFXP Registered User
 
aCe2k's Avatar
 
Join Date: Jun 2002
Posts: 58
Default

If the school does have a firewall, then the only thing i can think of is changing port on your ftp-server to like 80 (http) and connect threw that, coz if there is a firewall it's blocking port 21 (ftp)

If the school doesn't have port 21 blocked.. (try ftp://ftp.cdrom.com/ ) to check... if OK, then we can start bugtracking your NAT.
aCe2k is offline  
Old 12-17-2002, 11:26 PM   #10
kid_a
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default

I went there and it works, so port 21 isn't blocked. I've got my server connected to a switch before reaching the router.... does this have anything to do with it? It seemed to work fine before with that configuration but it just stopped all of a sudden.
kid_a is offline  
 

Tags
200, directory, listing, port, set

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP-servers vek General Discussion 1 02-04-2005 08:03 PM


All times are GMT -5. The time now is 07:46 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)