Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 04-03-2002, 04:28 AM   #1
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Exclamation "CPU Hog" ? Only Me ??

Easy Now ... EVERTHING WORKS GREAT BigStar !.

I have 1 issue though.

1. I have a RaidenFTPD install local + zipscript (hate wasting time check if files are ok or not)

2. I have mapped network drives. E: F: G: H: . (10mbit network)

Oki ... when i use FlashFXP to FTP (not xfer) from F: to my local server. It seem FlashFXP cant work fast enough. My computer goes.. boohhaaaaaaaaa .... chewingum feeling. BUT, if i raise its resource priority to "High" then it working "kinda ok", not satified though. ..hmmmm... i hope you understand the part above the "resource priority". (If you rightclick on your taskbar and goto flashfxp when its running. Rightclick on flashfxp and give it higher priority..)


I know infact that this is not only on my computer. tried it on other puter aswell. samesame ..

The stranges thing is that we tried different ftpclient. All of them react the same accept for CuteFTP. Now i Dont want CuteFTP to be the best FTP client in town so thought i let you know...

You prolly wonder why i use FTP but not XFER from the network drive. The speed shows when minimize FlashFXP.

I hope you understans the issue im trying to explain for you.

/Flow
Flow is offline  
Old 04-03-2002, 07:58 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

This wasn't exactly on topic so I have moved it into bug reports.

FlashFXP should almost max out your network connection, on my 100mbit network I get around 8.5mb/sec.

As you stated increasing the piority will speed things up a bit. This speed is much dependent on the cpu usage, By design we hold back a bit to prevent 100% cpu usage. Due to the way this works there is no way to fine tune it. At max speed it uses around 50% cpu on my machine. If cpu time isn't avilaible it will use less.

I have tweaked uploading extensively over the past 30 builds, previously upload speeds were very weak maxing out at around 800KB/sec. I don't think we're going to be able to gain anymore with the current design without locking up the GUI and using 100% cpu.
bigstar is offline  
 

Tags
flashfxp, ftp, local, network, priority

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:25 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)