Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 03-02-2002, 06:25 PM   #1
usurper
Junior Member
 
Join Date: Mar 2002
Posts: 3
Default speed display

The new beta is uploading locally much faster, from 500 to 900 K/s on my lan, but the speed doesn't display right. Glftpd (uploading to it locally) shows 900K/s, and I know the math there is correct =), and the progress bar in flashfxp shows 900K/s too, almost exactly the same as glftpd, but when the file is done, the summary line shows only 700K/s:
Transferred: xxxxxxxx.zip 2,914,692 bytes in 4.93 (723.35 KB/Sec)
usurper is offline  
Old 03-02-2002, 07:49 PM   #2
Fusion
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 542
Default

~700 seems right. No transfer has max-speed on the first byte transferred, the average # simply reflects that.
Fusion is offline  
Old 03-02-2002, 09:25 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

It appears the speed is effected by delays in the transfer complete message (scripts like zip checking)
bigstar is offline  
Old 03-02-2002, 09:35 PM   #4
Shark
Senior Member
FlashFXP Beta Tester
 
Shark's Avatar
 
Join Date: Oct 2001
Posts: 605
Default

Hi Usurper, if your the real one
Shark is offline  
Old 03-02-2002, 09:43 PM   #5
usurper
Junior Member
 
Join Date: Mar 2002
Posts: 3
Angry

bigstar: you're right, it was zipscript - oops

i didn't think such a short delay would result in such a big average speed difference.
usurper is offline  
Old 03-03-2002, 01:13 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

rather than waiting for the "226 " decided to change it to stop the elasped timer on the first line of the reply "226-", so far that doesn't seem to cause any problems.
bigstar is offline  
Old 03-03-2002, 06:39 AM   #7
Ethanol
Member
FlashFXP Registered User
 
Join Date: Feb 2002
Posts: 82
Default Re: speed display

Quote:
Originally posted by usurper

Transferred: xxxxxxxx.zip 2,914,692 bytes in 4.93 (723.35 KB/Sec)
I'm sorry, but I work this out to be 577.36 KB/Sec using the above two figures, and not 723. Even if there were delays imposed, the result should still be calculated from the two values presented (time and bytes)
Ethanol is offline  
Old 03-03-2002, 09:17 AM   #8
usurper
Junior Member
 
Join Date: Mar 2002
Posts: 3
Default

hmm, good point.
I
can't believe that short delay would cause the speed to get as far down as 577K/s though, it's gotta be something wrong with that time displayed. Maybe it counts from the time it issues the STOR command, instead of the time it sends the first byte of the file? But on my lan the latency is almost null, so that still should only make a minor difference.
usurper is offline  
Old 03-03-2002, 12:03 PM   #9
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I've done some tests and each time I get the correct results.

I can't explain why your results differ

KB/S = filesize / 1024 / elapsedtime

The elapsed time doesn't start until it starts sending data.
bigstar is offline  
 

Tags
900k/s, glftpd, shows, speed, uploading

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't let me connect Aingeal General Discussion 2 01-01-2005 05:34 PM


All times are GMT -5. The time now is 03:44 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)