Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 01-12-2002, 06:06 AM   #1
rimvydukas
Junior Member
 
Join Date: Jan 2002
Posts: 5
Exclamation FlashFXP latest beta version and Squid proxy

I took the latest beta version of your software (FFXP 1.4.1 Build 829) because your
official version did not wanted to work with my ISP proxy. As I saw,
this version does not want to work with proxy too My ISP uses
Squid 2.4 as HTTP proxy, and I can't connect to ftp servers through
this proxy with FlashFXP. CuteFTP works without any problems. You've
did great ftp client and I like it very much. Can you help me to
ressolve this problem? Thanks in advance.

Here you go status messages:

Connecting to ftp.btv.lt via Proxy #7
Connected to Proxy proxy.takas.lt Port 8080
<HTML><HEAD>
<TITLE>ERROR: The requested URL could not be retrieved</TITLE>
</HEAD><BODY>
<H1>ERROR</H1>
<H2>The requested URL could not be retrieved</H2>
<HR>
<P>
While trying to retrieve the URL:
<A HREF="ftp.btv.lt:21">ftp.btv.lt:21</A>
<P>
The following error was encountered:
<UL>
<LI>
<STRONG>
Access Denied.
</STRONG>
<P>
Access control configuration prevents your request from
being allowed at this time. Please contact your service provider if
you feel this is incorrect.
</UL>
<P>Your cache administrator is <A HREF="mailto:webmaster@takas.lt">webmaster@takas.l t</A>.
<br clear="all">
<hr noshade size=1>
Generated Sat, 12 Jan 2002 10:58:57 GMT by proxy.takas.lt (Squid/2.4.STABLE3)
</BODY></HTML>
rimvydukas is offline  
Old 01-12-2002, 11:00 AM   #2
exseven
Member
FlashFXP Registered User
 
Join Date: Dec 2001
Posts: 43
Default

its looks as if your squid proxy denied ur access to the ftp for whatever reason

try without the proxy =)
exseven is offline  
Old 01-12-2002, 11:14 AM   #3
rimvydukas
Junior Member
 
Join Date: Jan 2002
Posts: 5
Default

Quote:
Originally posted by exseven
its looks as if your squid proxy denied ur access to the ftp for whatever reason

try without the proxy =)

As I said, I can connect through the same proxy with CuteFTP Pro, Bulletproof FTP without any problems. So think again.
rimvydukas is offline  
Old 01-12-2002, 02:29 PM   #4
exseven
Member
FlashFXP Registered User
 
Join Date: Dec 2001
Posts: 43
Default

well actually
if you look at the error message you got
(stripped of HTML)

--------------


Connecting to ftp.btv.lt via Proxy #7
Connected to Proxy proxy.takas.lt Port 8080
ERROR: The requested URL could not be retrieved

ERROR
The requested URL could not be retrieved
While trying to retrieve the URL:
ftp.btv.lt:21
The following error was encountered:
Access Denied.
Access control configuration prevents your request from
being allowed at this time. Please contact your service provider if
you feel this is incorrect.
Your cache administrator is webmaster@takas.lt
Generated Sat, 12 Jan 2002 10:58:57 GMT by proxy.takas.lt (Squid/2.4.STABLE3)


--------------

to me that says your squid proxy DENIED you
exseven is offline  
Old 01-12-2002, 04:38 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The problem is that your proxy is not configured to allow the CONNECT method which FlashFXP requires. You will need to contact your isp and ask them to enable support. The CONNECT method provides a lot more control over the GET / POST methods and is required to FXP.


Just because other ftp clients work doesn't mean they work the same way. I suspect they don't.
bigstar is offline  
Old 01-12-2002, 05:27 PM   #6
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

You can pass this on to your admin. This must be added to your squid.conf file

acl CONNECT method CONNECT
http_access allow CONNECT

This would also be a good thing to add to the FAQ's
Linkster is offline  
Old 01-12-2002, 07:15 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Yes it sure would. you would not believe how many people have asked me how to enable it. I never knew how.

That information needs to be carved in stone
bigstar is offline  
Old 01-12-2002, 11:19 PM   #8
Fusion
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 542
Default

Duly noted.
Fusion is offline  
Old 01-13-2002, 06:24 AM   #9
rimvydukas
Junior Member
 
Join Date: Jan 2002
Posts: 5
Default

Quote:
Originally posted by bigstar
The problem is that your proxy is not configured to allow the CONNECT method which FlashFXP requires. You will need to contact your isp and ask them to enable support. The CONNECT method provides a lot more control over the GET / POST methods and is required to FXP.


Just because other ftp clients work doesn't mean they work the same way. I suspect they don't.
Is it possible to make FlashFXP to understand GET / POST method?
Because I dont think that my provider will enable this method For
now I'm forced to use CuteFTP but not your nice program Is is so
sad Other FTP clients support both methods without any problems.
rimvydukas is offline  
Old 01-13-2002, 06:21 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

no, we will not be supporting GET / POST
bigstar is offline  
 

Tags
error, proxy, url, version, work

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:05 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)