Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 12-04-2002, 06:43 AM   #1
TerjeMikal
Junior Member
 
Join Date: Dec 2002
Posts: 1
Default Large files causes disconnects

This is a problem I've had since the 1.4 days, but only recently have I discovered what causes it, and I believe it must be a bug in FlashFXP:

If I download or upload files of some size (I believe the problem starts at around 300 - 350MB), FlashFXP will disconnect with message "Connection lost" when that file finishes (causing an immediate reconnect and then skipping retransfer since that file has been completely transferred).

This also happens if I transfer several queued files with a total size greater than the 350MB boundary (it disconnects after the file that crosses that boundary has been transferred).

I've tried this on several different FTP's, and it always happens.

I have only tried this with passive mode, due to my company's firewall.

Using FlashFXP v2.0 Build 902.
TerjeMikal is offline  
Old 12-04-2002, 05:11 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

A firewall/router will manage socket connections and close connections that have been idle for a long period. When the router closes the connection it doesn't inform the client or the server. When the transfer is completed FlashFXP tries to send a command and that's when it determines the connection has been lost.

There really isn't much you can do about it.

FlashFXP does contain an option to help eliminate this problem but reports have shown that in most cases it causes more problems. The options is located at Preferences > Proxy Tab > Send noops during transfer.

If you encounter any new problems you will need to uncheck this option. This option will cause different compatiblity problems depending on the ftp server software.
bigstar is offline  
 

Tags
350mb, file, files, flashfxp, size

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"login incorrect." a bug? jahknee Bug Reports 10 01-29-2003 02:33 PM


All times are GMT -5. The time now is 11:46 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)