Old 09-27-2002, 08:28 AM   #1
Phonetic
Guest
 
Posts: n/a
Exclamation SSL Transfer Speed Bug

I got a very anoying porblem with the latest V2.0 RC3 build (also build 879):

When SSL is enabled (either modes) the transfer speeds drops significantly. (150 kb/s and should be 220 kb/s on my connection).

I tried SSLWrap just to see if it was the FTPD that was causing the problem, and got full speed.

So - it's gotta be something with FlashFXP. I hope you guys fix the problem ASAP - so FlashFXP can be my first choice once again.

I've heard form others that they are experiencing the same problems as I.

Best Regards - And keep up the good work. FlashFXP is still a kick-ass program
 
Old 09-27-2002, 12:29 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I'm not sure why you'd get a slower speed. We haven't toched the SSL code in ages (my motto is if it's not broke don't break it). I'm able to max out my broadband connection both upload & download using SSL.
bigstar is offline  
Old 09-27-2002, 01:07 PM   #3
PeNGuiN
Member
FlashFXP Beta Tester
 
Join Date: Apr 2002
Posts: 69
Default

Well, SSL -does- generate overhead and lots of extra CPU, so you might want to look into that.
PeNGuiN is offline  
Old 09-27-2002, 02:20 PM   #4
Phonetic
Guest
 
Posts: n/a
Default

Yeah I know about the CPU overhead - but servermachine is a P4 2.53 Ghz and client is 2.8 Ghz

Lets all flame Intel

Nah - I think we can rule out the machines geing the problem..

Some of my firends are experiencing the same thing - and others are not. Just seems very strange.
 
Old 09-27-2002, 02:54 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

there is very little cpu overhead in SSL, client side it shouldnt be a problem.
bigstar is offline  
Old 09-29-2002, 10:06 AM   #6
Phonetic
Guest
 
Posts: n/a
Default

But you guys got any idea why speeds with SSL in FlashFXP are so much lower than with other SSL enabled clients?

Can't see that it could be anything but FalshFXP thats causing it...
 
Old 09-29-2002, 01:11 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Nope, I don't have a clue. Like I stated earlier it's fast for me.
bigstar is offline  
 

Tags
build, flashfxp, kb/s, problem, ssl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.7.0 Known bugs darkone Bug Reports 6 12-10-2002 07:21 PM


All times are GMT -5. The time now is 09:39 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)