Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 12-05-2004, 06:00 PM   #1
Castor__
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default Flashfxp Not Using Pasv Ip But Real Ip

here's what i have when connection to a drftpd server with flashfxp 3 and starting a transfer :

[L] PRET RETR de_grote_boze_wolf.wmv
[L] 200 OK, will use Gogo2000 for upcoming transfer
[L] PASV
[L] 227 Entering Passive Mode (172,210,XXX,XXX,247,148).
[L] Opening data connection IP: 212.254.XXX.XXX PORT: 63380
[L] Data Socket Error: Connection refused

PASV replies 172,210,XXX,XXX, but flashfxp uses 212.254.XXX.XXX (wich is the real server ip address)

i didn't check the "Site use ip masq/nat..." in the site option.

for info :
-drftp uses PRET so maybe this is a related bug
-the computer from wich i'm connecting is NATed but this shouldn't involve (i think)
-i don't use proxy

so if you have clues..
Castor__ is offline  
Old 12-05-2004, 06:11 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I did some tests to try and reproduce this behavior and I was unable to.. I'm not sure why it's using the site-ip if the option is unchecked. I see no reason for it to.

BTW are you using 3.0.2 build 1045?
bigstar is offline  
Old 12-06-2004, 03:42 PM   #3
Castor__
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default

no 1044.. what's the problem with 1045 ?
Castor__ is offline  
Old 12-06-2004, 03:47 PM   #4
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

please upgrade to build 1045 and see if the "bug" persists.
Linkster is offline  
Old 12-06-2004, 03:52 PM   #5
Castor__
Junior Member
 
Join Date: Dec 2002
Posts: 4
Default

i have done.. the problem persists :/
Castor__ is offline  
Old 02-18-2005, 04:08 PM   #6
zubov
Junior Member
 
Join Date: Dec 2003
Posts: 7
Default

bigstar, I am one of the drftpd developers.

This is actually a problem with your client but occurs because of a misconfiguration of a drftpd server. What happens is that the main server(master) is NAT'd. The user logs into a server that thinks it's IP is 192.168.x.x. On a LIST command FlashFXP realizes that the server is misconfigured and now disregards the server as having any knowlegde about it's own IP. Now when the user requests a PASV command later in the connection, FlashFXP disregards the response by the server because it assumes it is incorrect once again. However, the server is correct because it is now returning an ip of a slave and it is the correct IP for the connection.

Hope this helps!

zubov
zubov is offline  
 

Tags
connection, flashfxp, pasv, pret, [l]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:43 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)