Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 11-02-2004, 12:26 PM   #1
psyko
Junior Member
FlashFXP Registered User
 
Join Date: Nov 2001
Posts: 5
Default ssl trouble

i have just updated to the latest ffxp version (3.0.2...) and now i get this error:

[L] Connected. Negotiating TLSv1 session..
[L] error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
[L] 425 Can't open data connection.

i never had this error with older versions.

any idea?
psyko is offline  
Old 11-02-2004, 12:49 PM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

use the search function...it works well. Change to AUTH-SSL. Your site doesn't support AUTH-TLS. In older versions, FlashFXP incorrectly issued AUTH-SSL even when AUTH-TLS was selected.
Linkster is offline  
Old 11-02-2004, 01:03 PM   #3
psyko
Junior Member
FlashFXP Registered User
 
Join Date: Nov 2001
Posts: 5
Default

not working. that site supports both, auth-tls and auth-ssl.

i'm using some kind of proxy (modified hpbnc with dynamic target-host) to connect to that site... workx with 3.0.
psyko is offline  
Old 11-02-2004, 02:46 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I'm really not sure, It should work exactly the same compared to v3.0. I didn't make any internal changes to the ssl/tls routines in v3.0.2.. The only change to ssl/tls was to auto close the certificate dialog when the ftp connection is lost.

The change linkster is referring to occured in v3.0 and not 3.0.2
bigstar is offline  
Old 11-02-2004, 03:07 PM   #5
psyko
Junior Member
FlashFXP Registered User
 
Join Date: Nov 2001
Posts: 5
Default

1. reinstalled 3.0 build 1015. works fine.
2. installed 3.0.2 build 1044 again...

[L] PWD
[L] 257 "/" is current directory.
[L] TYPE A
[L] 200 Type set to A.
[L] PROT P
[L] 200 Protection set to Private
[L] PASV
[L] 227 Entering Passive Mode (111,222,333,444,555,66)
[L] Opening data connection IP: 111.222.333.444 PORT: 59220
[L] LIST -al
[L] Connected. Negotiating TLSv1 session..
[L] error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
(soft abort)
[L] ABOR
[L] 425 Can't open data connection.
[L] List Error

psyko is offline  
Old 11-02-2004, 03:54 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Would it be possible to give me access to this ftp server so that I can debug the situation? You can send me a private message with the info.
bigstar is offline  
Old 11-02-2004, 04:07 PM   #7
redpoint
Junior Member
 
Join Date: Aug 2003
Posts: 12
Default

Interesting, I can confirm this bug. Usually I don't use hpbnc, but I tested this now. I found a couple of versions in my backups.

It works with a version 3.0 Build 1010 RC4.

It does not work with 3.0.1.1039
It does not work with 3.0.2 build 1044

Maybe it's possible for the developers to test with hpbnc. It's called "hpbnc.v1.5 test2".

Ftp server is glftpd.
redpoint is offline  
Old 11-02-2004, 05:24 PM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I have no way of testing this setup. If someone can provide me with a test site I can look into this further.
bigstar is offline  
Old 11-03-2004, 06:42 PM   #9
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

Looks a bit like this:

http://forum.flashfxp.com/showthread...&threadid=4671

(which still is a major problem)
djrob is offline  
Old 11-03-2004, 08:29 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Actually this bug has nothing to do with ssl. There is a bug in the proxy support (except types socks/http) in v3.0.2.. We will be releasing an update very soon to address this issue.
bigstar is offline  
Old 12-01-2004, 05:04 AM   #11
MadCowFred
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2004
Posts: 2
Default

I'm having the same issue, but with a PureFTPd server. Not sure if older FlashFXP versions work, though. lftp (UNIX client) can connect fine. I can make a test account available if you need one

FlashFXP v3.0.2 (build 1045)
PureFTPD v1.0.20

[L] 200 PORT command successful
[L] LIST -al
[L] Connected. Negotiating TLSv1 session..
[L] 150 Connecting to port 10153
[L] error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
[L] error:14095044:SSL routines:SSL3_READ_N:internal error
MadCowFred is offline  
Old 12-01-2004, 09:17 AM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Is this a public site that we can test?
bigstar is offline  
Old 12-01-2004, 09:23 AM   #13
MadCowFred
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2004
Posts: 2
Default

Just enabled anonymous, ftp://zort.madcowdisease.org
MadCowFred is offline  
Old 12-01-2004, 10:31 AM   #14
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

There appears to be a problem with FlashFXP

The server is returning an error indicating a secure data connection is not allowed or supported and FlashFXP is not taking this into consideration and trying to establish a secure connection anyways.

[08:25:41] 250 OK. Current directory is /
[08:25:41] PWD
[08:25:41] 257 "/" is your current location
[08:25:41] TYPE A
[08:25:41] 200 TYPE is now ASCII
[08:25:42] PROT P
[08:25:42] 534 Fallback to [C]

In this case FlashFXP should revert to unsecure mode for the data connection.

Thank you for your bug report, this will be resolved in the next release.
bigstar is offline  
Old 12-03-2004, 05:18 PM   #15
Fifer
Junior Member
FlashFXP Registered User
 
Join Date: May 2004
Posts: 3
Cool hi

hi , exact same problem here , glad you you are already on the case. Just wanted to know if there is a temp soloution to this niggling bug ?

Thanks for youre kind assistance.






P.S a Happy Flash fxp user
Fifer is offline  
 

Tags
425, error, version, versions, [l]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fxpiing in though a server with limitations zoranb General Discussion 3 05-18-2005 04:22 PM
sock problem Gip Bug Reports 1 01-26-2003 01:01 PM


All times are GMT -5. The time now is 01:59 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)