Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 11-01-2004, 08:35 PM   #1
spec1alk
Junior Member
 
Join Date: Nov 2004
Location: Bozeman, MT
Posts: 14
Default file exists - Same does not work on ascii files

* FlashFXP v[3].[02], build [1044], [X]registered, [ ]unregistered, [ ]pirated (LOL)
* OS [ ] WinXP, [X] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [X] Yes & Model [actiontec], [ ] No, [ ] Not sure
* Running firewall [X] Yes, Name [uknown], Ver. [uknown], or [ ] No
* Running Antivirus [X] Yes, Name [Symantec 9.x] or [ ] No
* Network [X] xDSL, [ ] CABLE, [ ] Dail-Up, [ ] Other

* FTP server(s) name [Pure-FTPd [TLS]], version [uknown]
* timestamped, and side prefixed FTP log (please paste)
* any other info

I tried searching for an answer, but did not find one.

Ill paste the ftp log in another post to keep it clean.

Problem:
I am using flashfxp to, in essence, perform a backup of my website every morning at 1am. I have an elaborate set of batch files setup perform these backup tasks.

I am launching flashfxp like this:
<path_to_fxp>\flashfxp.exe -tray -c4 -go -logfile=%ftplog% %ftpqfile%

%ftplog% = path my my fxp log file
%ftpqfile% = path to a fxp queue file I have created that backs up the public_html directory and a util directory on my site.

The problem is this, binary files like images, zips, swf work fine. If they are not updated, they are not downloaded/overwrite local copy. However, html, css, txt, php, shtml, etc are downloaded even if they have not changed.

I have set my file exists rules to be like this:
Same = skip
larger/smaller = overwrite

For some reason the server seems to be reporting the files sizes wrong. I do not know if this is linked with the ascii filter but it appears so far that the files affected by this false filesize problem are all in the ascii filter list.

What I want is the File Exists rules to work correctly. I want files that are the same to be skipped and files that are of different sizes to be overwritten with the file from the ftp site.
spec1alk is offline  
Old 11-01-2004, 08:39 PM   #2
spec1alk
Junior Member
 
Join Date: Nov 2004
Location: Bozeman, MT
Posts: 14
Default

ok, I tried to post the log in here but its too big(2mb).

Ill just post the beggining of it. If you would like the whole log, please pm me with an email address that I can send it to.

Code:
*** Log Opened: 10/31/2004 1:02:54 AM
WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[R] Connecting to Nooblink.com -> DNS=ftp.nooblink.com IP=63.247.82.90 PORT=21
[R] Connected to Nooblink.com
[R] 220---------- Welcome to Pure-FTPd [TLS] ----------
[R] 220-You are user number 2 of 50 allowed.
[R] 220-Local time is now 07:02. Server port: 21.
[R] 220-This is a private system - No anonymous login
[R] 220 You will be disconnected after 15 minutes of inactivity.
[R] USER ryan
[R] 331 User ryan OK. Password required
[R] PASS (hidden)
[R] 230-User ryan has group access to:  ryan    
[R] 230-This server supports FXP transfers
[R] 230 OK. Current restricted directory is /
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R]  EPRT
[R]  IDLE
[R]  MDTM
[R]  SIZE
[R]  REST STREAM
[R]  MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[R]  MLSD
[R]  ESTP
[R]  PASV
[R]  EPSV
[R]  SPSV
[R]  ESTA
[R]  AUTH TLS
[R]  PBSZ
[R]  PROT
[R] 211 End.
[R] CWD /public_html/
[R] 250 OK. Current directory is /public_html
[R] PWD
[R] 257 "/public_html" is your current location
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,173,36)
[R] Opening data connection IP: 63.247.82.90 PORT: 44324
[R] LIST -al
[R] 150 Accepted data connection
[R] 226-Options: -a -l 
[R] 226 23 matches total
[R] List Complete: 1 KB in 1.81 seconds (0.8 KB/s)
[R] TYPE I
[R] 200 TYPE is now 8-bit binary
[R] Skipping: .htaccess
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,176,25)
[R] Opening data connection IP: 63.247.82.90 PORT: 45081
[R] RETR 401.shtml
[R] 150 Accepted data connection
[R] 226-File successfully transferred
[R] 226 0.063 seconds (measured here), 13.52 Kbytes per second
Transferred: 401.shtml 925 bytes in 0.13 seconds (6.9 KB/s)
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,203,133)
[R] Opening data connection IP: 63.247.82.90 PORT: 52101
[R] RETR 404.shtml
[R] 150 Accepted data connection
[R] 226-File successfully transferred
[R] 226 0.034 seconds (measured here), 22.32 Kbytes per second
Transferred: 404.shtml 813 bytes in 0.09 seconds (8.8 KB/s)
[R] CWD /public_html/cgi-bin/
[R] 250 OK. Current directory is /public_html/cgi-bin
[R] PWD
[R] 257 "/public_html/cgi-bin" is your current location
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,133,30)
[R] Opening data connection IP: 63.247.82.90 PORT: 34078
[R] LIST -al
[R] 150 Accepted data connection
[R] 226-Options: -a -l 
[R] 226 8 matches total
[R] List Complete: 507 bytes in 0.93 seconds (0.5 KB/s)
[R] TYPE I
[R] 200 TYPE is now 8-bit binary
[R] Skipping: cgiecho
[R] Skipping: cgiemail
[R] Skipping: contact
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,38,122)
[R] Opening data connection IP: 63.247.82.90 PORT: 9850
[R] RETR entropybanner.cgi
[R] 150 Accepted data connection
[R] 226-File successfully transferred
[R] 226 0.063 seconds (measured here), 47.31 Kbytes per second
Transferred: entropybanner.cgi 2 KB in 0.11 seconds (27.0 KB/s)
and here is the end:

Code:
[R] PASV
[R] 227 Entering Passive Mode (63,247,82,90,167,164)
[R] Opening data connection IP: 63.247.82.90 PORT: 42916
[R] RETR uptime-chaos.pl
[R] 150 Accepted data connection
[R] 226-File successfully transferred
[R] 226 0.116 seconds (measured here), 21.14 Kbytes per second
Transferred: uptime-chaos.pl 2 KB in 0.17 seconds (15.0 KB/s)
[R] Skipping: uptime.key.txt
Transfer queue completed
Transferred 2,706 files totaling 20.18 MB in 2 hours 16 minutes 33 seconds (28.8 KB/s)
Skipped 8,849 files
[R] QUIT
[R] 221-Goodbye. You uploaded 0 and downloaded 20113 kbytes.
[R] 221 Logout.
[R] Logged off: Nooblink.com
*** Log Closed: 10/31/2004 2:19:30 AM
spec1alk is offline  
Old 11-01-2004, 10:47 PM   #3
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,830
Default Re: file exists - Same does not work on ascii files

Quote:
Originally posted by spec1alk
For some reason the server seems to be reporting the files sizes wrong. I do not know if this is linked with the ascii filter but it appears so far that the files affected by this false filesize problem are all in the ascii filter list.
they are not exactly wrong size.
text files on windows and *nix systems stored slightly differently.
one of them has <cr> and other <lf><cr> at the end of each file(don't remember which is which).
that is why 'ascii transfered' file size on a remote system is different from local.
you can force to trasnfer them as binary too, so they will have same size, however if such case you can end up with files that have extra line feeds or no line feeds.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 11-01-2004, 11:23 PM   #4
spec1alk
Junior Member
 
Join Date: Nov 2004
Location: Bozeman, MT
Posts: 14
Default

so what do you recommend?

I think its stupid to transfer 2700 files that most of which havent changed.
spec1alk is offline  
Old 11-02-2004, 11:38 AM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,830
Default

try to transfer text files as 'bin' and see if they look correct on your site and/or localy. if they do then problem is solved
otherwise, short of using soft designed specially for site synchronization, and wait until flashfxp is more capable in this area, i can't think of a solution(i could be wrong tho)
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 11-02-2004, 12:34 PM   #6
spec1alk
Junior Member
 
Join Date: Nov 2004
Location: Bozeman, MT
Posts: 14
Default

I saw another thread on these forums where the exists rules had a time modified condition. In other words, if the file on the server and the client were modified on the same date/time then the file is skipped. Otherwise overwrite.

Since you can specify in the options for flashfxp to use the created date/time of the source file then this condition would work for me.

It was stated that this feature request is on the todo list(and has been for a couple years). Do you have any idea when it might be implemented?

Thank you, I love your product.
spec1alk is offline  
 

Tags
file, files, flashfxp, ftp, fxp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:12 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)