Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 10-03-2004, 11:54 AM   #1
Joker
Senior Member
 
Join Date: Jul 2002
Posts: 182
Default b1038 timeout problems.

After upgrading to 1038 from 1031 ive experienced that i get the timeut error every time. Ive went back using my flashfxp.exe.bak in the backup dir and the problem dissapered.
Then used the 1038b of flashfxp.exe and the problem occured again.

This only happens when i dl to my harddrive, not when i fxp.
So it definetly has to do with it.

[18:52:57] [R] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,17,205)
[18:52:57] [R] PORT zzzz,zzz,zzz,zzz,12,214
[18:52:57] [R] 200 PORT command successful.
[18:52:57] [R] RETR xxxx.rar
[18:54:27] [R] 421 Timeout (90 seconds): closing control connection.
[18:54:27] [R] Transfer Failed!
[18:54:27] [R] Connection lost: xxxxxxxxxx
[18:54:29] [R] Attempting to Reconnect.
[18:54:30] [R] Connecting to xxxxxxxxxx

Then it transfers 2 files good, and then it doesnt even start to dl the third one just reaches to the RETR command and times out.

Running on winxp pro sp2, zone alarm as firewall (fully configurated and no logs bout blocked connections), kasperskys antivirus 5,0
And i have a cable connection, no router or anything.

As i said this doesnt occur with the build 1031.
And this happens on 2 sites that ive tried on.
Joker is offline  
Old 10-03-2004, 12:19 PM   #2
Hetfield
Senior Member
FlashFXP Scripter
 
Join Date: Nov 2002
Posts: 334
Default

Maybe you need to enable "send noops during transfer"?
Hetfield is offline  
Old 10-03-2004, 12:30 PM   #3
Joker
Senior Member
 
Join Date: Jul 2002
Posts: 182
Default

i havent touched any settings at all.
But it seems like b1038 changed my settings and disabled noop (among other settings when i looked now).
Because ive always had send noop during transfer as checked.

Anyways the same test was made on b1031 with the send noops disabled also and no timeout problems there with that enabled or not.

Ok. checked that setting on b1038 and it works good now.
Joker is offline  
Old 10-03-2004, 12:36 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Both builds 1031 and 1038 read the exact same values for these settings. This value shouldn't have changed itself as no code exists to do so. I simply can't explain this behavior.

The only value we changed in between 1031 and 1038 was the upload packet size, If you were using the default value of 4k it is updated to 8k. No other values should be changed.
bigstar is offline  
Old 10-08-2004, 11:58 PM   #5
LordOfLA
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 5
Default

I have this error as pasted by Joker as well.

My question is why does FlashFXP issue PASV adn then follow that with PORT???

if we are performing a passive mode transfer port inst needed.

the port command results in a b0rked trasfer as you can see from jokers paste:

Quote:
[18:52:57] [R] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,17,205)
[18:52:57] [R] PORT zzzz,zzz,zzz,zzz,12,214
[18:52:57] [R] 200 PORT command successful.
If you stop the PORT command after PASV the timeout will go away.

HTH
LordOfLA is offline  
Old 10-09-2004, 10:03 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

This problem should be solved in build 1039, Please let me know if it's not.
bigstar is offline  
Old 10-09-2004, 04:09 PM   #7
LordOfLA
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 5
Default

yeah it is thanks
LordOfLA is offline  
 

Tags
connection, fxp, [185257], [185427], [r]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:08 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)