Old 08-22-2004, 03:11 AM   #1
Unplugged
Junior Member
 
Join Date: Aug 2004
Posts: 3
Default Local Port Range

* FlashFXP v[3].[0], build [1015],[*]unregistered
* OS[*] WinXP + SP 1
* Running behind NAT/router[*] No
* Running firewall[*] Yes, Name [Sygate Personal Firewall], Ver. [5.5], Build [2364]
* Running Antivirus[*] No
* Network[*] CABLE


General Problem:
In The Connection-Tab {Preferences}, I've set up "Limit Local Port Range to : 2000 - 2100".
But every time, I'm using the active connection "PORT", the local ports are not within this Range, for example:
PORT ***,***,137,18,7,211
PORT ***,***,137,18,7,212
Unplugged is offline  
Old 08-22-2004, 03:57 AM   #2
ND-
Senior Member
FlashFXP Beta Tester
 
Join Date: Dec 2001
Posts: 185
Default

In the first instance the port is 2013, which is with your range.

The port isn't visible in "plain text".
It takes the last two numbers (7 and 221) and converts them to binary (00000111 and 11011101). It then connects them to one long string (0000011111011101) and converts it back to "normal" numbers (2013).

The second is 00000111 + 11010100 = 0000011111010100 -> port 2004.

I'm not entirule sure this is right, so if anyone wants to correct me, go for it.
ND- is offline  
Old 08-22-2004, 05:03 AM   #3
Unplugged
Junior Member
 
Join Date: Aug 2004
Posts: 3
Default

possible you're right, but my firewall tolds me, when the List-Command is used, then it uses
Remote-Port : 20
local Port: 500x

Is that normal?
Unplugged is offline  
Old 08-22-2004, 09:45 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,857
Default

if that is normal, you'll have to take it up with your firewall...
ffxp is telling that server to connect to a given port...if the server was connecting to any other port, you wouldn't get file list. so i'm pretty sure your firewall is wrong, or it's showing something else beside ftp session
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 08-23-2004, 03:57 AM   #5
Unplugged
Junior Member
 
Join Date: Aug 2004
Posts: 3
Default

I've set up to this port range full access (TCP, both directions). When I disable the Firewall, then it works fine.
I took a look at the packet protocol of the firewall to check, which requests were blocked. The requests within the port range don't have been blocked, but I found one blocked request of the FTP-Server I tried to connect. This was the connection on Port 500x, so I'm sure it's the data connection for the LIST-command. Is there a special port range for LIST?

Any ideas what to do? Normally I use PASSIVE without prolems, but some FTP-server don't allow passive, therefor I need the ACTIVE-session too :-/

Edit:
I saw, that different FTP-server always used ports of 5001++, so I allowed access for this range and it works now fine. I don't know, why the FTP-server don't uses the given port range
Unplugged is offline  
 

Tags
flashfxp, local, port, range, running

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:38 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)