Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-28-2004, 08:50 PM   #1
tacker
Junior Member
 
Join Date: Dec 2004
Posts: 3
Default FXP : hanging by [01:54:30] [R] STOR lala.rar

heyho,

first - i'm a german speaking person and so i can't speak english very well but i hadn't found a good germanspeaking supportforum for FlashFXP!

infos:
- FlashFXP v3.0 build1015
- OS: windowsXP professional with SP2

the problem is that when i want to fxp from server-to-server Flashfxp stopps by this part :

[01:54:28] [L] TYPE I
[01:54:28] [L] 200 Type set to I.
[01:54:28] [R] TYPE I
[01:54:28] [R] 200 Type set to I.
[01:54:29] [R] PASV
[01:54:29] [R] 227 Entering Passive Mode (xxx,xxx,130,146,128,87)
[01:54:29] [L] PORT xxx,xxx,130,146,128,87
[01:54:30] [L] 200 PORT command successful
[01:54:30] [R] STOR lala.exe
[01:54:35] [L] RETR lala.exe

the two servers are 100% fxpable becausee other people could send files between this two servers!

the two servers are online on port 21 ( 21 --> 21 ) and i don't know which options i must to set that i can send files via fxp!



by servers with other portconstellations it's no problem ! :

1. server with port21 --> server with port7453 (for example - i think with all ports exclusive port21)

source- and targetserver hadn't any special options by connect !

--> NO PROBLEM

2. server with port7453 (for example - i think with all ports exclusive port21) --> server with port7453 (for example - i think with all ports exclusive port21)

source- and targetserver hadn't any special options by connect !

--> NO PROBLEM

3. server with port7453 (for example - i think with all ports exclusive port21) --> server with port21

sourceserver hadn't any spcial options enabled by connect!
targetserver had "alternative FXP method downloading and uploading" enabled <-- options i'd founding by testing !

--> NO PROBLEM



-> problem exists only when i want to transfer files from a server with port 21 to a server with port 21 too...


i hope you understand my problem and could help !

thx tacker`
tacker is offline  
Old 12-28-2004, 10:17 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

sounds like your router is screwing up fxp trasnfers.
you have 3 soluctions:
remove router
use SSL, which will make control connection encrypted, so your router can't monitor it.
if you are registred use, you can download latest beta of flashfxp which has a trick to enable fxp on port 21.
otherwise you'll have to wait for the next public release.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 12-29-2004, 05:30 AM   #3
tacker
Junior Member
 
Join Date: Dec 2004
Posts: 3
Default

morning,

thx for the fast answer !

something i don't understand : what do you mean with this part "sounds like your router is screwing up fxp trasnfers." ? that i must forwarding some ports to the client ? or don't take this any effects ? my router is a zyxel 642ME-I - i know it's a bull**** from a router ...


to the 3 solutions :

- it's impossible to remove the router - but could it help when i buy a new router ?!?

- i haven't got control to the two server's so i think it's impossible to enable SSL ?!? i can't do this only with a setting in FlashFXP ?

but it could be the solution because when i transfered files from port=!21 --> port21 then i connected with SSL to the sourceserver with the port which's noch 21 ! EDIT : ok that's not the problem it functions without SSL, too

- i'm not special registred so i think i haven't got the possibility to download the beta -> waiting ! or which name has got the latest beta version ?

thx tacker`
tacker is offline  
Old 12-29-2004, 07:20 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

forwarding ports will not help.
your router does NATP, which means when it sees PORT command with any ip address, it always changes that ip to YOUR ip. it is useful for regular downloads, but completly destroys ability to FXP.
the reason why it other ports work is becuase your router only monitor port 21 for ftp commands, not other.

getting new router will help(as long as it doesn't do the same thing).

or you could just buy flashfxp and have access to latest betas
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-01-2005, 02:15 PM   #5
tacker
Junior Member
 
Join Date: Dec 2004
Posts: 3
Default

heyho !

i'd found a solution for my problem on the board so now i could transfer files via fxp also on port 21 ! the solution is to insert "FxpNatTrick=1" in the flashfxp.ini ! could it be that that will be the new feature in the latest beta ?

thx for help!

tacker`
tacker is offline  
Old 01-01-2005, 03:13 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

We've done some testing with this feature and we have found that it isn't compatible with some ftp servers/hardware. Due to the limited compatiblity of this solution I'm not sure if it will become a GUI setting.

Off hand I know it's not compatible with RaidenFTPD.
bigstar is offline  
Old 01-01-2005, 06:03 PM   #7
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

Quote:
Originally posted by tacker
the solution is to insert "FxpNatTrick=1" in the flashfxp.ini ! could it be that that will be the new feature in the latest beta ?
yes that is the feature, and like bigstar mentioned above, there are some compatability issues..
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-01-2005, 11:51 PM   #8
Uradox
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Aug 2004
Posts: 37
Default

Quote:
Originally posted by MxxCon
forwarding ports will not help.
your router does NATP, which means when it sees PORT command with any ip address, it always changes that ip to YOUR ip. it is useful for regular downloads, but completly destroys ability to FXP.
I had simular problems once with fxp and all mine were solved by enabling dmz on the router which i think is the same thing as your described with NATP (im not very knowlegable with networking) wouldnt this also fix this mans problems?
Uradox is offline  
Old 01-02-2005, 01:42 AM   #9
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

it might fix the problem, however for many/most it isn't a solution or even an option becuase dmz opens another can of security "worms".
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-02-2005, 08:31 AM   #10
Uradox
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Aug 2004
Posts: 37
Default

ah ok hope im safe
Uradox is offline  
Closed Thread

Tags
flashfxp, fxp, port21, server, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
Transfer failed "[R] 501- ==YOU'RE BEHIND A NAT ROUTER==" error ardenj General Discussion 2 01-18-2005 11:40 PM


All times are GMT -5. The time now is 04:00 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)