Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 11-18-2004, 12:12 AM   #1
Kar Laeda
Junior Member
 
Join Date: Nov 2004
Posts: 3
Default Passive mode vs Active and [R] Opening data connection IP: xxx PORT: 1385

[R] Opening data connection IP: xxx PORT: 1385

port itself is not open by the router, 1201 is tho, passive mode just keeps on trying different ports every time, how do I set it up? And every time I switch to active mode i dont even see folders/files when i finally connect, yes i have permissions etc.

Any ideas?
Kar Laeda is offline  
Old 11-18-2004, 12:41 AM   #2
Kar Laeda
Junior Member
 
Join Date: Nov 2004
Posts: 3
Default

[R] Connecting to xxx -> IP= xxx PORT=21
[R] Connected to xxx
[R] 220 Serv-U FTP Server v5.2 for WinSock ready...
[R] USER Cant-tell-ya
[R] 331 User name okay, need password.
[R] PASS (hidden)
[R] 230 User logged in, proceed.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extension supported
[R] CLNT
[R] MDTM
[R] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[R] SIZE
[R] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[R] REST STREAM
[R] XCRC filename;start;end
[R] MODE Z
[R] 211 End
[R] CLNT FlashFXP 3.0.1015
[R] 200 Noted.
[R] CWD /c:/
[R] 250 Directory changed to /c:
[R] PWD
[R] 257 "/c:" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,100,5,130)
[R] Opening data connection IP: xxx PORT: 1410
[R] Data Socket Error: Connection timed out
[R] List Error

well this is it, all behind linksys router, and this is what happens when switched to active mode:

WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[R] Connecting to xxx -> IP=xxx PORT=21
[R] Connected to xxx
[R] 220 Serv-U FTP Server v5.2 for WinSock ready...
[R] USER Cant-tell-ya
[R] 331 User name okay, need password.
[R] PASS (hidden)
[R] 230 User logged in, proceed.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extension supported
[R] CLNT
[R] MDTM
[R] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[R] SIZE
[R] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[R] REST STREAM
[R] XCRC filename;start;end
[R] MODE Z
[R] 211 End
[R] CLNT FlashFXP 3.0.1015
[R] 200 Noted.
[R] PWD
[R] 257 "/c:" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] Resolving DNS: xxx
[R] Resolved: xxx
[R] PORT xx,xx,xxx,xx,4,176
[R] 200 PORT Command successful.
[R] LIST -al
[R] 150 Opening ASCII mode data connection for /bin/ls.
[R] Connection lost: xxx

I appologize for "xxx" marks....:P but server is not mine and i dont want to yell about it.
Kar Laeda is offline  
Old 11-18-2004, 01:03 AM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Is the ftp server properly configured to allow passive mode?
If it is try checking "use site ip for passive mode connections" in the Site Manager / Options tab

Are you behind a router? If you are you need to forward the proper ports to use active mode. Also set the port range in FlashFXP within your allowed incoming range.
bigstar is offline  
Old 11-18-2004, 01:30 AM   #4
Kar Laeda
Junior Member
 
Join Date: Nov 2004
Posts: 3
Default

Quote:
s the ftp server properly configured to allow passive mode?
Yes it is.

Quote:
Are you behind a router? If you are you need to forward the proper ports to use active mode.
The client is not behind a router altho, the server is, when i just connected to it this evening, had to ask a friend to open up ports 1200-1299 for me but then as i reconnected the port number in passive mode used went up to 1400, and i cannot allow those ports to be open as it is not my server.

Quote:
Also set the port range in FlashFXP within your allowed incoming range.
Only found that option for active mode, is there one for passive? If there is can you point it out for me please?

Oh one more thing, i did connect and see all the folders succesfully until the passive mode started using ports for opening data connection beyond 1300.
Kar Laeda is offline  
Old 11-18-2004, 02:03 AM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,861
Default

Quote:
Originally posted by Kar Laeda
Only found that option for active mode, is there one for passive? If there is can you point it out for me please?

Oh one more thing, i did connect and see all the folders succesfully until the passive mode started using ports for opening data connection beyond 1300.
you can't. when you send PASV command, you ask SERVER for ip and port to connect TO.
you don't need to open ports for that..unless your firewall is blocking outgoing connection TO ports(highly doubt it)

Quote:
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,100,5,130)
according to that reply, that server is misconfigured for internet connections.
tell site's admin to fix it.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
1385, mode, passive, port, time

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
Transfer failed "[R] 501- ==YOU'RE BEHIND A NAT ROUTER==" error ardenj General Discussion 2 01-18-2005 11:40 PM


All times are GMT -5. The time now is 03:29 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)