Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 03-05-2012, 08:01 AM   #1
mrphuzz
Junior Member
FlashFXP Registered User
 
Join Date: Mar 2010
Posts: 9
Default Upload on save

FlashFXP v[4].[2], build [1730], [x]registered, [ ]unregistered, [ ]pirated
* OS [ ] Windows 7, [ ] Vista, [x] WinXP, [ ] Other (specify)
* Running behind hardware router/firewall [x] Yes & Model [not sure], [ ] No, [ ] Not sure
* Running software firewall [x] Yes, Name [not sure], Ver. [ ], or [ ] No
* Running Antivirus [x] Yes, Name [synamtec] or [ ] No
* Internet Connection [ ] DSL, [ ] CABLE, [x] Other(specify) I don't know. Whatever the Marine Corps uses, as I'm on a Marine Corps computer.

Hello,

I just upgraded to v4.2.0.1730 (actually, I'm using the USB Portable version. I'm on a computer that restricts installing applications). Now when I open a remote file for editing and save it, the updated version does not upload. Even if I right-click the entry in the "Active Edits" and click "Upload," it does not upload. I also notice that clicking "Open folder location" and "ReDownload" in that same menu does nothing. "Auto upload on change" is checked. I have tried using the different remote edit options. "Upload" and "Prompt" behave as expected, except that the the updated file does not upload when I click the editor's save button. For "Legacy Prompt," the "Confirm" window is modal and I can't interact with the editor until I close it. When I was using v4.1.8, I did not experience these problems.

I've pasted the transfer log so you can see the connection details.
[R] Connecting to ftp.....com -> DNS=ftp.....com IP=50.xxx.xxx.94 PORT=21
[R] Connected to ftp.....com
[R] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[R] 220-You are user number 2 of 50 allowed.
[R] 220-Local time is now 06:46. Server port: 21.
[R] 220 You will be disconnected after 15 minutes of inactivity.
[R] USER myusername
[R] 331 User myusername OK. Password required
[R] PASS (hidden)
[R] 230 OK. Current restricted directory is /
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R] EPRT
[R] IDLE
[R] MDTM
[R] SIZE
[R] REST STREAM
[R] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNI X.gid*;unique*;
[R] MLSD
[R] AUTH TLS
[R] PBSZ
[R] PROT
[R] ESTA
[R] PASV
[R] EPSV
[R] SPSV
[R] ESTP
[R] 211 End.
[R] PWD
[R] 257 "/" is your current location
[R] CWD /public_html
[R] 250 OK. Current directory is /public_html
[R] PWD
[R] 257 "/public_html" is your current location
[R] PASV
[R] 227 Entering Passive Mode (50,..,..,..,202,24)
[R] Opening data connection IP: 50.xxx.xxx.94 PORT: 51736
[R] MLSD
[R] 150 Accepted data connection
[R] 226-Options: -a -l
[R] 226 58 matches total
[R] List Complete: 6 KB in 0.43 second (6.6 KB/s)
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] PASV
[R] 227 Entering Passive Mode (50,xx,xx,94,202,26)
[R] Opening data connection IP: 50.xx.xx.94 PORT: 51738
[R] RETR about.php
[R] 150 Accepted data connection
[R] 226-File successfully transferred
[R] 226 0.000 seconds (measured here), 264.03 Kbytes per second
Transferred: about.php 20 bytes in 0.01 second (0.0 KB/s)
mrphuzz is offline  
Old 03-05-2012, 12:34 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Are you using an external text editor, if so which application?

It sounds to me like perhaps FlashFXP is not detecting the local temporary file was modified.

If you are not using an external editor I would recommend it and see if that resolves the problem.

You might also try clearing your active edits list if you haven't already done so.

Quote:
I also notice that clicking "Open folder location" and "ReDownload" in that same menu does nothing. "Auto upload on change" is checked.
I am not quite sure what to make of this, I will need to investigate the issue further.

Quote:
For "Legacy Prompt," the "Confirm" window is modal and I can't interact with the editor until I close it.
Thank you, I have determined that is a logic flaw when using the legacy prompt with the built-in editor.
bigstar is offline  
Old 03-05-2012, 04:05 PM   #3
mrphuzz
Junior Member
FlashFXP Registered User
 
Join Date: Mar 2010
Posts: 9
Default

Hello and thanks for your reply.

Quote:
Are you using an external text editor, if so which application?
Yessir, I am using Notepad++. That is when I noticed the problem. So, to troubleshoot, I tried the internal editor, as well as notepad. All have the same effect.

Quote:
You might also try clearing your active edits list if you haven't already done so.
Done. Nothing.

Also, as a side note, I have used this new version only on this WinXP system here at work. I will be using it at home on my Win7x64 system in a couple hours, so I will be able to help determine if this is an OS issue or something else.

UPDATE:
I just got home, and as posted, I'm using WinXP at work (which, if you recall, FFXP v4.1.8's upload-on-save feature worked), and I'm using Win7x64 here at home. I just attempted an upload-on-save, using Notepad++, and it worked.

Additional info: because of the firewalls at work, I am not able to do a regular update via the application, which is why I simply downloaded the USB portable version of v4.2. Therefore, it was a clean "installation," as it were. Here at home, I am able to do the normal application update, and that is what I did. So... yeah. Not sure what else I can say! Please let me know if there is anything else I can do to help fix this problem. For now, I went back to v4.1.8 at work, but would really love to use v4.2. Our network disconnects a lot and v4.2 supposedly fixed some bugs that will really shine for me at work.

Thanks!

Last edited by mrphuzz; 03-05-2012 at 04:49 PM. Reason: Just got home and checked program on home computer
mrphuzz is offline  
Old 03-06-2012, 02:05 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I sent you a private message with a dev build for testing, Please give it a try and let me know if it resolves any of the issues you experienced.
bigstar is offline  
Closed Thread

Tags
connection, flashfxp, ftp, upload, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)