Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 06-30-2007, 08:09 PM   #1
DJAndre
Junior Member
FlashFXP Registered User
 
DJAndre's Avatar
 
Join Date: Mar 2004
Location: San Diego, CA
Posts: 12
Default Data Socket Error: Connection timed out

Hi,

I am new to this forum. But been a registered user for FlashFXP since 2003.

I was wondering if anyone could explain or assist me with this issue I got. When I am doing my monthly backups of my websites. I get "timed out" errors and it's really a drag, since this causes my backup to take a long time to complete.

For instance, I am currently uploading my "backup files" from my computer to a new FTP site. As I am just uploading files, it seems to always get stuck with ports: 28001 and 27909. (It may get stuck with others, but since the window on the lower right gets refreshed quite rapidly, I can't catch all of the ports, if any, that are also getting stuck.) When those ports get stuck, it then generates that the "connection timed out". (see a quote below of the error.)

Quote:
[R] PASV
[R] 227 Entering Passive Mode (67,55,47,84,109,97)
[R] Opening data connection IP: 67.55.47.84 PORT: 28001
[R] Data Socket Error: Connection timed out
[R] List Error
I am hoping to learn if there is anything I can do to fix this, so my backup and transfers get uninterrupted with these errors. (Below in my signature is my system info as stated in your "read me rules". Please let me know if you need more info.)

My level of computer literacy and troubleshooting or following instructions is medium to advance. I am quite a fast learner and I am quite capable of following advance instructions. Thanks in advance.
__________________
My System Info:

App: FlashFXP 4.4.3 (build 2029) [registered]
OS: WinXP Pro
Router: Linksys WRT54G build 5
Firewall: COMODO
Anti-Virus: AVAST
Network: Broadband
ISP: cox.net
DJAndre is offline  
Old 07-01-2007, 05:48 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,813
Default

does it always get stuck when ports are in the range of 27909 - 28001? when transfers work, what ports are in use? same range or higher/lower?

also try to disable PASV mode for that site..it could be that the server is misconfigured and give you port range that it blocked in their firewall.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 07-19-2007, 04:23 AM   #3
DJAndre
Junior Member
FlashFXP Registered User
 
DJAndre's Avatar
 
Join Date: Mar 2004
Location: San Diego, CA
Posts: 12
Default

I did try to disable PASV mode, but after a bit, it started to give me errors in FlashFXP and it wasn't uploading my files, so I had to re-enable it.

Yes, it seems like it just gets stuck for 22 seconds each time it hits those two ports: 27909 and 28001 and then it times out and restarts again.

It doesn't have any problems with the others ones (I just listed a few.. since they are so many):

27915, 27930, 27967, 27936, 27915, 27977, 27959, 27922, 27920, 27948, 27985, 27996, 27945, 27933, 27917, 27998, 27995, 27944, 27991, 28000, 27945, 27983, 27991, 27993, 27947, 27940, 27998, 27922, 27932....

I did contact the host of the server and they say the following (quoted below), But their explanation is a bit over my head. Do you know what they mean and what are the steps I must follow?:

Quote:
The provided non-standard ports are being used on your network connection and you should ask the ISP Administrator about this issue. Regarding to access your account via FTP, the port 21 should be opened on your network connection. As I checked, there is nothing wrong with the FTP service of the server which hosts your account. You can check the standard ports using the telnet command; for example;

telnet 67.55.47.84 21

As a good test, you can check the FTP connection to your website using the following FTP link(replace the login information with Username/Password) to make sure about the correct configuration of FlashFXP;

ftp://USERNAME:PASSWORD@67.55.47.84/

Best Regards,
Canaca-Com Inc.
__________________
My System Info:

App: FlashFXP 4.4.3 (build 2029) [registered]
OS: WinXP Pro
Router: Linksys WRT54G build 5
Firewall: COMODO
Anti-Virus: AVAST
Network: Broadband
ISP: cox.net
DJAndre is offline  
Old 07-19-2007, 12:55 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,813
Default

they did not address your question.
they are talking about connecting to a regular ftp port(also called control connection). you have no problems with that, since you can login to the site just fine.
you are having problem with DATA connection port.
here's basic explanation of how ftp works http://slacksite.com/other/ftp.html
but they did bring up one possibility that your ISP maybe causing this issue.
if you can, connect your computer to another ISP and see if that makes any difference.
also try to temporary disable norton's firewall. make sure it's completly disabled(ie all related services are stopped and stuff). and see if that makes any difference too.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 07-20-2007, 05:43 AM   #5
DJAndre
Junior Member
FlashFXP Registered User
 
DJAndre's Avatar
 
Join Date: Mar 2004
Location: San Diego, CA
Posts: 12
Default

Hi,

I decided to give "disable PASV mode" one more shot. It worked great my second time around. I think the first time it failed, I must have misunderstood it as maybe a problem with the connection to the server or something (normally I like to call it "Internet funkiness" when that happens).

I was able to complete my transfer of my files to the server without any hiccups or delays. I think from now on, I'll just save that setting for that particular site/server to be PASV disabled, so I don't have anymore issues with that site/server.

Million thanks! Consider this problems solved for now...

For another person reading this, the way I am able to disable "Use Passive mode" is by the following steps:
  • first open Site Manager (F4 or Sites > Site Manager) Make sure to save your site under the folder FlashFXP Sites in the right column. (Tip: if its a Quick Connect site, you can drag and drop the site into the FlashFXP Sites folder directory).
  • Click the site on the left column so it gets highlighted.
  • click on the Options tab.
  • make sure to completely uncheck (square shows empty) the following setting: "Use Passive mode".
  • click on Apply.
  • Then you can either close it or click on Connect to go to your site.
  • keep in mind this setting will stay this way until you decide to enable Passive Mode again.

If anyone has a faster or quicker way to do this, please let us know. Thanks in advance.
__________________
My System Info:

App: FlashFXP 4.4.3 (build 2029) [registered]
OS: WinXP Pro
Router: Linksys WRT54G build 5
Firewall: COMODO
Anti-Virus: AVAST
Network: Broadband
ISP: cox.net

Last edited by DJAndre; 07-20-2007 at 05:52 AM. Reason: corrected some misspelling and grammar
DJAndre is offline  
Closed Thread

Tags
error, flashfxp, ftp, stuck, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:41 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)