Go Back   FlashFXP Forums > >

Programming Need help with C/C++/Delphi? Ask here and make us all laugh.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 01-04-2004, 12:17 PM   #1
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default [itcl] mountfile open doesn't work for scheduled scripts

That's the code i use for testing, using ioFTPD 5.4.3r
Code:
set anuke(mtab)	"C:/ioFTPD/etc/default.vfs"

proc autonuke {} {
global anuke
# Load mount table
if {[catch { mountfile open $anuke(mtab) }]!= 0} {return 1}
putlog "TEST: \"/\" is resolved to \"[resolve pwd "/"]\" using \"$anuke(mtab)\""
}
autonuke
That's what i get in ioFTPD.log when i run the script using a site command:
01-04-2004 18:10:11 TEST: "/" is resolved to "C:/ioFTPD/site" using "C:/ioFTPD/etc/default.vfs"

And that's what i get when i use the scheduler:
01-04-2004 18:10:44 TEST: "/" is resolved to "" using "C:/ioFTPD/etc/default.vfs"
Harm is offline  
Old 01-04-2004, 12:36 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Oh, try opening userfile too (i think it requires one)
darkone is offline  
Old 01-04-2004, 12:53 PM   #3
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

Indeed, it has to be:
Code:
if {[catch { userfile open "sitebot" }]!= 0} {return 1}
if {[catch { mountfile open $anuke(mtab) }]!= 0} {return 1}
Thank you darkone.
Harm is offline  
Closed Thread

Tags
autonuke, c/ioftpd/etc/default.vfs, mountfile, resolved, test

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:59 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)