Go Back   FlashFXP Forums > > > >

WarC's scripts ioA, Warchive, ZR-Tools

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-17-2005, 05:41 AM   #46
LordM_2
Member
 
Join Date: Sep 2003
Posts: 66
Default

Got a problem with kick on nuke.

Users don't get kicked on nuke and so Dir isn't renamed. Is this because one of the users has got the M Flag? Or did I do something wrong?

debug Log sais:

Code:
05-16-2005 13:20:38 NUKE - Running kick...start
05-16-2005 13:20:38 NUKE - Running kick...stop. result=0, success
05-16-2005 13:20:39 NUKE - Was unable to rename nuked directory
05-16-2005 13:20:39 NUKE - Flushing cache in: e:\ftp\upload\Tools\[Nuked]-Little.Advisory.to.get.nuked-PPP
05-16-2005 13:20:39 NUKE - Time to run command: 11887ms
the first two lines are there 50 times and then 'was unable to rename...'.

using ioA 2.0.3

Thx for any help
LordM_2 is offline   Reply With Quote
Old 05-18-2005, 05:27 AM   #47
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

Flag should not matter so thats not the problem. I dont really know why it would not work. Only thing I can think of is if a script is locking it. By default ioa tries to rename it 50 times and kick inbetween if not succesful. Does this always happen so its reproducable or is it random? If you can recreate it I would need you to run a special version to check whats happening.
WarC is offline   Reply With Quote
Old 05-27-2005, 03:08 AM   #48
LordM_2
Member
 
Join Date: Sep 2003
Posts: 66
Default

I'll try to reproduce it.
LordM_2 is offline   Reply With Quote
Old 05-27-2005, 07:21 AM   #49
LordM_2
Member
 
Join Date: Sep 2003
Posts: 66
Default

Well, triggered by a user it works fine now. Triggered by nxAutoNuke kick work, but rename not.
LordM_2 is offline   Reply With Quote
Old 07-15-2005, 02:01 PM   #50
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default ioa reqwipe

seems the site reqwipe function dont work..

When i do it nothing happens..

[L] site reqwipe
[L] 200-[REQUESTS] - Current Requests on %Site :
[L] 200- ioA execution time: 0ms
[L] 200 Command successful.

thats all..

filled requests are still there..
zOrP is offline   Reply With Quote
Old 07-15-2005, 07:38 PM   #51
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

The command is site reqwipe [request number]
EwarWoo is offline   Reply With Quote
Old 07-17-2005, 08:17 AM   #52
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default no ?

its not..
that would be site reqdel #nr

shouldn't site reqwipe delete all filled requests?

But doesn't seem to work still.. :/
zOrP is offline   Reply With Quote
Old 07-17-2005, 04:32 PM   #53
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

reqwipe is used by scheduler(usually) to wipe filled requests older than x days.

possible commands:
site request hubba
site reqdel <number>
site reqfilled <number>
site reqwipe
WarC is offline   Reply With Quote
Old 07-18-2005, 10:59 AM   #54
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

hmm..
yes.
but i tried earlier today..

worked fine with site reqwipe

here's the debug.

07-18-2005 17:30:42 REQWIPE - ioA Version: 2.0.3
07-18-2005 17:30:42 REQUESTWIPE - Trying to kick from: F:\REQ\[FILLED]-Some.test.rls
07-18-2005 17:30:42 WIPE - Flushing cache in: F:\REQ
07-18-2005 17:30:42 REQWIPE - Time to run command: 62ms

then i added
reqwipe = 1M

and i cant seem to get it to work.
i just get
[R] site reqwipe
[R] 200-[REQUESTS] - Current Requests on %site:
[R] 200- ioA execution time: 47ms
[R] 200 Command successful.

here's the debug
07-18-2005 17:57:54 REQWIPE - ioA Version: 2.0.3
07-18-2005 17:57:54 WIPE - Flushing cache in: F:\REQ
07-18-2005 17:57:54 REQWIPE - Time to run command: 47ms

i tried to remove
reqwipe = 1M
didn't help..
any ideas of why it suddently dont work ? :-(

btw, tried to add it to scheduler as u said.

Then debug gives me this.

07-18-2005 23:07:28 REQWIPE - ioA Version: 2.0.3
07-18-2005 23:07:28 WIPE - Flushing cache in:
07-18-2005 23:07:28 REQWIPE - Time to run command: 0ms

still no wiping of [FILLED]-req dirs.. :-/
zOrP is offline   Reply With Quote
Old 07-18-2005, 11:15 AM   #55
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

btw.. another question for ioA 2.0.3

I customized my request output like this..

(18:05:50) (@me) !requests
(18:05:52) (@xxx) [REQUESTS] - Current Requests on sitename :
(18:05:54) (@xxx) [REQUESTS] - [ 001:] me at 18-07-2005 ~ test.folder
(18:06:08) (@xxx) [REQUESTS] - If you fill a request, please do !reqfilled <number>

but I was wondering.
Is it possible to customize so the request is not the last part ?
i tried to add the time after, but then when i reqfill the folder dont rename and it makes a mess.. :-(

Any ideas ?
zOrP is offline   Reply With Quote
Old 07-18-2005, 04:36 PM   #56
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

by just adding who can use the commnad can't have anything to do with if reqwipe works or not, must be something else. ioA dont know anything about who can use it or not. You sure you didnt change any of the ioa.cfg settings also?

on format of request it depends on exacly how your requestline is formatted in ioa.cfg. if you only use %request (ie not limitiing the length) and then date after it will go banana I'm sure. There are limitations on how it can look.
WarC is offline   Reply With Quote
Old 07-19-2005, 06:29 AM   #57
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

ahh.. so i can limit the lengh of %request.
how do i do that ?

this is my request line :

Request_Line = "[REQUESTS] - [ %##:] %-10user at %D-%M-%Y ~ %request"

is it possible to make like this

Request_Line = "[REQUESTS] - [ %##:] %request ~ by %-10user at %D-%M-%Y"
and still have the reqdel reqfilled work.
and of course have the rename to filled work ?

for example if it was possible to make a
Request_Field = " :] "
and
Request_Field_end = " ~ "
zOrP is offline   Reply With Quote
Old 07-19-2005, 06:44 AM   #58
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

limiting %request you do the same way as you limited userlength. %-30request or something like that.
I havnt tested all possible ways of formatting therefor not 100% it will work as you want. I'll see if I can find some time and do some tests.
WarC is offline   Reply With Quote
Old 07-19-2005, 07:01 AM   #59
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

i just tried with
Request_Line = "[REQUESTS] - [ %##:] %-65request ~ by %-10user at %D-%M-%Y"

but its still ****ed..

the announce works fine.
bot for make request and for !requests

but u cant reqfill or reqdel..
so i was thinking if it was possible to make a
Request_Field_end = " ~ "
so the script would know its only the thing between ]: and ~

cause the other way script thinks its everything after ]:
thats why reqdel / filled dont work there..
zOrP is offline   Reply With Quote
Old 07-19-2005, 07:04 AM   #60
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

and for the reqwipe thing.. where do i set the request section.

cause scheduler gave me this back

07-18-2005 23:07:28 REQWIPE - ioA Version: 2.0.3
07-18-2005 23:07:28 WIPE - Flushing cache in:
07-18-2005 23:07:28 REQWIPE - Time to run command: 0ms

btw,
here is my config so there is no confusions..

################################################## ##############################

[Request]
Request_Header = "[REQUESTS] - Current Requests on site :"
Request_Footer = "[REQUESTS] - If you fill a request, please do !reqfilled <number>"
Request_File = "F:\REQ\.ioFTPD.message"
Request_Line = "[REQUESTS] - [ %##:] %-10user at %D-%M-%Y ~ %request"
Request_Field = " ~ "
Request_Max = 50
Request_Max_User = 5
Request_Excluded_User_0 = "ioFTPD"
Request_Excluded_User_1 = "me"
Request_Too_Many_Made = " Too many requests made. Limit is %.0request"
Request_Too_Many_Made_User = " You have made too many requests already. Limit is %.0request"
Request_Already_Made = " That is already requested"
Request_Output_Line = " Added request: %request"
Request_Log = ""%user" "%group" "%request" "
Request_Add_Tag = 1
Request_Tag = "[REQ]-%request"
Request_IRC_Uid = 0
Request_IRC_Gid = 0
Request_Use_Uid-GID_from_IRC = 0


Request_Max_age = 10
Request_Wipe_Log = ""%release" "%.0dirs" "%.0files" "%.2mb""

Reqfilled_Not_Found = " Request not found"
Reqfilled_Log = ""%user" "%group" "%request""
Reqdel_Log = ""%user" "%group" "%request""
Reqdel_Output_Line = " Deleted following request: %request"
Reqfilled_Output_Line = " Filled following request: %request"
Reqfilled_Tag = "[FILLED]-%request"
ReqFilled_Add_Tag = 1
ReqFilled_Send_Message = 1

################################################## ##############################
zOrP is offline   Reply With Quote
Reply

Tags
/warc, exe, internal, users, version

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:50 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)