Go Back   FlashFXP Forums > > > >

WarC's scripts ioA, Warchive, ZR-Tools

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-26-2004, 03:59 PM   #1
godlike
Senior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 94
Default IoA.exe stalls in my taskmgr any suggestions...

Ok first the offical part:

I use:
ioFTPD version: 5-8-5r
ioBanana version: 20
IoA 1.2.0
and some other little scripts which realy doesnt matter ...

Ok now for the problem i got from time to time that the process IoA.exe just stals/stayes in the taskmgr as a active process and it makes connection to ioftpd impossible at that stage.

i can get only:

[R] Connecting to xxx.xxx.xxx.xxx PORT=xxxx (attempt # 1)
[R] Connected to xxx

and no more.

But when i open up the taskmgr and i close that IoA.exe process things get back to normal as they were ... i mean i have a few sites and it occures once a week or twice on one of them, not always the same site.

aybe ioa on login event or smthing but i would do something but theres no ioa.debug i mean it`s empty no error in it. Any clues on what could be wrong ?

Appreciate your help and thx.

CYA
godlike is offline   Reply With Quote
Old 09-26-2004, 04:08 PM   #2
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

Bit hard to figure out this. hmmm

onlogin is not triggered before you actually logged on so cant be that I think.

Clue would be to check your debuglog for which command that was run last and if it finished or not. debuglog is created as soon as ioa is being started if you got debug=1 so you should definitly have one of those. If you dont got debug=1 then enable it and get back to me onces it happens again with that debuglog ready for delivery. You could set debug=5 just for experimentation to track the issue.
WarC is offline   Reply With Quote
Old 09-26-2004, 04:47 PM   #3
godlike
Senior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 94
Default

Yes unfortunatly i missed that debug setting it`s on top and not missable but still i was having on 0

But don`t worry it will happen again and now im ready :P

Will try to debug this myself if something serious i keep you informed.
godlike is offline   Reply With Quote
Old 10-02-2004, 05:59 AM   #4
godlike
Senior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 94
Default

Here you go it happend gain now i have the debug.log it`s 100mb cause ioa.exe staled and tried to do one command and logged each attempt ...

Ok the important lines in debug-log are:

09-30-2004 22:18:37 KICK - Trying to kick from: RLS
09-30-2004 22:18:37 KICK - Kicking cid #1
09-30-2004 22:18:37 KICK - Kicking cid #8

and this line repeats itself for another 99mb of the log

And i dont now whos CID was that ... it tried to kick ... hmmm let me see the cmd before it gets stalled ...

heh i supposed that it was NUKE... here paste from the log before it gets cycled:

09-30-2004 21:50:59 NUKE - nuke: RLS
09-30-2004 21:50:59 NUKE - multi: 3
09-30-2004 21:50:59 NUKE - reason: incomplete.for.more.than.300.minutes
09-30-2004 21:50:59 NUKE - oldpath: RLS
09-30-2004 21:50:59 NUKE - newpath: RLS[Nuked]RLS
09-30-2004 21:50:59 NUKE - Check if directories are present
09-30-2004 21:50:59 NUKE - Checked directories if present
09-30-2004 21:50:59 NUKE - Resolve owner of directory to nuke
09-30-2004 21:50:59 NUKE - Scanning files
09-30-2004 21:50:59 NUKE - Complete nuke
09-30-2004 21:50:59 NUKE - Sum users
09-30-2004 21:50:59 NUKE - Nukees found: 2
09-30-2004 21:50:59 NUKE - Ratio of user: 3
09-30-2004 21:51:00 NUKE - Ratio of user: 3
09-30-2004 21:51:00 NUKE - Create nukelog
09-30-2004 21:51:00 NUKE - Putlog: ""RLS" "AUTONUKE" "NUKERS" "USER" "GROUP" "3" "192.27" "incomplete.for.more.than.300.minutes""
09-30-2004 21:51:00 NUKE - Putlog: ""RLS" "AUTONUKE" "NUKERS "USER" "GROUP" "3" "0.02" "incomplete.for.more.than.300.minutes""
09-30-2004 21:51:00 NUKE - Run Script: c:\ioFTPD\scripts\script.exe nuke USER 192 3
09-30-2004 21:51:00 NUKE - Run Script: Something wrong with Nuke_Run_Script setting
09-30-2004 21:51:00 NUKE - Run Script: c:\ioFTPD\scripts\script.exe nuke pronto 0 3
09-30-2004 21:51:00 NUKE - Run Script: Something wrong with Nuke_Run_Script setting
09-30-2004 21:51:00 NUKE - Rename nuked directory
09-30-2004 21:51:00 NUKE - From: RLS to: RLS[Nuked]-RLS

... i edited so the rls name is blacked out and the user and group ...

hope it helps you getting the problem ... btw i use autonuke from harm (in iobv20 pack)... but ioa.exe stals so i dont know exactly where the problem...

ope it help if not lemme know i will paste more results or logs

CYA and thanx
godlike is offline   Reply With Quote
Old 10-02-2004, 09:08 AM   #5
jeza
Senior Member
ioFTPD Scripter
 
jeza's Avatar
 
Join Date: May 2003
Posts: 529
Default

set
Nuke_Run_Script = ""

if u dont use any script for nuke

and

UnNuke_Run_Script = ""
jeza is offline   Reply With Quote
Old 10-02-2004, 12:13 PM   #6
godlike
Senior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 94
Default

Heh thanx but thats just my failure in config it but this isnt causing problems cause if i nuke it goes ok but those two errors .. but that isnt tcausing the ioa.exe to stall in proces list and eat up the cpu...

But anyway thanx for mentioned that problem i already seen it when i was posting the debug log and corrected it

Any suggestions were to look for this problem in ioa or autonuke from harm ... besides ioa nukes fine and autonuke also but time to time ioa.exe gets cycled up.

cya
godlike is offline   Reply With Quote
Old 10-02-2004, 03:22 PM   #7
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

Hmm I'll look into that kicking part once more then. cant really understand why it wouldnt kick them though or not return from it.
WarC is offline   Reply With Quote
Old 10-04-2004, 04:17 PM   #8
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

godlike could you contact me on irc please.
WarC is offline   Reply With Quote
Reply

Tags
ioa.exe, process, taskmgr, time, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:38 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)