Go Back   FlashFXP Forums > > > >

WarC's scripts ioA, Warchive, ZR-Tools

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-05-2004, 12:05 PM   #1
MonsterDK
Junior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 21
Unhappy ioA: NEWDAY Not Creating Dated Folders

Hey,

I have ioFTPD
ioFTPD-beta5-3-0r
UPGRADED to
ioFTPD-beta5-3-9r

The NEWDAY on my site for 0-day apps is not working automatically.

If I do the command in FLASHFXP to instruct new date to be made it works. New date is done and its annouced in sitechan.

The problem I have is with the scheduled one.....

I have added the lines as per instructions....

[Scheduler]
Newday = 0 0 * * EXEC ..\scripts\ioA\ioA.exe NEWDATE

in iOA config:
Use_Local_Time_Instead_of_UTC = 1

[Newdate]
Newdate_0 = "0-day|D:\ftproot\0-day\%M%D|/0-day/%M%D|D:\ftproot\0-daytoday|0|0"
Newdate_Log = ""%vfs" "%desc" "%desc" "%phys""

If I missed anything important that maybe I over looked that I did not post here... please let me know.

If anyone can see the problem and can help me solve it, that would be great.

But like I said above..... manual command creates the correct folder. It is only automatic dated folder problems....


TIA,
MonsterDK
MonsterDK is offline   Reply With Quote
Old 01-05-2004, 12:51 PM   #2
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

This scheduler line would be trigerred at midnight GMT.
Dunno what time that is for u.
Mouton is offline   Reply With Quote
Old 01-05-2004, 01:19 PM   #3
MonsterDK
Junior Member
ioFTPD Foundation User
 
Join Date: Dec 2003
Posts: 21
Default

Quote:
Originally posted by Mouton
This scheduler line would be trigerred at midnight GMT.
Dunno what time that is for u.

Its been scheduled for 4 days and at midnight no date is made

Any further help please?
MonsterDK is offline   Reply With Quote
Old 05-25-2004, 07:54 PM   #4
vanisher
Junior Member
 
Join Date: May 2004
Posts: 14
Default

I too am having this problem. It works if I do a site newdate, but
doesn't make the directory from the scheduler. I have it configured exactly the same as you do.
vanisher is offline   Reply With Quote
Old 05-25-2004, 08:22 PM   #5
_away_
Junior Member
 
Join Date: Mar 2004
Posts: 4
Default

[Newdate]
Newdate_0 = "0-Day|0-Day|D:\0-Day\%M%D|/0-Day/%M%D|D:\Today_0-Day|0|0|0|1|777"
Newdate_1 = "0-Day|Upload|D:\Upload\%M%D|/Upload/%M%D|D:\Today_Upload|0|0|0|1|777"
Newdate_2 = "0-Day|0-Day|D:\0-Day\%M%D|/0-Day/%M%D|D:\Yesterday_0-Day|0|0|-1|0|777"
Newdate_3 = "0-Day|Upload|D:\Upload\%M%D|/Upload/%M%D|D:\Yesterday_Upload|0|0|-1|0|777"
Newdate_Log = ""%area" "%vfs" "%desc" "%phys""

IOFTPD.ini
Reset = 0 0 * * &Reset
Service_Update = 10,30,50 * * * &Service_Update
Newday = 0 23 * * EXEC ..\scripts\ioA\ioA.exe NEWDATE
_away_ is offline   Reply With Quote
Old 05-25-2004, 09:03 PM   #6
vanisher
Junior Member
 
Join Date: May 2004
Posts: 14
Default

I am in US CST, so I am UTC-6.

Here's my setup:

IOA.cfg

[Newdate]
Newdate_0="Default|0-day|d:\0day\%M%D|/0day/%M%D|d:\ioFTPD\site\today|0|0|0|1|777"


Use_Local_Time_Instead_of_UTC=0

#this is set to 0 because I am using the conversion of -6 hours #for the scheduler to run.

ioFTPD.ini

[scheduler]
Newday = 0 6 * * EXEC ..\scripts\ioA\ioA.exe NEWDATE

site newdate command issued manually works fine. all the other scheduler commands run fine. what's wrong? it's been up and running for 3 days now with no directory or symlink being made.
vanisher is offline   Reply With Quote
Old 05-26-2004, 05:57 PM   #7
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

If newdate works as sitecommand as you seem to have testet the configuration is correct of ioA. That leaves us with the scheduler and this is where the problem is.
Timezones is a problem

vanisher
I think it should work for you if you have it set to use local time. perhaps trigger it 1 min after full hour just in case clocks is a tick after or so. dunno how precise ioftpd scheduler is.

MonsterDK
My guess is that your danish(due to DK) so for you the following line might work. Also set it to use locatime instead of utc

Newday = 1 22 * * EXEC ..\scripts\ioA\ioA.exe NEWDATE
WarC is offline   Reply With Quote
Old 06-01-2004, 09:07 PM   #8
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

warc, same here

site newdate works, but scheduler doesn't

gmt+1 so i tried 1 22 * * and nothing

EDIT: just tried ioNewDay.exe from ioZS, it works like a dream so it seems like i will stick to this zs only for this feature
zpr is offline   Reply With Quote
Old 07-25-2004, 06:37 PM   #9
talktwo
Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 38
Default

so let me get this straight, because i'm having the same problem too

Under ioftpd.ini

[Scheduler]
Newday = 0 1 * * EXEC ..\scripts\ioA\ioA.exe NEWDATE

because I am GMT +1 ....

ok then in ioA.cfg i should have this right:

Use_Local_Time_Instead_of_UTC = 0

if that is set to = 1 it won't create dir right?? should I rehash or reboot after changing this setting?
talktwo is offline   Reply With Quote
Old 07-27-2004, 07:13 AM   #10
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

no need to rehash after chening ioa.cfg.

There is a easy way to schedule it correct. By reading the debugfile. In it ioa logs what time it is in utc and in localtime, then just adjust your scheduler to fit your needs. Easy.
WarC is offline   Reply With Quote
Old 07-27-2004, 09:32 AM   #11
talktwo
Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 38
Default

hmmm ... it still does not create the directory even though both times match, it only creates the directory when I perform site newdate in ffxp.

could it be that originally it was creating one day ahead, so I had deleted that days folder (i.e. actual date was 0724, it created 0725 ... I had done site wipe -r 0725) and restarted ioftpd ... since then it has not been functioning correctly
talktwo is offline   Reply With Quote
Reply

Tags
command, date, flashfxp, newday, problem

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:29 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)