Old 08-09-2003, 02:14 PM   #1
w3rd
Junior Member
 
Join Date: Aug 2003
Posts: 12
Default something wrong with ioZs :(

Hi,

i've been trying to setup ioftpd with iozs,ioa and dzsbot.. but i'm having one very annoying problem...

with iozs, when i upload a file, any file, it just deletes itself and returns no error... weird thing is if you upload it to the root dir it accepts it and processes the sfv/rar file...

im using:
ioftpd 4.9.4u
ioA 0.7.4
ioZS 1.06
mouton's imdbinfo 2
and dzsbot 0.0.8.3

on a windows XP sp1 box

i have set the SystemRoot environment variable aswell for the imdbinfo, which works fine
now my only problem is with iozs deleting uploaded files

if someone could help me i would appreciate it

thanks in advance,
w3rd
w3rd is offline   Reply With Quote
Old 08-11-2003, 03:02 AM   #2
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Try removing some of the scripts to see which cause the problem,
this is first I have heard of this so it's most likely a misconfiguration.
A little troubleshooting won't hurt.

Paste the contents of your etc/ioftpd.env file as well.

Peace
neoxed is offline   Reply With Quote
Old 08-11-2003, 03:20 PM   #3
Giant
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Aug 2002
Posts: 71
Default

One way to recreate this is by missing the msvcr71.dll that iozs need.
You can easy check by executing iozs from the explorer and see if you get any errors.
I just renamed my msvcr71.dll to msvcr71.dlll and all files that i upload gets deleted.

Might not be the case but thats the only think i know that causes that problem.
Giant is offline   Reply With Quote
Old 08-12-2003, 04:45 AM   #4
w3rd
Junior Member
 
Join Date: Aug 2003
Posts: 12
Default

thanks for the help but i figured it out..

seems ioftpd has a problem with non-full directory paths..

like before i had it "..\scripts\iozs.exe Upload"
then i changed it to "D:\ioftpd\scripts\iozs.exe\Upload"

and it all worked good

w3rd
w3rd is offline   Reply With Quote
Old 08-12-2003, 10:42 AM   #5
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

I use those relative paths all over my ioFTPD.ini - has always worked fine.
Zer0Racer is offline   Reply With Quote
Old 02-03-2004, 10:36 AM   #6
|ZOK|
Junior Member
ioFTPD Registered User
 
Join Date: Mar 2003
Posts: 11
Default

actually i got full paths in each iozs line and still have the same problem.
file is upped, using ioFTPD-beta5-6-3r and iozs 1.08 + ioA 1.0.8, and vanishes after it's done.
Strange thing is that ioZS acts as if it's there, even when deleting the sfv after and reupping it, or rescan... says 100% complete.
I don't have the faintest idea what's goin on

[Events]
OnUploadComplete = EXEC c:\ioftpd\scripts\ioZS\ioZS.exe Upload

[FTP_Post-Command_Events]
dele = EXEC c:\ioftpd\scripts\ioZS\ioZS.exe Delete
|ZOK| is offline   Reply With Quote
Old 04-01-2004, 04:56 PM   #7
Orbital
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

Sorry to bump this old thread but i got the same problem...

i get this error msg:
"Faulting application ioZS.exe, version 0.0.0.0, faulting module msvcr71.dll, version 7.10.3052.4, fault address 0x000017fb."

Running win2k3 server...
Orbital is offline   Reply With Quote
Old 04-27-2004, 12:58 PM   #8
moonpyk
Junior Member
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 3
Default Re: something wrong with ioZs :(

Quote:
Originally posted by w3rd
Hi,

i've been trying to setup ioftpd with iozs,ioa and dzsbot.. but i'm having one very annoying problem...

with iozs, when i upload a file, any file, it just deletes itself and returns no error... weird thing is if you upload it to the root dir it accepts it and processes the sfv/rar file...

im using:
ioftpd 4.9.4u
ioA 0.7.4
ioZS 1.06
mouton's imdbinfo 2
and dzsbot 0.0.8.3

on a windows XP sp1 box

i have set the SystemRoot environment variable aswell for the imdbinfo, which works fine
now my only problem is with iozs deleting uploaded files

if someone could help me i would appreciate it

thanks in advance,
w3rd
I was having the same problem, in fact, i was using non-full paths in my VFS file, ioFTPD seem to accept it with no problem but ioZS not...
moonpyk is offline   Reply With Quote
Old 12-27-2004, 09:38 AM   #9
Lettiz
Junior Member
 
Join Date: Dec 2004
Posts: 2
Default

Im still havin this problem also with the new ioZS

Code:
[L] 150 Opening ASCII mode data connection for psf-d7e2.sfv.
[L] 226- .---------==[ ioZS v2.06 ]-=-[ by StarDog, (c)2004 ]==------------.
[L] 226- | 0-Byte File: Deleted!                                           |
[L] 226- '--------------------------------======---------------------------'
[L] 226 Transfer complete.
Transferred: psf-d7e2.sfv 24 bytes in 0,06 seconds (0,4 KB/s)
[L] TYPE I
[L] 200 Type set to I.
[L] PASV
[L] 227 Entering Passive Mode (127,0,0,1,7,149)
[L] Opening data connection IP: 127.0.0.1 PORT: 1941
[L] STOR psf-d7e2.rar
[L] 150 Opening BINARY mode data connection for psf-d7e2.rar.
[L] 226- .---------==[ ioZS v2.06 ]-=-[ by StarDog, (c)2004 ]==------------.
[L] 226- | 0-Byte File: Deleted!                                           |
[L] 226- '--------------------------------======---------------------------'
[L] 226 Transfer complete.
Transferred: psf-d7e2.rar 11,32 MB in 0,86 seconds (13.475,3 KB/s)

But in the root dir i don't have this problem
Lettiz is offline   Reply With Quote
Old 12-28-2004, 02:22 PM   #10
Stardog
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Oct 2001
Posts: 236
Default

Quote:
Originally posted by Lettiz
Im still havin this problem also with the new ioZS

But in the root dir i don't have this problem
Are your physical paths too long? If the complete path is longer than MAX_PATH it might bomb trying to get the filesize...
Stardog is offline   Reply With Quote
Old 12-28-2004, 04:09 PM   #11
Lettiz
Junior Member
 
Join Date: Dec 2004
Posts: 2
Default

well my path name in default.vfs and admin.vfs

"../site" / is that so that should be a problem
Lettiz is offline   Reply With Quote
Old 12-28-2004, 04:19 PM   #12
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Well there's your problem, you can't use relative paths in the .vfs file. Where on earth would you get that idea? There are countless examples in the documentation and forums and they all have absolute paths.

http://www.ioftpd.com/documentation/03-vfs.php
neoxed is offline   Reply With Quote
Reply

Tags
file, imdbinfo, iozs, problem, upload

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PC to PC connection... silvaeon General Discussion 3 02-10-2005 05:28 PM
No unicode support! GSMD General Discussion 5 02-04-2005 12:00 AM


All times are GMT -5. The time now is 09:41 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)