Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-22-2014, 12:12 PM   #1
Saiph
Junior Member
 
Join Date: Oct 2010
Posts: 23
Default LoadPackage error

i see this alot in the nxError.log any help with this would be appreciated ty
i've gone throught the read me on where to place all files etc and it still continues

04-21-2014 09:36:34 - LoadPackage : attempt to provide package nxHelper 2.3.0 failed: package nxHelper 2.4.0 provided instead
04-21-2014 09:36:35 - LoadPackage : attempt to provide package nxHelper 2.3.0 failed: package nxHelper 2.4.0 provided instead
04-21-2014 09:36:36 - LoadPackage : attempt to provide package nxHelper 2.3.0 failed: package nxHelper 2.4.0 provided instead

Last edited by Saiph; 04-22-2014 at 09:29 PM. Reason: ioFTPD-v7.7.2 + ioNiNJA.1.0.Beta4.2012-10-02 + nxTools-v1.2.1
Saiph is offline   Reply With Quote
Old 04-23-2014, 01:30 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

nxHelper is a TCL extension library. It provides a couple of commands used by nxTools that are written in C instead of TCL if I remember correctly. Somewhere the system is asking for v2.3 and the system finds a newer v2.4 and uses that instead. This isn't a big deal at all. If you want to prevent this showing up look at the top of the nxTools TCL files in the scripts directory and find the reference to nxTools 2.3 and change it to 2.4 and then you won't get any more errors showing up. Or I think you can even drop the v2.4 reference and it will just use the newest one automatically.
Yil is offline   Reply With Quote
Old 04-23-2014, 02:22 PM   #3
Saiph
Junior Member
 
Join Date: Oct 2010
Posts: 23
Default

Quote:
Originally Posted by Yil View Post
nxHelper is a TCL extension library. It provides a couple of commands used by nxTools that are written in C instead of TCL if I remember correctly. Somewhere the system is asking for v2.3 and the system finds a newer v2.4 and uses that instead. This isn't a big deal at all. If you want to prevent this showing up look at the top of the nxTools TCL files in the scripts directory and find the reference to nxTools 2.3 and change it to 2.4 and then you won't get any more errors showing up. Or I think you can even drop the v2.4 reference and it will just use the newest one automatically.
i found the pkgIndex.tcl and changed the reference
from: package ifneeded nxHelper 2.3.0[list load [file join $dir nxHelper.dll]]
to: package ifneeded nxHelper 2.4.0[list load [file join $dir nxHelper.dll]]

the 2.3.0 it was looking for was renamed to nxHelper.dll2

no more errors thank you
Saiph is offline   Reply With Quote
Reply

Tags
04-21-2014, attempt, loadpackage, nxhelper, package

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:59 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)