Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-13-2009, 12:27 PM   #16
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

The built-in version of site who is much nicer (especially with color enabled) so you probably want that. In which case just comment out or remove the nxTools "who" definition under [FTP_Custom_Commands]. BTW, that extra character at the end will go away in the next release...

If you wish to disable the built-in version, prefix the command under [FTP_Custom_Commands] with a "^". See the comments in that section for an example.
Yil is offline   Reply With Quote
Old 02-01-2010, 01:54 AM   #17
newguy
Junior Member
 
Join Date: Jul 2009
Posts: 16
Default

I'm running the latest build off ioFTPD 7.1.0 and the latest nxTools with fix but for some reason when i do a site who the users/groups i said to hide are still vissible ?

Any ideas ?

No other scripts added.
newguy is offline   Reply With Quote
Old 02-01-2010, 03:14 PM   #18
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

newguy: Double check which version of "site who" you are using. As of v6.5 ioFTPD includes a built-in "site who" along with a couple of .ini settings to let you control which users/groups/paths should be hidden. nxTools also has a "site who" that you can install (with the "^" prefix) to override the built-in one if you prefer it. Also note that until v7.1 the example for hiding a user in the .ini file was wrong (it's user, username*, =group, .FLAG, !thing, etc) where FLAG is any single letter userflag like 1/G/M etc.
Yil is offline   Reply With Quote
Old 02-01-2010, 03:41 PM   #19
newguy
Junior Member
 
Join Date: Jul 2009
Posts: 16
Default

Quote:
Originally Posted by Yil View Post
newguy: Double check which version of "site who" you are using. As of v6.5 ioFTPD includes a built-in "site who" along with a couple of .ini settings to let you control which users/groups/paths should be hidden. nxTools also has a "site who" that you can install (with the "^" prefix) to override the built-in one if you prefer it. Also note that until v7.1 the example for hiding a user in the .ini file was wrong (it's user, username*, =group, .FLAG, !thing, etc) where FLAG is any single letter userflag like 1/G/M etc.
@Yil, Thanks for explaining.
It suddenly worked but i'll double check config because i think i have double settings now (probably didn't read change log good enough )
Thanks again.
newguy is offline   Reply With Quote
Old 03-28-2010, 08:26 AM   #20
jojo2peter
Junior Member
 
Join Date: Jun 2006
Posts: 20
Default

Quote:
Originally Posted by DJZacharia View Post
hehe...i figured out the what caused the error.
i already had an init.tlc....and i just copied and pasted the data from the init.tcl i had already had to the end of the one for nxtools....and then the script worked perfectly :P
Hey, I have the problem you had now, but i cant solve it ...
I installed ioNinja at first, then i tried to install nxtools, but i got your error.
But i edited the init.itcl, can you help me?
jojo2peter is offline   Reply With Quote
Old 03-28-2010, 12:14 PM   #21
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Paste your scripts\init.itcl file and a copy of the error message(s). Perhaps it's something simple.
Yil is offline   Reply With Quote
Old 03-28-2010, 01:17 PM   #22
jojo2peter
Junior Member
 
Join Date: Jun 2006
Posts: 20
Default

Oh I'm sorry

SystemError.log:
Quote:
03-28-2010 14:53:53 "..\scripts\nxTools\nxClose.tcl" terminated abnormally
--- ErrorInfo ---
can't read "misc(ReloadConfig)": no such variable
while executing
"IsTrue $misc(ReloadConfig)"
invoked from within
"if {[IsTrue $misc(ReloadConfig)] && [catch {source "../scripts/init.itcl"} error]} {
iputs "Unable to load script configuration, contact a siteop...."
(file "..\scripts\nxTools\nxClose.tcl" line 15)
----
03-28-2010 14:55:39 "..\scripts\nxTools\nxClose.tcl" terminated abnormally
--- ErrorInfo ---
can't read "misc(ReloadConfig)": no such variable
while executing
"IsTrue $misc(ReloadConfig)"
invoked from within
"if {[IsTrue $misc(ReloadConfig)] && [catch {source "../scripts/init.itcl"} error]} {
iputs "Unable to load script configuration, contact a siteop...."
(file "..\scripts\nxTools\nxClose.tcl" line 15)
----
nxError.log
Quote:
03-28-2010 14:51:41 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 14:53:26 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 14:55:56 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:55:56 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 14:56:03 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:56:03 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:56:05 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:56:06 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:56:29 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 14:56:29 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:01:48 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:01:53 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:01:59 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:02:07 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:02:14 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:02:23 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:02:31 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:03:59 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:05:59 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:07:59 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:09:59 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:12:00 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:14:01 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:16:01 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:18:01 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:20:01 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:22:02 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:22:04 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:22:29 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:22:30 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:22:38 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:22:47 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:22:48 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:22:56 - LoadScript : couldn't read file "C:/TEST/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
03-28-2010 15:24:30 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:26:30 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:27:32 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
03-28-2010 15:29:32 - InvalidArgs : unknown event "..\scripts\nxTools\nxClose.tcl LOGI": check your ioFTPD.ini for errors
ioFTPD.log
Quote:
03-28-2010 14:53:43 SSL: "Found certificate" "name=ioFTPD" "Service=FTP_Service" "(Certificate_name)"
03-28-2010 14:53:43 START: "PID=11664" "CmdLine="
03-28-2010 14:53:43 PRELOAD: "begin" "..\etc\default.vfs"
03-28-2010 14:53:43 PRELOAD: "points=1" "..\etc\default.vfs"
03-28-2010 14:55:52 SSL: "Found certificate" "name=ioFTPD" "Service=FTP_Service" "(Certificate_name)"
03-28-2010 14:55:52 START: "PID=11404" "CmdLine="
03-28-2010 14:55:52 PRELOAD: "begin" "..\etc\default.vfs"
03-28-2010 14:55:52 PRELOAD: "points=1" "..\etc\default.vfs"
03-28-2010 14:56:23 SSL: "Found certificate" "name=ioFTPD" "Service=FTP_Service" "(Certificate_name)"
03-28-2010 14:56:23 START: "PID=12680" "CmdLine="
03-28-2010 14:56:23 PRELOAD: "begin" "..\etc\default.vfs"
03-28-2010 14:56:23 PRELOAD: "points=1" "..\etc\default.vfs"
03-28-2010 15:01:42 SSL: "Found certificate" "name=ioFTPD" "Service=FTP_Service" "(Certificate_name)"
03-28-2010 15:01:42 START: "PID=14304" "CmdLine="
03-28-2010 15:01:42 PRELOAD: "begin" "..\etc\default.vfs"
03-28-2010 15:01:42 PRELOAD: "points=1" "..\etc\default.vfs"
03-28-2010 15:22:24 SSL: "Found certificate" "name=ioFTPD" "Service=FTP_Service" "(Certificate_name)"
03-28-2010 15:22:24 START: "PID=18244" "CmdLine="
03-28-2010 15:22:24 PRELOAD: "begin" "..\etc\default.vfs"
03-28-2010 15:22:24 PRELOAD: "points=1" "..\etc\default.vfs"
init.itcl
Quote:
set nx(scripts) {
{../scripts/nxAutoNuke/nxAutoNuke.cfg}
{../scripts/nxTools/nxTools.cfg}
{../scripts/nxLib.tcl}
}

################################################## ####################

proc nxLoadError {type message} {
if {![catch {set handle [open "../logs/nxError.log" a]}]} {
set now [clock format [clock seconds] -format "%m-%d-%Y %H:%M:%S"]
puts $handle "$now - [format %-12s $type] : $message"
close $handle
}
}

foreach name $nx(scripts) {
if {[catch {source [file normalize $name]} error]} {
nxLoadError LoadScript $error
}
}

foreach name {nxHelper sqlite3} {
if {[catch {package require $name} error]} {
nxLoadError LoadPackage $error
}
}
if {[catch {source "../scripts/ioNiNJA/ioNiNJA.cfg"} error]} {
return
}
if {[catch {source "../scripts/ioNiNJA/themes/$ioNJ(themefile)"} error]} {
return
}

if {[catch {source "../scripts/ioNiNJA/MiSC/NiNJALiB.tcl"} error]} {
return
}

if {[catch {package require http 2.7.1} error]} {
return
}
ioFTPD.ini

Last edited by jojo2peter; 03-28-2010 at 01:22 PM.
jojo2peter is offline   Reply With Quote
Old 03-28-2010, 02:05 PM   #23
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

nxTools shouldn't refer to nxAutoNuke in init.itcl unless it's installed, so you can remove that reference to make some of those errors go away.

set nx(scripts) {
{../scripts/nxTools/nxTools.cfg}
{../scripts/nxLib.tcl}
}


The pass pre-command event is missing the N on the end from the "..\scripts\nxTools\nxClose.tcl LOGI" errors... should be LOGIN which is why all logins are generating an error line.

Other than that things look OK. Try those 2 fixes and report back.
Yil is offline   Reply With Quote
Old 03-28-2010, 02:35 PM   #24
jojo2peter
Junior Member
 
Join Date: Jun 2006
Posts: 20
Default

Quote:
Originally Posted by Yil View Post
nxTools shouldn't refer to nxAutoNuke in init.itcl unless it's installed, so you can remove that reference to make some of those errors go away.

set nx(scripts) {
{../scripts/nxTools/nxTools.cfg}
{../scripts/nxLib.tcl}
}


The pass pre-command event is missing the N on the end from the "..\scripts\nxTools\nxClose.tcl LOGI" errors... should be LOGIN which is why all logins are generating an error line.

Other than that things look OK. Try those 2 fixes and report back.
Ok now it works..
i already saw that mistake "LOGI" but i didnt think about it -.-
and the line with nxAutoNuke did I delete too ... well thank you
jojo2peter is offline   Reply With Quote
Old 06-13-2010, 07:09 AM   #25
BoNeZz
Member
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 39
Default

i installed ioftpd 7.5.7, but what version about nxtools i must installed on 7.5.7? can you write me post links of this or these versions?

i downloaded nxtools-tempfix-2008-09-29.rar but this .rar not contain all files of this script and is impossible to install, so i think that i need download another .rar and replace old files with nxtools-tempfix-2008-09-29.rar.

i hope can you help me.

thanks in advance
BoNeZz is offline   Reply With Quote
Old 09-20-2011, 12:39 PM   #26
Rusher
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2004
Posts: 57
Default

"site drives" crashes ioftpd.exe using Windows Server 2008 R2 Enterprise x64

Faulting application name: ioFTPD.exe, version: 7.7.2.0, time stamp: 0x4dc859d3
Faulting module name: tcl85t.dll, version: 8.5.2.9, time stamp: 0x4d61c78e
Exception code: 0x40000015
Fault offset: 0x00078caf
Faulting process id: 0xf4c
Faulting application start time: 0x01cc77ba65821c11
Faulting application path: C:\ioFTPD\system\ioFTPD.exe
Faulting module path: C:\ioFTPD\system\tcl85t.dll

any clue what it could be ?

edit: i dont get any error messages in ../logs/

Last edited by Rusher; 09-20-2011 at 12:45 PM.
Rusher is offline   Reply With Quote
Old 09-21-2011, 02:43 AM   #27
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

You are absolutely correct. I noticed this a long time ago and guess I forgot to mention it here. nxTools contains a companion dll that enhances TCL with a few extra features and somewhere along the line upgrading the TCL library to newer releases broke parts of the dll.

There are no trivial solutions immediately available, however v8 of ioFTPD will fix this problem in 2 ways. The information the dll provided that is currently broken will now be available via iTCL (i.e. an ioFTPD extension to TCL) so nxTool's dll won't be necessary and we can fix nxTools by replacing the dll call with the ioFTPD call. That should be relatively straightforward to do. In fact is someone else wants to fix the dll right now it probably wouldn't be hard either.

I have also written most of a replacement for this command as a standalone script which is why ioFTPD v8 will have this info I think my solution should be superior because it will use section, mountfile, etc directly from ioFTPD instead of trying to do it in the script by parsing files. It's also much smarter. nxTools pre-dates those new features though so it did the best it could at the time, but depending on parsing ioFTPD files and requiring updates to it's own config file is something I'm trying to avoid in my stuff.

Short answer: disable the command by undefining it and wait a bit for the replacement.
Yil is offline   Reply With Quote
Old 08-29-2012, 02:51 PM   #28
Henkie2
Member
 
Join Date: Dec 2011
Posts: 53
Default

Hope anyone can help me, for some reason on irc my !request/!reqfill and !reqwipe aren't working any more.
!requests is working like the rest of triggers :P anyone?
(i'm not changed/removed any trigger commands)
Henkie2 is offline   Reply With Quote
Old 08-29-2012, 03:13 PM   #29
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Are you using the bot that comes with ioNiNJA? Have you made sure that the REQBOT command from nxTools is configured in the .ini file along with it's permissions. Does the bot have the 1 flag so it can run the command? If all of that is true then you should be seeing some sort of error message if you try those commands. Remember, you have to use 'site invite <nick>' so the bot knows what user on the FTP to use when performing actions.
Yil is offline   Reply With Quote
Old 08-29-2012, 06:22 PM   #30
Henkie2
Member
 
Join Date: Dec 2011
Posts: 53
Default

Thx for your fast reply Yil

Last edited by Henkie2; 09-02-2012 at 10:19 PM.
Henkie2 is offline   Reply With Quote
Reply

Tags
chg, download, dupe, fix, insert

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:43 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)