Old 01-09-2008, 12:46 AM   #1
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default nxTools v1.0.7

Changes:
  • CHG: Updated ignore lists to include new common directories.
  • CHG: Updated SQLite to v3.5.4.
  • FIX: All parent symlinks would be removed on nuke and wipe.
  • FIX: Force NFO/SFV/Sample was not working properly.
  • FIX: Properly terminate switches to the glob function.
Download:

See attachment.

Last edited by neoxed; 02-10-2008 at 04:10 PM.
neoxed is offline   Reply With Quote
Old 01-09-2008, 06:33 PM   #2
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Hi neoxed, thanks for the update. nxClose error seems to be gone now. Nice

I have a issue here with on upload it add stuff to right section defined, but when I do site rebuild, some defined section goes listed as "default" section in the login msg.

Display 15 latest releases:
%[execute(TCL ..\scripts\nxTools\nxDupe.tcl)(NEW -max 15)]

That line, display defined section when using site rebuild to "default"...uuughh... i dunno exactly howto explain this...
Flow is offline   Reply With Quote
Old 01-12-2008, 02:23 PM   #3
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Quote:
Originally Posted by Flow View Post
Hi neoxed, thanks for the update. nxClose error seems to be gone now. Nice
I haven't changed any code in nxClose. Like I've said a thousand times already, the bug is/was in ioFTPD.

http://www.flashfxp.com/forum/showpo...06&postcount=9
http://www.flashfxp.com/forum/showpo...88&postcount=5

Quote:
Originally Posted by Flow View Post
I have a issue here with on upload it add stuff to right section defined, but when I do site rebuild, some defined section goes listed as "default" section in the login msg.

Display 15 latest releases:
%[execute(TCL ..\scripts\nxTools\nxDupe.tcl)(NEW -max 15)]

That line, display defined section when using site rebuild to "default"...uuughh... i dunno exactly howto explain this...
The dupe database doesn't keep track of the sections. nxTools gets the section information from ioFTPD.ini.
neoxed is offline   Reply With Quote
Old 01-20-2008, 10:23 AM   #4
magicman2008
Junior Member
 
Join Date: Nov 2007
Posts: 4
Default

I cant get site NUKE to work.
[L] 200 Command successful.
[L] site nuke This.nice.Releae 1 get.proper
[L] 200-.-[Nuke]-----------------------------------------------------------------.
[L] 200-| You are not allowed to nuke other groups. |
[L] 200-'------------------------------------------------------------------------'

im still using nxTools v.1.0.6

but i dont think thats my problem ?

UPDATED to v.1.0.7 now its working i dont know if it was because of the v1.0.6 :-)

Last edited by magicman2008; 01-20-2008 at 10:52 AM.
magicman2008 is offline   Reply With Quote
Old 01-21-2008, 07:10 AM   #5
gastonCZ
Junior Member
 
Join Date: Feb 2005
Posts: 4
Default

neoxed, you can add to dupe log wipe date?
site dupe Test.2008-IND
200-01182008 Test.2008-IND
200-01182008 Test.2008-IND wiped by STAFF 19/01/2008 at 16:32


I have one problem, if i wipe some dir, so is deleted from dupe db..its bad
any chance to disable it? thx

Last edited by gastonCZ; 01-24-2008 at 06:25 PM. Reason: fix dupe now
gastonCZ is offline   Reply With Quote
Old 01-21-2008, 08:20 AM   #6
MaSTeRsans
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

how do I create Weekly dirs ?

in my config I have

{*** {New ***} {/***/week_%W} {e:/site/***/week_%W} {c:/ioFTPD/site/***_weekly} True 0 0 0 777}

but it dont work, what have I done wrong ?
MaSTeRsans is offline   Reply With Quote
Old 01-23-2008, 12:53 PM   #7
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

If you havent you should add this under SCHEDULER in ioftpd.ini... make sure time zone settings are correct etc...

nxNewDate = 1 0 * 6 TCL ..\scripts\nxTools\nxUtilities.tcl NEWDATE
hukker is offline   Reply With Quote
Old 01-23-2008, 12:58 PM   #8
MaSTeRsans
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

Yeah I have the scheduler bit in, i forgot to mention, im using it for daily newdirs as well on mp3, which works fine, hence left me a bit confused when the weekly dir dident work
MaSTeRsans is offline   Reply With Quote
Old 01-23-2008, 08:11 PM   #9
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Quote:
Originally Posted by MaSTeRsans View Post
Yeah I have the scheduler bit in, i forgot to mention, im using it for daily newdirs as well on mp3, which works fine, hence left me a bit confused when the weekly dir dident work
Check "ioFTPD\logs\nxError.log" for clues. The "SITE NEWDATE" command is also useful for troubleshooting.
neoxed is offline   Reply With Quote
Old 01-23-2008, 08:55 PM   #10
MaSTeRsans
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

Quote:
Originally Posted by neoxed View Post
Check "ioFTPD\logs\nxError.log" for clues. The "SITE NEWDATE" command is also useful for troubleshooting.
I've found the problem, I put the code back in and ran site newdate, it linked to week_3, time and date is fine on the rig, and when I first ran the script it linked to week_1 which left me confused, but now its obvious its running 1 week behind, anyhow I've set +7 days on the offset and its linking now to week_4, hopefully sunday it will change to week_5

MaSTeRsans is offline   Reply With Quote
Reply

Tags
chg, download, fix, properly, updated

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:22 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)