Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-05-2006, 08:58 PM   #1
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default nxTools v1.0.5

Changes:
  • NEW: Aliases for SITE EDITPRE sub-commands ("section" and "group").
  • NEW: Section cookie for latest race and pre symlinks.
  • CHG: Improved path resolving and symlink removal functions.
  • CHG: Improved performance of directory listing routines.
  • CHG: Output from "SITE CLEAN" and "SITE REBUILD" is no longer buffered to prevent ioFTPD from stopping the script because of execution time limits.
  • CHG: Updated SQLite to v3.3.7.
  • FIX: Always make the pre area upper-case.
  • FIX: Directory dupe database was always cleaned, even if disabled in the config.
  • FIX: Log the maximum request age as a time duration.
  • FIX: Many directories and files were skipped when rebuilding the dupe database.
  • FIX: The "SITE EDITPRE ADDAREA" command requires the "other" variable to be set.
Download:

http://www.inicom.net/pages/en.ioftpd-scripts.php?id=78
neoxed is offline   Reply With Quote
Old 09-09-2006, 08:31 AM   #2
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

nxTools-v1.0.5
ioFTPD-beta5-8-5r
AlcoBot-v1.2.0

Hey neoxed

Ive got problems with the latest version. Not really sure what to make of it but heres a few debug lines.

!request helo
[AlcoBot] Debug :: FtpSend - Sending command "SITE REQBOT ADD hukker "helo"".
[AlcoBot] Debug :: FtpHandler - Reply code "200" and message ".-[Request]--------------------------------------------------------------.".

It just wont put thrue the request. site request doesnt work either.

(15:28:46) [2] site request asd
(15:28:46) [2] 200-.-[Request]--------------------------------------------------------------.
(15:28:46) [2] 200 Command successful.

Just gives me that strange output line, Ive deleted the dbs and had them recrated with the new files just to make sure, but that didnt help anything.

Is it working alright for you?
hukker is offline   Reply With Quote
Old 09-09-2006, 01:38 PM   #3
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

I made a small typo in nxLib.tcl, I'll release a minor update soon.
neoxed is offline   Reply With Quote
Old 09-09-2006, 05:46 PM   #4
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

never trust a ms spell checker
ArtX is offline   Reply With Quote
Old 09-12-2006, 03:38 AM   #5
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

Neoxed, I know your busy n all but couldnt you just say what to change in here, I mean if its a minor spell issue like you say?
hukker is offline   Reply With Quote
Old 09-13-2006, 12:56 AM   #6
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Right...sorry about that, I'll post it now.

Update: Just posted v1.0.5a, which corrects this regression. To upgrade from v1.0.5 to v1.0.5a, just replace the nxLib.tcl file.

Last edited by neoxed; 09-13-2006 at 01:09 AM.
neoxed is offline   Reply With Quote
Old 09-13-2006, 06:28 AM   #7
hukker
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 165
Default

working, thx
hukker is offline   Reply With Quote
Old 10-12-2006, 05:16 PM   #8
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

hi.. a small request for next version. when rotating logs, instead of renaming them to lots of different dates, would it be possible to delete them?
zOrP is offline   Reply With Quote
Old 10-22-2006, 10:07 AM   #9
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

weird thing here.
After i updated to 1.05a not much is working anymore.

!bw !speed etc. and !new gives me no reply what so ever.
and no errors pop up in debug or dcc chat.. :s
any ideas?

Tried to change back to 1.0.4a.
Now that isnt working either.. :x
But all ftp cmds work.
So seems its something with the bot. But what?
Only the Online and nxtools module is not working.

Fixed.
forgot ioftpd was running as a service with interact..

Last edited by zOrP; 10-22-2006 at 10:38 AM.
zOrP is offline   Reply With Quote
Old 10-22-2006, 10:49 AM   #10
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

found a bug though.
When wiping.
No matter what i wipe.
it says 0KB ( 0Files, 0 dirs)
And could u paste a working link for that debug module?
zOrP is offline   Reply With Quote
Old 11-01-2006, 06:42 PM   #11
spirit
Member
 
Join Date: Mar 2006
Posts: 44
Default

Quote:
Originally Posted by zOrP
found a bug though.
When wiping.
No matter what i wipe.
it says 0KB ( 0Files, 0 dirs)
And could u paste a working link for that debug module?
Ive got the same problem, no matter what i get wiped there are always 0's.
spirit is offline   Reply With Quote
Old 11-06-2006, 11:56 AM   #12
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Known bug, there was an error in the file stats routine.
neoxed is offline   Reply With Quote
Old 11-07-2006, 01:46 PM   #13
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

and about the link for the debug thingy ?

Since this botchrash on !df makes me crazy.. :s
zOrP is offline   Reply With Quote
Old 11-11-2006, 02:40 PM   #14
srtu
Junior Member
 
Join Date: Aug 2005
Posts: 24
Default

hi,
i got a error msg in nxerror.log
Quote:
LoadScript : couldn't read file "C:/ioFTPD/scripts/nxAutoNuke/nxAutoNuke.cfg": no such file or directory
but i didn´t want tu use autonuke, i find a entry in init.tcl an i make a # infront
Quote:
set nx(scripts) {
# {../scripts/nxAutoNuke/nxAutoNuke.cfg}
{../scripts/nxTools/nxTools.cfg}
{../scripts/nxLib.tcl}
}
but i still get a error msg.
the problem is, that io crashs sometimes, and the only error.log i found is this i wrote above
can i delete the line
Quote:
{../scripts/nxAutoNuke/nxAutoNuke.cfg}
?
srtu is offline   Reply With Quote
Old 11-18-2006, 01:00 PM   #15
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Remove the line, you cannot comment it inside curly braces.
neoxed is offline   Reply With Quote
Reply

Tags
chg, directory, download, fix, site

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:39 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)