Old 04-13-2006, 01:52 PM   #1
snatsert
Member
ioFTPD Foundation User
 
Join Date: Mar 2003
Posts: 61
Default !dupe problem

I have some existing folders that I have before I installed alcobot and nxtools and when I do !dupe it doesn't show them ... it only shows new folders I upped after the installation . Do I need to add them to the dupe db ?? if so , how do I do that
snatsert is offline   Reply With Quote
Old 04-13-2006, 02:40 PM   #2
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Read the manual and configuration included with nxTools.

Code:
- SITE REBUILD
    Description:
     - Updates the file and directory dupe database by scanning predefined paths.
    Examples:
     - SITE REBUILD
Code:
#### Dupe Log Rebuild ######################################
#
# - Recreates the file and/or directory dupe log by searching the defined paths.
# - Format: <virtual path> <physical path> <directories> <files>
#   Virtual Path    - Virtual path to rebuild files and directories from.
#   Physical Path   - The virtual path's physical location.
#   Log Directories - Update the directory database from this path.
#   Log Files       - Update the file database from this path.
#
set dupe(RebuildPaths) {
  {{/0DAY}  {D:/Site/0DAY}  True False}
  {{/APPS}  {D:/Site/APPS}  True True}
  {{/GAMES} {E:/Site/GAMES} True True}
  {{/SVCD}  {E:/Site/SVCD}  True True}
  {{/VCD}   {E:/Site/VCD}   True True}
  {{/XVID}  {E:/Site/XVID}  True True}
}
neoxed is offline   Reply With Quote
Old 04-14-2006, 10:30 AM   #3
snatsert
Member
ioFTPD Foundation User
 
Join Date: Mar 2003
Posts: 61
Default

I did that site rebuild and it said it updated the database , but when I do site dupe I get no results
snatsert is offline   Reply With Quote
Old 09-05-2006, 11:01 AM   #4
colsha2702
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 6
Default

im sorry to say NeoXed that the rebuild function does not seem to complete correctly .. I have just had to do it and when it was rebuilding it has only picked up 207 folders/files.
colsha2702 is offline   Reply With Quote
Old 09-05-2006, 04:12 PM   #5
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Honestly, what am I supposed to do with that information?

Try providing some useful details... configuration options, entries from logs\SystemError.log, script output from the FTP client, or anything that can actually be used to reproduce the problem.
neoxed is offline   Reply With Quote
Old 01-28-2007, 05:51 AM   #6
spirit
Member
 
Join Date: Mar 2006
Posts: 44
Default

Quote:
Originally Posted by neoxed
Honestly, what am I supposed to do with that information?

Try providing some useful details... configuration options, entries from logs\SystemError.log, script output from the FTP client, or anything that can actually be used to reproduce the problem.
Hey NeoXed, ive got similar problem and i can provide some information about it.

site rebuild hangs up and ive tried also optimizing and creating and they also hang up, only site db create works means shows output in ftp client.

Here is my config:

set dupe(RebuildPaths) {
{{/0DAY} {E:/Dump/0DAY} True True}
{{/APPS} {E:/Dump/APPS} True True}
{{/GAMES} {D:/Dump/GAMES} True True}
{{/XVID} {D:/Dump/XVID} True True}
{{/MP3} {D:/Dump/MP3} True True}
{{/TV} {D:/Dump/TV} True True}
{{/DOX} {E:/Dump/DOX} True True}
{{/MVID} {E:/Dump/MVID} True True}
{{/EBOOKS} {E:/Dump/EBOOKS} True True}
}

and the info what i get from systemerror.log:


01-28-2007 11:10:27 "..\scripts\nxTools\nxDupe.tcl" terminated abnormally
--------------------------- ErrorInfo ----------------------------
invalid command name "GetDirList"
while executing
"GetDirList $realPath listing $dupe(RebuildIgnore)"
(procedure "RebuildDb" line 28)
invoked from within
"RebuildDb"
("REBUILD" arm line 2)
invoked from within
"switch -- $event {
DUPELOG {
set virtualPath [GetPath [join [lrange $argList 2 end]] $pwd]
if {[IsTrue $dupe(CheckDi01-28-2007 11:12:14

and another one:

"..\scripts\nxTools\nxDupe.tcl" terminated abnormally
--------------------------- ErrorInfo ----------------------------
database is locked
while executing
"DirDb eval {BEGIN; DELETE FROM DupeDirs;}"
(procedure "RebuildDb" line 16)
invoked from within
"RebuildDb"
("REBUILD" arm line 2)
invoked from within
"switch -- $event {
DUPELOG {
set virtualPath [GetPath [join [lrange $argList 2 end]] $pwd]
if {[IsTrue $dupe(CheckDirs..."
(procedure 01-28-2007 11:13:39 "..\scripts\nxTools\nxDupe.tcl" terminated abnormally

Any help will be appreciated
Thank You
spirit is offline   Reply With Quote
Old 01-28-2007, 08:29 AM   #7
spirit
Member
 
Join Date: Mar 2006
Posts: 44
Default

Hmm didnt say anything about version of nxTools so i use 1.0.5a.

But looks like ive solved the problem its kinda weird but ive deleted all files from nxtools/data/ then ive replaced all .tcl files from nxtools coz my configs are fine and replaced nxlib.tcl file and now it works. Dont know what was wrong but it works now maybe nxlib was broken or something.
spirit is offline   Reply With Quote
Reply

Tags
add, dupe, folders, installation, upped

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:04 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)