Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-16-2005, 03:00 PM   #1
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default Ssl And Invite Pb

hi ,
i setup a box with all your script neoxed ,all is working perfectly now.
i just have some pb with ssl or tsl mode in AlcoBot0.5 ,only "none" is working
if you know what i need to setup or investigate ?

and i can't make invite module working .
i need a little more help cause i test it like that in linknet :
ftp user :taiyo
irc nick associate : epoke
host add to the db : user@LinkNet-74272f1fd6.proxad.net or without mangling ??
anyway if i set False in :
hostCheck = False
userCheck = False

it is not working
any idea ?
TIA
thx for the great work neoxed
epoke is offline   Reply With Quote
Old 10-16-2005, 03:19 PM   #2
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

Have you set up a ODBC db for the bot to use? Invite modules use this now.
PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-16-2005, 03:31 PM   #3
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default

yes i have all the ODBC db working .and nothing special on debug log
epoke is offline   Reply With Quote
Old 10-17-2005, 03:00 PM   #4
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

Ok i`m running into the invite problem too. If i stop the ioftpd service then restart, invite wont work until i .rehash the windrop. After that it works as normal.

PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-17-2005, 04:04 PM   #5
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Describe "wont work".

I need useful information to track down the problem (debug message, partyline errors, etc.).
neoxed is offline   Reply With Quote
Old 10-17-2005, 04:12 PM   #6
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default

[23:08] [☻AlcoBot☻] Error :: ModInvite - Invalid number of items in log data "Ta
iyo SiTEOP epoke".
[23:08] [☻AlcoBot☻] Debug :: ModReadLogs - Event disabled or callback returned f
alse, skipping announce.
[23:08] [☻AlcoBot☻] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[23:08] [☻AlcoBot☻] Debug :: ScriptExecute - The callback "::alcoholicz::Invite:
:LogEvent" for pre INVITE returned false.

i try some different setup ,host etc but no luck

can you give me an example of a valid host please ?
anyway i set it up false on check and host
tia
epoke is offline   Reply With Quote
Old 10-17-2005, 04:26 PM   #7
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default

don't know why but now if i set all to false it 's seem to work ( after restart and rehash of both site and eggdrop)
i'll try to make it hostCheck
epoke is offline   Reply With Quote
Old 10-17-2005, 05:41 PM   #8
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

At the momemt i`m using host and nick checks set to false. But when enabling them, i try to add a Nick to the users account i get an error:

10-17-2005 23:32:04 "..\scripts\siteInvite.tcl" terminated abnormally
--------------------------- ErrorInfo ----------------------------
23000 1062 {Duplicate entry 'PaRaNoiD_JaCK' for key 1}
while executing
"db "INSERT INTO invite_users(ftp_user,irc_user) VALUES('$ftpUser','$ircUser')""
(procedure "SetIrcUser" line 7)
invoked from within
"SetIrcUser $ftpUser $ircUser"
("USER" arm line 7)
invoked from within
"switch -- $event {
ADDHOST - ADDIP {
if {![IsTrue $hostCheck]} {
PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-19-2005, 08:40 PM   #9
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

epoke: You're using the wrong SITE INVITE command, please read the manual. (Hint: you need to use siteInvite.tcl, which is included with AlcoBot).

PaRaNoiD_JaCK: Thanks, that's a bug. It will be fixed for the next release.
neoxed is offline   Reply With Quote
Old 10-20-2005, 03:45 AM   #10
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default

neoxed ?
i'm using only the tcl (siteInvite.tcl) include in the AlcoBot.
the invite is working great only if i don't use host check as PaRaNoiD_JaCK said .
epoke is offline   Reply With Quote
Old 10-20-2005, 04:29 AM   #11
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

I hope this helps. When i restart the service and do site invite it does this in the partyline.

[11:26] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:26] [AlcoBot] Debug :: ModReadLogs - No variable definition for event, skipping announce.
[11:26] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:26] [AlcoBot] Debug :: ModReadLogs - No variable definition for event, skipping announce.

I rehash the windrop and the invite will work now. This is what`s in the party when it works tho:

[11:28] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:28] [AlcoBot] Error :: ModInvite - Invalid number of items in log data "PaRaNoiD_JaCK SITEOPS PaRaNoiD_JaCK".
[11:28] [AlcoBot] Debug :: ModReadLogs - Event disabled or callback returned false, skipping announce.
[11:28] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:28] [AlcoBot] Debug :: ScriptExecute - The callback "::alcoholicz::Invite::LogEvent" for pre INVITE returned false.
[11:28] [AlcoBot] Debug :: ModReadLogs - Event disabled or callback returned false, skipping announce.


i`m using the invite tcl script that was with alcobot 0.5.0, It`s been placed in the ioftpd scripts folder.

PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-20-2005, 05:47 AM   #12
epoke
Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 60
Default

it's seem to be the same error log .

ps : can i write a french tuto (or and an english one ) for your script ,tool and flashfxp cmd ?
if you need help ...
epoke is offline   Reply With Quote
Old 10-23-2005, 10:34 PM   #13
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Quote:
Originally Posted by PaRaNoiD_JaCK
[11:26] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:26] [AlcoBot] Debug :: ModReadLogs - No variable definition for event, skipping announce.
[11:26] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:26] [AlcoBot] Debug :: ModReadLogs - No variable definition for event, skipping announce.

I rehash the windrop and the invite will work now.
You receive this error because the invite module was not loaded, or failed to load initially.

Quote:
Originally Posted by PaRaNoiD_JaCK
[11:28] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:28] [AlcoBot] Error :: ModInvite - Invalid number of items in log data "PaRaNoiD_JaCK SITEOPS PaRaNoiD_JaCK".
[11:28] [AlcoBot] Debug :: ModReadLogs - Event disabled or callback returned false, skipping announce.
[11:28] [AlcoBot] Debug :: ModReadLogs - Received event: INVITE (log: 0).
[11:28] [AlcoBot] Debug :: ScriptExecute - The callback "::alcoholicz::Invite::LogEvent" for pre INVITE returned false.
[11:28] [AlcoBot] Debug :: ModReadLogs - Event disabled or callback returned false, skipping announce.


i`m using the invite tcl script that was with alcobot 0.5.0, It`s been placed in the ioftpd scripts folder.
First off, remove your old invite script (hint: Invalid number of items in log data). The siteInvite.tcl file logs five items for INVITE (user group groups flags nick), while other scripts, like ioA, log three items (user group nick).

Quote:
Originally Posted by epoke
ps : can i write a french tuto (or and an english one ) for your script ,tool and flashfxp cmd ?
if you need help ...
AlcoBot doesn't have any SITE commands, I suppose you are referring to nxTools? If that is the case, I will include a FlashFXP command pack in the next nxTools release. I do not plan on translating the readmes or documentation, but if you want to do it unofficially that's fine.
neoxed is offline   Reply With Quote
Old 10-24-2005, 06:24 AM   #14
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

I did have another invite script loaded:

invite = TCL ..\scripts\nxTools\nxUtilities.tcl INVITE

Theres still reference to it in the readme for nxtools on what command`s to add to the ioftpd.ini.

The problem with rehashing the bot was down to the bot using a TLS connection to ioftpd. When none is used, it will work first time.

PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-24-2005, 08:31 AM   #15
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

I know, but that doesn't change anything. You have to make a choice between AlcoBot's invite system or nxTools' invite system (which is depreciated now).
neoxed is offline   Reply With Quote
Reply

Tags
false, ftp, invite, setup, working

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:23 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)