Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-07-2005, 10:55 PM   #1
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default Alcoholicz Sitebot (AlcoBot) v0.4.0

Changes:
  • NEW: Online stats module, to view bandwidth usage and user activity (!bw, !speed, !who, etc.).
  • NEW: Support for alternative user/group stores (e.g. ioShareDb). Access to ioFTPD's user and group files is now done using shared memory.
  • NEW: Tcl version check, to ensure Tcl v8.4, or newer, is present.
  • CHG: The ioFTPD directory is now found automatically using the message window, so the "rootPath" ioFTPD configuration option is no longer necessary.
  • FIX: Login/logout announce for glFTPD when users do not have a tagline.
Notes:
  • Even though the change log is quite short, there was approximately 3000 lines of changed code (for the external ioFTPD Tcl interface).
Download:

http://www.inicom.net/pages/en.ioftp...pts.php?id=126

Website:

http://www.alcoholicz.com
neoxed is offline   Reply With Quote
Old 10-08-2005, 10:37 AM   #2
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

Is there anyway to turn off the !help trigger for AlcoBot. I`ve tried removing the help module in the
AlcoBot.conf to stop it from loading but the windrop wont start then. This is the error.

Error:

[17:31] [AlcoBot] Starting...
[17:31] [AlcoBot] Loading libraries...
[17:31] [AlcoBot] Loading configuration...
[17:31] [AlcoBot] Loading modules...
[17:31] [AlcoBot] Module Loaded: nxtools
[17:31] [AlcoBot] Module Unloaded: help
[17:31] [AlcoBot] Error :: Modules - no such binding

I`ve also tried changing the trigger. But it`ll still paste when !help is used.

# Help module.
!???nxhelp = +target=notice

Everything else is working great tho. Nice bot.
PaRaNoiD_JaCK is offline   Reply With Quote
Old 10-08-2005, 11:53 AM   #3
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Removing help from the modules option in AlcoBot.conf prevents the module from being loaded. I have tested this and it works as described. Maybe try restarting Eggdrop after removing the module.
neoxed is offline   Reply With Quote
Old 10-08-2005, 12:35 PM   #4
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

Yes it works now thanks.
PaRaNoiD_JaCK is offline   Reply With Quote
Reply

Tags
download, ioftpd, tcl, user, users

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:45 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)