Go Back   FlashFXP Forums > > > >

Harm's scripts ioBanana, Readd script, ioVote

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-15-2003, 01:10 PM   #1
ideal
Junior Member
 
Join Date: Nov 2003
Posts: 2
Default strange ioBanana behaviour

for some reason Windrop loads all .tcl files w/out error, i've checked paths/logins numerous times, and the following still happens every time Windrop loads:

[12:58] ioBanana 7c by Mouton & Harm: Attempting to connect to FTP...
[12:58] debug | Starting new connection with:
[12:58] debug | -port = 6655
[12:58] debug control | C: Connection from 127.0.0.1:6655
[12:58] debug | -> rc="220"
-> msgtext="ioFTPD [www: http://www.ioftpd.com] - [version: beta 5] server ready."
-> state="user"
[12:58] debug | ---> USER sitebot
[12:58] debug control | C: 220 ioFTPD [www: http://www.ioftpd.com] - [versio
n: beta 5] server ready.


the forums might make that a bit hard to interpret, sorry

it appears to me that the last line (right before it dies) isn't being parsed correctly (or at least isn't parsed like the first "control |" bit). i would take a look at the code if tcl didn't give me the willies

thanks for all the work you've done on ioB, it looks awesome and i look forward to using it
ideal is offline   Reply With Quote
Old 11-15-2003, 04:04 PM   #2
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Code:
<Botgbb> [16:00] debug      | Starting new connection with: 
<Botgbb> [16:00] debug      |   -port = 9998
<Botgbb> [16:00] debug     control | C: Connection from 127.0.0.1:9998
<Botgbb> [16:00] debug      | -> rc="220"
<Botgbb> -> msgtext="ioFTPD [www: http://www.ioftpd.com] - [version: beta 5] server ready."
<Botgbb> -> state="user"
<Botgbb> [16:00] debug      | ---> USER !sitebot
<Botgbb> [16:00] debug     control | C: 220 ioFTPD [www: http://www.ioftpd.com] - [version: beta 5] server ready.
<Botgbb> [16:00] debug      | -> rc="331"
<Botgbb> -> msgtext="Password required for sitebot."
<Botgbb> -> state="passwd"
<Botgbb> [16:00] debug      | ---> PASS orange
<Botgbb> [16:00] debug     control | C: 331 Password required for sitebot.
<Botgbb> [16:00] debug      | -> rc="230"
<Botgbb> -> msgtext="Welcome on ioFTPD demo server sitebot@NoGroup from pomme2003 (gb@127.0.0.1)"
<Botgbb> -> state="connect"
<Botgbb> [16:00] debug     control | C: 230-Welcome on ioFTPD demo server sitebot@NoGroup from pomme2003 (gb@127.0.0.1)
<Botgbb> [16:00] debug     control | C: 230-...
<Botgbb> [16:00] debug     control | C: 230 User sitebot logged in.
<Botgbb> [16:00] debug      | -> rc="   "
<Botgbb> -> msgtext=""
<Botgbb> -> state="type"
<Botgbb> [16:00] debug      | ---> TYPE I
<Botgbb> [16:00] debug      | -> rc="200"
<Botgbb> -> msgtext="Type set to I."
<Botgbb> -> state="type_sent"
<Botgbb> [16:00] debug     control | C: 200 Type set to I.
<Botgbb> [16:00] ioSS: FTP connection established - handle: 0
This is what a normal verbose/debug log should look like.
What u seem to be missing is the 331 answer to USER sitebot.

You probably included a %[execute()] cookie in your login msg and Harm needs to fix those since they show at the top of the login msg instead of in the middle, and they don't have any prefix.
Remove those %[execute()] cookies from your welcome.msg and it should work.
Btw, all this is explained in ioB faq.txt

If it doesn't work, what does the FFXP log look like when u login using the sitebot account from localhost ?
Mouton is offline   Reply With Quote
Old 11-16-2003, 01:30 AM   #3
ideal
Junior Member
 
Join Date: Nov 2003
Posts: 2
Default

there are no %[execute()] cookies in welcome.msg (or any other /ftp/*.msg files) .. i read that in ioBanana's docs and checked it before making the post.
using FFXP works as expected. no errors or anything, i think i'm just going to workaround having to use windrop.

thanks for your prompt reply
ideal is offline   Reply With Quote
Old 11-16-2003, 09:39 AM   #4
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

The problem is that the answer to USER xxx is not valid.
FFXP doesn't really care, so it works, but eggdrop can't work when it receives invalid replies.
Maybe u got debug=1 in your iobanana.ini or something similar.

Thus why i asked to see the login sequence from ffxp to be able to pinpoint the problem.
Mouton is offline   Reply With Quote
Old 12-26-2003, 01:50 PM   #5
g!zMo
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

i have a similar error:

Quote:
.
.
.
[19:40] debug control | C: 230 User xxx logged in.
[19:40] debug | -> rc=" "
-> msgtext=""
-> state="type"
[19:40] debug | ---> TYPE I
[19:40] debug | -> rc="200"
-> msgtext="Type set to I."
-> state="type_sent"
[19:40] debug control | C: 200 Type set to I.

C:\Windrop>
it seems that windrop logs in correctly but when the "connection established" message should show up it just exists...

i read through the readme an faq but cannot find the reason for this behaviour
g!zMo is offline   Reply With Quote
Old 12-26-2003, 02:32 PM   #6
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

What eggdrop and TCL version?

I had problems with similar FTP library's on the latest eggdrop cvs 1.6.16, but thats due to tcl bugs in 1.6.16.
neoxed is offline   Reply With Quote
Old 12-26-2003, 07:36 PM   #7
g!zMo
Junior Member
 
Join Date: Dec 2003
Posts: 11
Default

i've upgraded to 1.6.16 and now it seems to work
g!zMo is offline   Reply With Quote
Reply

Tags
control, debug, ftp, http://www.ioftpd.com], [1258]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Long filenames mullbank General Discussion 2 11-12-2004 03:02 PM
.ioFTPD files bug in 4.5.4 WarC Bug Reports 1 02-27-2003 04:31 AM


All times are GMT -5. The time now is 12:45 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)