Go Back   FlashFXP Forums > > > >

Harm's scripts ioBanana, Readd script, ioVote

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-17-2005, 03:13 PM   #1
eger
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2003
Posts: 40
Default [Fixed] ioBvar(disable,SECTION) "ANNOUNCE" not working?

Was trying to disable some announces in the ioBanana.tcl for ioB2 and was still seeing the announces for that section. For example:

set ioBvar(disable,0DAY) "NEWDIR"

Still announced the NEWDIR for the 0DAY section. Is this correct syntax? I have only tested with this section. I have not tried to test another section yet so i'm not sure if it has to do with the '0' in 0DAY stopping something from working. Though I don't have a SystemError.log so it doesn't look like any errors are happening on the bot.

Thanks!
eger is offline   Reply With Quote
Old 11-18-2005, 04:18 PM   #2
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

First, I welcome the opportunity to mention that the SystemError.log logfile is an ioFTPD logfile and doesn't contain events generated by the bot.

Then, have you rehashed to bot after changing this configuration setting ? Could you also try using another message type at the same time (preferably not DELDIR) ? Is the section correctly identified ? And finally, is the message type redirected to some other channel ?
Harm is offline   Reply With Quote
Old 11-19-2005, 01:39 PM   #3
eger
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2003
Posts: 40
Default

Usually the SystemError.log will show errors form tcl scripts though. That is why I mentioned it. I have rehashed the bot and tried using other message types and other sections. heres what I found.

Not working:
ioBvar(disable,0DAY) "NEWDIR"
ioBvar(disable,0DAY) "NUKE"
ioBvar(disable,0DAY) "DIZ"
ioBvar(disable,0DAY) "WIPE"
ioBvar(disable,MP3) "NEWDIR"

Working:
ioBvar(disable,MP3) "NUKE"

I just did a little testing and actually disable is hit or miss. Sometimes it will work and sometimes it will not. Not sure whats going on. Sections are correctly identified and they are not redirected to any channels. I'm stumped... Wonder if it has something to do with the color per section hack..
eger is offline   Reply With Quote
Old 11-19-2005, 01:46 PM   #4
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

It's a list. You are currently overriding all your settings each time you try to add an announce to the list.

Try:
set ioBvar(disable,0DAY) "NEWDIR NUKE DIZ WIPE"
set ioBvar(disable,MP3) "NEWDIR NUKE"
Harm is offline   Reply With Quote
Old 11-19-2005, 02:57 PM   #5
eger
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2003
Posts: 40
Default

Ah thanks Harm. I didn't realize it was a list. Maybe the example should show it's a list by using 2 or more instead of one in the example.
eger is offline   Reply With Quote
Reply

Tags
0day, announces, newdir, section, working

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:10 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)