Go Back   FlashFXP Forums > > > >

Harm's scripts ioBanana, Readd script, ioVote

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-04-2005, 10:24 AM   #1
[-AzAZeL-]
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 21
Default [Latest] symlink does not work.

Like the title says,

###; The [Latest] symlink will be created there
set dupe(latest) "C:/ioFTPD/site"

With these settings there will be no [Latest] symlinks in my folder.

Runningt latest iob v2.0 with 5.8.5r
[-AzAZeL-] is offline   Reply With Quote
Old 09-04-2005, 11:19 AM   #2
router
Member
ioFTPD Registered User
 
Join Date: Mar 2005
Posts: 26
Default

Well, i have thhe same problem and in addition there isn't MP3 genre info displayed in [complete] tag, like in iobanana v20.
Iobanana v20 has also option to customize how many [latest] symlinks will be created and their length.
router is offline   Reply With Quote
Old 09-05-2005, 03:04 AM   #3
[-AzAZeL-]
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 21
Default

searching was the key, and the new windrop the problem...
[-AzAZeL-] is offline   Reply With Quote
Old 09-07-2005, 01:47 PM   #4
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

I can't see how windrop could disable the [latest] symlinks since it doesn't interact with them at all. The main known reason for those symlinks not to be active is a detail I forgot to add to the documentation. There's a setting in ioCONFIG.itcl called $dupe(dupelogs); search for "set dupe(dupelogs)". This value is the path to a directory that will be used to store the dupelogs. This directory must be created by hand.
Harm is offline   Reply With Quote
Old 09-07-2005, 03:56 PM   #5
[-AzAZeL-]
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 21
Default

ok, i see, now it's working, but it only creates Latest- bla bla, before it was [Latest]-bla bla,
with the new iob2 on my bot I cant send site commands thru the bot nemore, or some does still work, like '.site who' but ".site uinfo nick" returns: SITE {uinfo: Command not understood.

thnx, for an excellent script and all the support!
[-AzAZeL-] is offline   Reply With Quote
Old 09-08-2005, 01:57 AM   #6
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

I will investigate this asap. Have you replaced your old ftp.tcl with the new one ?
Harm is offline   Reply With Quote
Old 09-08-2005, 04:18 AM   #7
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

I have manually created the dupe dir, and now it creates latest symlink fine, ut I have 2 problems:
1) if I wipte the dir, symlink will be still there and have to be removed manually.
2) If a dir is created in /+GROUPS/* path, there will be a symlink for that dir too
even if my config file looks like this:
###; No dupechecking in these dirs
set zs(excluded,dupe) "/+GROUPS*"
That's a major problem for me
oldhouse is offline   Reply With Quote
Old 09-08-2005, 01:59 PM   #8
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

1. Indeed and that's the expected behaviour. This symlink shows the latest created directory. I don't think I'll ever add something to remove it on wipe or rmd because it's time and cpu consuming and finally pointless. Why should the script check everytime you wipe or remove a directory if it was the latest one ? This shouldn't happen more than 1% of the time.. even less if you are using the wipe command to do warchive's job manually And most of all, the symlink is replaced by a new one the next time someone uses MKD; and that happens quite often if you need such a symlink.

2. That's pretty odd. Are your users also seing this directory like this (same name, same location, etc.) ? Do you have any message in the ..\logs\SystemError.log file ?

To reply to the old messages, there's indeed no mp3 genre info in the default mp3 complete tag. You have access to the source code so you can add it easily. Everything is customizable even if it looks hardcoded. If it's not in a config file it's only because it doesn't need to be changed often.. the script is faster this way.

Regarding the latest and latestpre symlinks, their number will most probably be customizable in the next release.
Harm is offline   Reply With Quote
Old 09-08-2005, 03:37 PM   #9
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

Ok for first part, no problem at all.
For the second part: No error in log file. And the dir that appeared in latest symlink was created in a subdir of /+GROUPS/predir but as it was in previous version /+GROUPS* should cover also all subdirs.
oldhouse is offline   Reply With Quote
Old 09-11-2005, 10:23 PM   #10
ko0ky
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 28
Default

hey oldhouse try setting the following in ioCONFIG.itcl

###; No dupechecking in these dirs
set zs(excluded,dupe) "/pre*"

I just fixed my latest with this information and testing new folder in pre dir, it does NOT show up in latest. So looks like your problem might be a config error.

Check it out.

ko0ky
ko0ky is offline   Reply With Quote
Old 09-12-2005, 12:52 AM   #11
[-AzAZeL-]
Junior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jun 2004
Posts: 21
Default

Harm: the ftp.tcl is from 2005.08.26
[-AzAZeL-] is offline   Reply With Quote
Reply

Tags
folder, symlink, symlinks, v2.0, [latest]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:39 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)