Go Back   FlashFXP Forums > > > >

Eggdrop All eggdrop related questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-20-2007, 08:24 AM   #16
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

according to Yil ioftpd cant handle ipv6 yet, dont know if there are any ftp clients that do also, maybe flashfxp - but i cant find anything that says if it does or doesnt
ArtX is offline   Reply With Quote
Old 07-20-2007, 03:53 PM   #17
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Carpo, i get tcl84.dll not found error here with your latest package
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 07-20-2007, 03:59 PM   #18
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

god damnit!!! i think i see why now, although i told it not too something containing that lib has put an entry in my PATH and so its not showing as being missing here, grab the tcl libs from my site and add them, now im getting errors that alcobot wont start and its after removing that path variable

Last edited by ArtX; 07-20-2007 at 04:08 PM.
ArtX is offline   Reply With Quote
Old 07-20-2007, 04:01 PM   #19
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

And megahall module won't run on 1.6.18 can't find modules it says
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 07-20-2007, 04:20 PM   #20
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

whats that ? i think i have the answer but its too late for me to do anything now - i will have to see about it in the morn
ArtX is offline   Reply With Quote
Old 07-21-2007, 03:29 AM   #21
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by Carpo View Post
whats that ? i think i have the answer but its too late for me to do anything now - i will have to see about it in the morn
MegaHal is a AI module that can be found on egghelp.org
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 07-21-2007, 03:49 AM   #22
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

seems if i use the way described on windrop site to make windrop it will compile yet alcobot gives loads of errors - if i update the libs in a stand alone way it wont compile, yet if i install activetcl it will allow the updated libs, but as soon as you remove active tcl even if you have copied the libs to windrop dir alcobot wont load saying it cant find a file has anyone tested this bot on any other sitebot script ?
ArtX is offline   Reply With Quote
Old 07-21-2007, 05:31 AM   #23
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by Carpo View Post
seems if i use the way described on windrop site to make windrop it will compile yet alcobot gives loads of errors - if i update the libs in a stand alone way it wont compile, yet if i install activetcl it will allow the updated libs, but as soon as you remove active tcl even if you have copied the libs to windrop dir alcobot wont load saying it cant find a file has anyone tested this bot on any other sitebot script ?
Never used alcobot so dunno, having trouble setting it up (to lazy to read whole thing) trying other scripts i normaly use later such as ioA, ioBanana etc

Compiling newer version with all the things i think is fun or good to have but it gives error's on:
Code:
../botnetop.o: In function `tcl_bop_reqop':
/eggdrop1.6.18/src/mod/botnetop.mod/.././botnetop.mod/tclcmds.c:26: undefined re
ference to `_Tcl_AppendResult'
../botnetop.o: In function `tcl_bop_letmein':
/eggdrop1.6.18/src/mod/botnetop.mod/.././botnetop.mod/tclcmds.c:33: undefined re
ference to `_Tcl_AppendResult'
collect2: ld returned 1 exit status
make[2]: *** [../../../botnetop.so] Error 1
make[2]: Leaving directory `/eggdrop1.6.18/src/mod/botnetop.mod'
make[1]: *** [botnetop.mod_so] Error 2
make[1]: Leaving directory `/eggdrop1.6.18/src/mod'
make: *** [modules] Error 2
Did that work for you?

:update:
Compiling with extra modules added makes modules dir almost empty, kinda strange
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1

Last edited by whocarez2k5; 07-21-2007 at 05:53 AM.
whocarez2k5 is offline   Reply With Quote
Old 07-21-2007, 06:00 AM   #24
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

what version of tcl are you using
ArtX is offline   Reply With Quote
Old 07-21-2007, 06:09 AM   #25
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by Carpo View Post
what version of tcl are you using
I tryed with version 8.4.15 but that was a no go so reverted back 8.4.14

I noticed when compiling default as explained modules where going good 1 by 1 until i do botnetop it keeps giving those error's
botnetop.mod is fixed. it seems some scripts need a little change in MakeFile when compiling in Cygwin
Code:
Open the modules Makefile with a text editor

Change all the .so to  .$(MOD_EXT)

Add a space and $(XLIBS) at the end of $(LD) line
Quote:
Originally Posted by Carpo View Post
....................... as for the 32 nick handle if you read eggdrop.h you will see that is says to leave that alone and change it in eggdrop.conf
A Late reply on this but imo you need to change it still to 32!!!

Code:
/*
/*
 * HANDLEN note:
 *       HANDLEN defines the maximum length a handle on the bot can be.
 *       Standard (and minimum) is 9 characters long.
 *
 *       Beware that using lengths over 9 chars is 'non-standard' and if
 *       you wish to link to other bots, they _must_ both have the same
 *       maximum handle length.
 *
 * NICKMAX note:
 *       You should leave this at 32 characters and modify nick-len in the
 *       configuration file instead.
 */
#define HANDLEN 32   /* valid values 9->NICKMAX  */
#define NICKMAX 32  /* valid values HANDLEN->32 */
I think you based your answer on the NICKMAX note and not the HANDLEN
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1

Last edited by whocarez2k5; 07-21-2007 at 10:40 AM.
whocarez2k5 is offline   Reply With Quote
Old 07-22-2007, 06:46 PM   #26
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

dns issue is fixed its not 0.9.7 or the 1.0.x of minires its more the fact that bind is not installed (nor anywhere in cygwin as far as i could see) have found bind and its working fine, still getting the errors about alcobot and dzsbot not finding log files when path is fine
ArtX is offline   Reply With Quote
Old 07-22-2007, 08:47 PM   #27
razoor
Senior Member
ioFTPD Foundation User
 
Join Date: Oct 2006
Posts: 163
Default

works like a charm for me. finaly i don´t see those nasty krasches that killed my bot all the time before. =)
razoor is offline   Reply With Quote
Old 07-23-2007, 04:25 AM   #28
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

do you use dzsbot or alcobot ? as these are the two that are giving me issue says that they can never fin c:/ioFTPD/logs/xxxx.log - yet they are there - have checked nexord forum but no clues there, thats the only sticking point atm, other than that its all working fine here
ArtX is offline   Reply With Quote
Old 07-23-2007, 07:19 AM   #29
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by Carpo View Post
dns issue is fixed its not 0.9.7 or the 1.0.x of minires its more the fact that bind is not installed (nor anywhere in cygwin as far as i could see) have found bind and its working fine, still getting the errors about alcobot and dzsbot not finding log files when path is fine
According to some other sites most people aren't happy with bind and it shouldn't be needed because version 0.97-1 from minires should fix that dns issue.
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 07-23-2007, 03:13 PM   #30
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Any1 want to test this version?

For some reason it won't recognize me as bot owner when doing /msg bot hello
This version uses minires 0.97-1 (DNS resolve issue fixed!)

http://rapidshare.com/files/44613431...8_SSL.rar.html
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Reply

Tags
error, giving, scripts, tcl, working

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:08 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)