Go Back   FlashFXP Forums > > > >

Eggdrop All eggdrop related questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-27-2007, 01:33 AM   #1
mo3head
Junior Member
 
Join Date: May 2007
Posts: 1
Default how to get it windrop to work with ioftpd?

hey,
i just wonder how can i get both work together?
is there any tut for it or something else?
i dunno wat i should do to bind it in oftpd.ini ?
thanks for any help
mo3head is offline   Reply With Quote
Old 05-27-2007, 10:29 AM   #2
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Make sure your windrop runs on manual usage; now lets make it ioFTPD auto

1. Get PsTools from Microsoft.

2. Make a .bat file out of this and stick it under ioFTPD\scripts\ folder. Call the .bat file BotChk.bat

----------------- C/P below to the .bat file -----------------

@echo off
set Systemroot=C:\WINDOWS
set path="D:\ioFTPD\scripts\pstools"
E:
cd "D:\ioFTPD\eggdrop"

rem Change this to the name of your bot's config:
set botscript=eggdrop.conf

rem Change this to the handle/botnet-nick of your bot:
set botname="sitebot"

rem Change this to the name of your bot's userfile:
set userfile=sitebot.user

rem You probably don't need to change anything below here....
if exist .share* del .share*
if exist *.stackdump del *.stackdump
if exist *.tmp del *.tmp
if not exist %botscript% echo Config file (%botscript%) missing.
if not exist %botscript% goto cantload
if exist %userfile% goto checkrunning
if exist %userfile%~new ren %userfile%~new %userfile%
if exist %userfile% echo Missing userfile... Using the last saved one..
if exist %userfile% goto checkrunning
if exist %userfile%~bak ren %userfile%~bak %userfile%
if exist %userfile% echo Missing userfile... Using the last backed up one..
if exist %userfile% goto checkrunning
if not exist %userfile% echo Userfile missing. No backup/last saved userfile either. =/
goto cantload

:checkrunning
pslist egg > nul
if errorlevel 1 goto restart
goto end

:restart
set result=
if not exist eggdrop.exe echo eggdrop.exe not found!
if not exist eggdrop.exe goto cantload
echo Restarting Eggdrop...
eggdrop.exe -nt
if errorlevel 8 echo Possibly Missing .dll File(s)? (tcl8*.dll, cygwin1.dll)
if errorlevel 8 goto cantload
goto success

:cantload
echo Could not reload the bot. =(
goto end

:success
echo Successfully Started Eggdrop (%botname% - %botscript%).

:end

------------------ CODE end after :end ----------------------------

3. Add this line to your ioFTPD.ini file.

################################ SCHEDULER ################################
BotChk = 00,15,30,45 * * * EXEC D:\ioFTPD\scripts\BotChk.bat

########################### FTP CUSTOM COMMANDS ###########################
botchk = EXEC ..\scripts\BotChk.bat

############################# FTP PERMISSIONS #############################

botchk = 1M

4. Restart your ioFTPD. Bot should autoload/autocheck if died etc ...

Good luck, make sure your windrop run at manual mode before settingit up with this audoload/check settings.
Flow is offline   Reply With Quote
Old 06-04-2007, 02:25 AM   #3
Bygone
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 20
Default

Hi Flow

Thanks for the guide to the botchk'er, i have one question. Does your bat file need ioftpd 6.1.4? cause on 5.8.5r i cant get it to work...

...when i activate the botchk.bat manually inside a cmd prompt, it starts and runs fine. If i activate it inside a ftp client via ioftpd and "site botchk" then the executable pslist.exe hangs and dont come further...when i then kill pslist.exe thread (which is only way to make it stop) then i get info inside ftp client window that it cant find my userfile, which puzzles me as it runs from a cmd prompt.

...any suggestions?
Bygone is offline   Reply With Quote
Old 06-04-2007, 04:12 AM   #4
Bygone
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 20
Default

Problem located...i needed to alter the logon user for ioftpd service to a real user instead of system account, then it works like a charm...
Bygone is offline   Reply With Quote
Old 06-04-2007, 09:23 AM   #5
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

Have fun

You can even turn the .bat file to an .exe application file. Why? It load faster. I use this small Free app. Works really well. Be sure changing the ioFTPD.ini file to .exe aswell if you plan to use it as one.

Bat To Exe Converter

Last edited by Flow; 06-04-2007 at 12:33 PM.
Flow is offline   Reply With Quote
Old 03-18-2008, 01:18 PM   #6
_gordon_
Junior Member
 
Join Date: Mar 2008
Posts: 10
Default

it wont connect to irc server for me :/
i dont know whats wrong but it stops at this point..

[R] 200-Successfully Started Eggdrop ("sitebot" - eggdrop.conf).
[R] 200 Command successful.

when running it manually from cmd promt it works ok
_gordon_ is offline   Reply With Quote
Old 05-07-2008, 03:22 AM   #7
LiMoE
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2006
Posts: 9
Default

yeah same problem anyone can fix it or have an other idea?
LiMoE is offline   Reply With Quote
Old 06-07-2008, 08:21 AM   #8
razoor
Senior Member
ioFTPD Foundation User
 
Join Date: Oct 2006
Posts: 163
Default

annyone know why this aint working with windrop.1.6.18.with.ssl.and.Tcl.8.5.v0.4.by.ronin. rar

Or is it just me that have some problem.
It starts, but then i just get -
Successfully Started Eggdrop ("botnick" - eggdrop.CONF).
Then it dies.
__________________
ioFTPD 7.0.3 nxTools ioNiNJA ioJM http://ioftpd.zapto.org /
razoor is offline   Reply With Quote
Old 03-28-2009, 01:07 PM   #9
ZnowZtorM
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2004
Posts: 25
Lightbulb not so secure

do this instead use the service thats all ready included in windows to install any app as a service
INSTSRV.EXE
NETSVC.EXE
SRVANY.EXE

and put the in the same dir as the eggdrop or download the free GUI called pk's Service installer
and most important when u use the SSL on the bot!!
eggdrop -m eggdrop.conf -n

eggdrop -mode then.name.off.cfg.file -n
__________________
-[ If the Ocean was Whiskey and I was a duck, I'd swim to the bottom and drink my way up! ]-
ZnowZtorM is offline   Reply With Quote
Old 03-31-2009, 03:58 AM   #10
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default Installed PSTools yet?

Quote:
Originally Posted by _gordon_ View Post
it wont connect to irc server for me :/
i dont know whats wrong but it stops at this point..

[R] 200-Successfully Started Eggdrop ("sitebot" - eggdrop.conf).
[R] 200 Command successful.

when running it manually from cmd promt it works ok
Um, iv seen that somewhare before. If im not mistaken is was the PSTools firstlaunch. You know, when you haveto read and press the license agreement before usage. Have you seen that popup from PSTools yet?

and these below haveto be edited to match your bot settings.

Quote:
@echo off
set Systemroot=C:\WINDOWS
set path="X:\ioFTPD\scripts\pstools"
X:
cd "X:\ioFTPD\eggdrop"

rem Change this to the name of your bot's config:
set botscript=eggdrop.conf

rem Change this to the handle/botnet-nick of your bot:
set botname="changeme"

rem Change this to the name of your bot's userfile:
set userfile=changeme.user
Flow is offline   Reply With Quote
Reply

Tags
bind, dunno, oftpd.ini, wat, work

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:48 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)