Go Back   FlashFXP Forums > > > >

Eggdrop All eggdrop related questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-12-2005, 10:38 AM   #1
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default Starting sitebot from site

Hey all

I'm trying to use this bat file to start sitebot from the login event on the ftp when not running:

@echo off
CD x:\path
pslist eggdrop > nul
IF ERRORLEVEL 1 GOTO restart
ECHO Sitebot is currently running
GOTO END

:RESTART
CD x:\path
start hidewndw /r /n eggdrop.exe -nt eggdrop.conf
ECHO Sitebot is currntly down (attempting to restart)

:END

It seems to work a treat however when bot is started this way !bw and !sped wont work, returning a tcl error (Tcl error [proc_bandwidth]: couldn't duplicate input handle: bad file number).

I've tried using hiderun instead of hidewndw and it worked perfectly other than it freezes the ftp session just after starting the bot if its down (but !bw does work) so it certainly seems to be a hidewndw issue.

Either of these issues is not very appealing :/

I'm using dzsbot.

Anyone have any ideas?

Cheers

Scratch that, I found the answer.

In case anyones interested it needed quotations around 'eggdrop.exe -nt eggdrop.conf'.
EwarWoo is offline   Reply With Quote
Old 11-12-2005, 11:04 AM   #2
PaRaNoiD_JaCK
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 101
Default

I see you got the answer before i posted
PaRaNoiD_JaCK is offline   Reply With Quote
Reply

Tags
ftp, hidewndw, restart, sitebot, work

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:21 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)