Old 10-03-2004, 09:32 PM   #1
CP-Geek
Junior Member
 
Join Date: Oct 2004
Posts: 12
Default How to increase speed on dZSbot's output?

Howdyho.

I think I really should thank You ppl for some great script's! I can't imagine how I could do without them

But. As usual, there's a but coming.

How could I increase the speed bot print's stuff to irc? I don't have to care about flood, I have a dedicated channel for my server, and it's obly for my use. I already disabled floodcontro, but couldn'y find any speed-settings for dZSbot?

I'm using ioFTPD 5.8.4u + dZSbot 1.15 + Eggdrop 1.6.16+hpux (Windrop) on Windows 2003

CP
CP-Geek is offline   Reply With Quote
Old 10-03-2004, 11:28 PM   #2
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default Re: How to increase speed on dZSbot's output?

When you say, "I have a dedicated channel for my server" I am assuming you run your IRCd? Since anyone can create their own “dedicated”, channel by doing /join #<random channel>.

Most IRCds have a relatively low RecieveQ (how many lines can be recieved by a client) as a preventative measure against flooding. When you say you have "disabled floodcontrol" this could mean many things. With bahamut based IRCds (maybe others?) you can create a seperate client class with a larger RecieveQ. Some IRCd's have a designated user-mode or channel-mode (UnrealIRCd) which exempts a used from these limits.

If you have in fact disabled/exempted the Eggdrop from such anti-flood measures, you could try increasing the max message queue in your Eggdrop's configuration file. The configuration directive is called max-queue-msg, you could try increasing it (if you don't have it, add it).

Quote:
Excerpt from a default eggdrop.conf
# Set here the maximum number of lines to queue to the server. If you're
# going to dump large chunks of text to people over IRC, you will probably
# want to raise this. 300 is fine for most people though.
set max-queue-msg 300
You could also try replacing all "putserv" and "puthelp" commands with "putquick" in dZSbot.tcl, which prioritizes the output to IRC.
neoxed is offline   Reply With Quote
Old 10-04-2004, 11:09 AM   #3
CP-Geek
Junior Member
 
Join Date: Oct 2004
Posts: 12
Default

I re-installed my IRCd, just to be sure. But no, the problem is either in windrop, dZSbot or ioFTPD, the output for example !help is extremely slow. Maybe a line per second, and that is too low.

It's not question of power, setup run's on XP2800+ w. 512 MB memory, and it's definetly not maxed yet

Any ideas?

CP
CP-Geek is offline   Reply With Quote
Old 10-04-2004, 04:16 PM   #4
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

Quote:
Originally posted by CP-Geek
Any ideas?
Yeah...I gave you two possible solutions, re-read my previous post (the last two points).
neoxed is offline   Reply With Quote
Old 10-04-2004, 04:39 PM   #5
CP-Geek
Junior Member
 
Join Date: Oct 2004
Posts: 12
Default

I tried all those before I posted. (Sorry dude, just forgot to mention that, my bad) but it's still sluggish. I think I saw a very little speed increase on "putquick", but it's barely anything to talk about. If my file server wasn't on windows I'd drop all these to one of my debian's

CP
CP-Geek is offline   Reply With Quote
Reply

Tags
disabled, dzsbot, increase, obly, speed

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't let me connect Aingeal General Discussion 2 01-01-2005 05:34 PM


All times are GMT -5. The time now is 08:27 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)