Old 11-21-2003, 01:40 PM   #181
Luke
Member
 
Join Date: Oct 2003
Posts: 50
Unhappy

-removed-

Luke is offline   Reply With Quote
Old 11-21-2003, 02:07 PM   #182
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default

all modifications of dzsbot are welcome to share with everyones

- announces skins
- modifications of code
- etc ...

but please i would like to ask everyones to create your own thread to share modifications and let this thread for bug reports or requests

very big thx in advance
bounty
bounty is offline   Reply With Quote
Old 11-23-2003, 01:07 PM   #183
axora
Disabled
 
Join Date: Nov 2003
Posts: 4
Default

Hi there!

I installed the dzsbot and now i have got one problem/question.
The bot announces actions like new dir/delete dir/race stats etc. without problems and absolutely correct, but it doenst react on channel commands like !who oder !bw. The only channel command that works is !help.

Anyone who knows what could be wrong?
Would be nice.

Thanks in advance.
axora is offline   Reply With Quote
Old 11-23-2003, 01:15 PM   #184
-=DoBBeR=-
Senior Member
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 298
Default

what info does the bot give you in dcc or telnet?
-=DoBBeR=- is offline   Reply With Quote
Old 11-23-2003, 01:53 PM   #185
axora
Disabled
 
Join Date: Nov 2003
Posts: 4
Default

On !bw command, on telnet appears:
[19:52] Tcl error [proc_bandwidth]: couldn't duplicate input handle: bad file number
axora is offline   Reply With Quote
Old 11-23-2003, 02:00 PM   #186
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default

Quote:
Originally posted by axora
On !bw command, on telnet appears:
[19:52] Tcl error [proc_bandwidth]: couldn't duplicate input handle: bad file number
RTFM
bounty is offline   Reply With Quote
Old 11-23-2003, 02:27 PM   #187
axora
Disabled
 
Join Date: Nov 2003
Posts: 4
Default

Oh, $me should be beaten for that. Sorry
I just checked telnet after dobber mentioned that. So i didnt recognize the manual-entry for that before.
axora is offline   Reply With Quote
Old 11-25-2003, 07:00 AM   #188
ko0ky
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 28
Default sitebot

hey man, great script but I am having a bit of a problem.

I have tried two different installations following everything in the documentation and I get the same results.

I can not get sitewho command to process any commands as far as I can tell. !who, !bw, !uploaders and the rest of the commands basically tell me no one is online. I don't get any errors displayed in the bot console window or dcc chat window when using these errors, as I said.. the bot replies back with no users online.

everything else seems to be working fine tho, the bot will display new uploads, stats, uptime and the other stuff. (except for !new and I read I had to get newdir for that to work, ill try that)

I'm wondering if you have any suggestions.

I just downloaded ioFTPD, and everything else, it all seems to be the latest stuff.

hey man thanks in advance,

ko0ky
ko0ky is offline   Reply With Quote
Old 11-25-2003, 07:07 AM   #189
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

is your version of ioFTPD 5.2.11 or later? (the free version 5.2.9 has a separate 5.2.14 update)
sitewho.exe won't work on earlier versions
ADDiCT is offline   Reply With Quote
Old 11-25-2003, 07:12 AM   #190
ko0ky
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 28
Default

Quote:
Originally posted by ADDiCT
is your version of ioFTPD 5.2.11 or later? (the free version 5.2.9 has a separate 5.2.14 update)
sitewho.exe won't work on earlier versions
damn i feel really stupid now. This indeed was my problem and everything so far seems to be working. thanks for your prompt reply and sorry Im such a newb.

thanks again!
ko0ky is offline   Reply With Quote
Old 11-26-2003, 05:36 PM   #191
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default dzsbot v1.03 out

here we go m8s with a new version of dzsbot

!!! IMPORTANT !!!

for ranking announce you must add a cookie in your zipscript log STATS:

here is the modification for ioZS:

search the original line:
STATS_USERTOP=STATS: "$pwd" "$cnt. $bold$user$bold/$group [$uppedsize/$uppedfilesF/$percent%/$speedKB/s]"

and replace by:
STATS_USERTOP=STATS: "$pwd" "$cnt. $bold$user$bold/$group [$uppedsize/$uppedfilesF/$percent%/$speedKB/s] - rank:$user"

here the cookie is rank:$user

and dzsbot will replace it automatically !

have fun
bounty
bounty is offline   Reply With Quote
Old 11-27-2003, 05:30 PM   #192
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default other ranking announce setup

for ranking announce you must add a cookie in your zipscript log STATS:

here is the modification for project-zs/zipscript-c

search for line:
#define user_top "%n. %B%u%B/%-10g [%.1mM/%fF/%.1p%%/%.0sKB/s]"

and replace with:
#define user_top "%n. %B%u%B/%-10g [%.1mM/%fF/%.1p%%/%.0sKB/s] - rank:%u"

here the cookie is rank:%u



here is the modification for php_psio

search for line:
$user_top = "STATS: \"%v\" \"%n. %B%u%B/%g [%mM/%fF/%p%/%sKB/s]\"";

and replace with:
$user_top = "STATS: \"%v\" \"%n. %B%u%B/%g [%mM/%fF/%p%/%sKB/s] - rank:%u\"";

here the cookie is also rank:%u

have fun
bounty
bounty is offline   Reply With Quote
Old 11-27-2003, 06:04 PM   #193
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default other ranking announce setup

for ranking announce you must add a cookie in your zipscript log STATS:

here is the modification for badaazs itcl zipscript

!!! you need to change this twice !!!

search for line:
set dzstatu "$dzstatu$uamnt\. [b][lindex $line 0][b]/$groupt \[[format %.1f $mbfu]\mB/$filet\F/$perc\%/[format %.1f $spfu]\KBs\] [c]4[b]\(†[b] $tagwin [b]†\)[c]|"

and replace with:
set dzstatu "$dzstatu$uamnt\. [b][lindex $line 0][b]/$groupt \[[format %.1f $mbfu]\mB/$filet\F/$perc\%/[format %.1f $spfu]\KBs\] [c]4[b]\(†[b] $tagwin [b]†\)[c] - rank:[lindex $line 0]|"

here the cookie is rank:[lindex $line 0]

have fun
bounty
bounty is offline   Reply With Quote
Old 11-29-2003, 09:53 AM   #194
Psychosis
Member
ioFTPD Foundation User
 
Join Date: May 2003
Posts: 45
Default

I got several problems with new dzsbot 1.03. When i do !bw it gives me this:

[BW] + Uploaders: ParseTemplateFile()@ERROR:kb/sec - Leechers: template@->kb/sec - Idlers: file - Total: missing:@iskb/sec

for !wkup 10 it gives me this:

ERROR: "user_file" is not a valid file.

other commands give bogus output too such as !leechers, !idlers, !uploaders, etc etc.

Anyone have any idea what is going on. I just replaced me dzsbot 1.0.0 with this one.....edited all the variables just like 1.0.0.

NM, LOL I FIXED IT.....I was in a hurry and didn't edit the new iogroups, uptime, and sitewho ini's .
Psychosis is offline   Reply With Quote
Old 11-29-2003, 09:57 AM   #195
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

edit sitewho.ini correctly
ADDiCT is offline   Reply With Quote
Reply

Tags
bounty, dzsbot, fun, link, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:12 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)