Old 11-30-2005, 02:59 AM   #1
default
Junior Member
 
Join Date: Nov 2005
Posts: 2
Question REQUEST problem with the user

Hello, this is my problem, i have try to edit variables in the tcl code but nothing...
I have ioftpd 0.5.84u - ioa 2.0.3 - dZSbot 1.15

When i start a new request using raw ftp command no problem all its good and this is the result:

[L] 250--[Request]----------------------------------------------------------------------
[L] 250- [001] [test ] -> just.a.test

and i have in the request dir a [REQ]-just.a.test with owner account "test"

but if i try to add a reuest using !reqadd command (all have +o flag) the request is added but the owner of the dir is "nobody" and if i make !requests the result is a request without the requester.

[4:40am] Bot: -[Request]----------------------------------------------------------------------
[4:40am] Bot: [004] [ ] -> just.a.test.B

and

[L] 250--[Request]----------------------------------------------------------------------
[L] 250- [004] [ ] -> just.a.test.B


anyone know like fix this thing and passing to ioa over the request also the user that adding... tnx for help!
default is offline   Reply With Quote
Old 11-30-2005, 04:20 AM   #2
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

I dont think you can.
Users tend to have different nicks on irc to their site usernames a lot of the time so having this feature enabled would lead to errors.
Request_IRC_Uid = 0
Ensure in ioA that is set to a valid user and it will stop it coming up blank and instead will show up as that user.
EwarWoo is offline   Reply With Quote
Old 11-30-2005, 01:51 PM   #3
default
Junior Member
 
Join Date: Nov 2005
Posts: 2
Default

i have try to make a new user account with 1MHT flag, added at gadmin group and i have insert the id now !reqadd don't work in any way... others req command are ok instead...

i have try to assign id of sitebot account and nothing

now don't work this command.... I have try to search more explication about :

Request_IRC_Uid = 0
and
Request_IRC_Gid = 0

but no more infos

also about a "new" fuction Request_Use_Uid-GID_from_IRC = 0
i haven't found infos

if any one can help me for configure user for irc request, id to insert and know the fuction of
Request_Use_Uid-GID_from_IRC = 0 please tell me TNX!
default is offline   Reply With Quote
Old 04-01-2006, 05:43 PM   #4
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

make sure there exists files in /users and /groups called 0
zOrP is offline   Reply With Quote
Reply

Tags
command, ftp, problem, request, [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:12 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)