Go Back   FlashFXP Forums > > > >

ADDiCT's scripts sitewho.exe, ioGroups, ioGui, ioLimitTransfers, ioSecureAdduser

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-22-2005, 07:34 PM   #136
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

well, i'm still can't fix the error.

4:46:03 PM wSock_Connect()
4:46:08 PM 220 FTP Server ready.
4:46:08 PM > USER member@192.168.1.1:8000
4:46:08 PM 530 Login incorrect.
4:46:22 PM 421 Timeout (15 seconds): closing control connection.
4:46:24 PM wSock_Error() -> Connection is aborted due to timeout or other failure (10053)
4:46:24 PM ----------- connection closed -----------

i'll post my settings now, maybe it help to fix it.

Under sites.ini:

--------------------------------------------------------------------------------------------------------------------

name = Admin
host = ******.myftp.org
port = 8000
user = ioFTPD
pass = ************
ident =
connectonstartup = 0
usesslproxy = 1
--------------------------------------------------------------------------------------------------------------------

Under settings.ini

--------------------------------------------------------------------------------------------------------------------
just changed

#####################
# WinSSLWrap tunnel #
#####################
# for AUTH TLS support
#

ssl_tunnel_host = localhost
ssl_tunnel_port = 8000

--------------------------------------------------------------------------------------------------------------------


Just to remember i'm using TLS enabled on my site.

C'mon guys. My ioFTPD is almost perfect.

Just gimme a hand with this issue.

Thx a lot !!!!
goom is offline   Reply With Quote
Old 11-23-2005, 04:06 AM   #137
Pu$u
Member
 
Join Date: Jul 2004
Posts: 36
Default

i'm not sure if this will work for u, because i cant test it i dont have io reg. ( NO SSL/TLS )
but u should type Under ioGui -> settings.ini -> ssl_tunnel_host = 127.0.0.1
and for TLS u should use Under Services -> FTP server type -> AUTH TLS.
let me know if it worked.

sry 4 my bad english
Pu$u is offline   Reply With Quote
Old 11-23-2005, 04:34 AM   #138
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

Quote:
Originally Posted by Pu$u
and for TLS u should use Under Services -> FTP server type -> AUTH TLS.
let me know if it worked.

sry 4 my bad english
hello Pu$u

ok, where is Under Services -> FTP server type -> AUTH TLS

i can't find it.
goom is offline   Reply With Quote
Old 11-23-2005, 04:37 AM   #139
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

Cause, as u can see, i don't have that option, under GUI edit preferences. all i can see is this image

http://img512.imageshack.us/my.php?image=0010ma.jpg
goom is offline   Reply With Quote
Old 11-23-2005, 05:29 AM   #140
Pu$u
Member
 
Join Date: Jul 2004
Posts: 36
Default

Quote:
Originally Posted by ADDiCT
ioGui can't connect to the hostort u specified.
=> check the settings of the site in ioGui, did u enter the correct IP and port?

When using SSL, u need to use a wrapper like WinSSLWrap, ioGui has no built-in SSL support. See included screenshot on how to configure WinSSLWrap.
Like ADDiCT said before u need a wrapper like WinSSLWrap and the options u search for are in WinSSLWrap.
Pu$u is offline   Reply With Quote
Old 11-23-2005, 02:19 PM   #141
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

Quote:
Originally Posted by Pu$u
Like ADDiCT said before u need a wrapper like WinSSLWrap and the options u search for are in WinSSLWrap.

ok, but

what is a "wrapper" ?? how can i do it ?


sorry i'm soo n00b
goom is offline   Reply With Quote
Old 11-23-2005, 10:47 PM   #142
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

well, i made some testes last night.

if i set site without TLS protected GUI works fine. but if i enable TLS i get that login incorrect msg.

Let's go guys, do me a tutorial or give me a rela help to fix it.


i'm noob
goom is offline   Reply With Quote
Old 11-30-2005, 02:25 AM   #143
goom
ioFTPD Professional License
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 32
Default

Well guys, after several days asking for help, and getting help via PM's i finally solved my problem.

For any future doubt from any user, to iogui work with SSL/TLS sites protected, all u have to do is change one line in [FTP_Service] > ### Encryption ###:

change from Require_Encrypted_Auth = * to Require_Encrypted_Auth = !-ioFTPD *

This will allow ioFTPD user connect with iogui without SSL enabled on it, and it will require all other users to use secure connections.

Sorry about my english and thx all.
goom is offline   Reply With Quote
Old 04-03-2006, 09:32 AM   #144
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Thx for the info, i had SSL setup and with this ioGUI works perfect

I only have other problems with ioGUI2

When i add user with it he places him in the group "NoGroup" when i try to change user to for example "FRiENDS" he is in both groups?

Deleting him from the other 1 isn't working and it looks like io hangs?

ioFTPD version used is : ioFTPD-5-8-7r
whocarez2k5 is offline   Reply With Quote
Old 05-11-2006, 01:46 PM   #145
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

After some problems i have installed latest stable version of io (585.r) from 10 May.
I noticed ioGUI isn't working any more on this release
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 05-15-2006, 03:27 AM   #146
panzerfaust
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 112
Default

ioGui works on 5.8.5r, but it does not however work on 5.8.8r any suggestions ADDiCT?
panzerfaust is offline   Reply With Quote
Old 05-15-2006, 11:01 AM   #147
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by panzerfaust
ioGui works on 5.8.5r, but it does not however work on 5.8.8r any suggestions ADDiCT?
Which version did you use of io 5.8.5r?
The latest from 10 May?

Quote:
Wednesday 10th of May 2006
README for ioFTPD-beta5-8-5r.zip


ioFTPD Beta 5.8.5r Full Install


This package represents the last major \"stable\" beta, 5.8.5r, combined with all of the updated documentation and configuration files from the newest releases. This should make getting ioFTPD running from a fresh install much easier. The old 5.8.0 package will be archived.
I have doen anything, only thing works is dir structure
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 05-15-2006, 03:16 PM   #148
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

If you are using the EXE version of ioGuiExt -> try the iTCL version instead: currently, none of my SHMEM scripts are interacting with 5.8.8r.
ADDiCT is offline   Reply With Quote
Old 05-15-2006, 04:46 PM   #149
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

Quote:
Originally Posted by ADDiCT
If you are using the EXE version of ioGuiExt -> try the iTCL version instead: currently, none of my SHMEM scripts are interacting with 5.8.8r.
Not working ADDiCT

Quote:
------------------------------------------------------------------
05-15-2006 23:44:45 "..\scripts\ioGuiExt.itcl" terminated abnormally
--------------------------- ErrorInfo ----------------------------

while executing
"vfs chattr $where 254"
------------------------------------------------------------------
If you read my quoite earlyer, you almost think that version is based on the new 5.8.8 code or at least some off maybe that's why it isn't working?
__________________
Setup: ioFTPD 6.6.0 / ioNiNJA.beta.v.0.6.1.1 / nxTools v.1.2.1
whocarez2k5 is offline   Reply With Quote
Old 05-31-2006, 06:17 AM   #150
dink-puller
Member
ioFTPD Foundation User
 
dink-puller's Avatar
 
Join Date: Sep 2004
Posts: 58
Cool ioGUIExt v.1.0.4

I have been using ioftpd 5.8.5 with ioGUI with no problems. I noticed the newer version of ioGUIExt in the scripts section so I thought I'd give it a try. I couldn't make it work at all, until I deleted ioGUIExt.ini. What is that exactly? And what's the trouble?

P.S. It wouldn't surprise me if ioGUIExt.itcl didn't work with 5.8.8, none of the tcl scripts I've tried have worked with 5.8.8...or 5.8.7...or 5.8.6, so I see no reason to upgrade until the http daemon is fixed anyway.
dink-puller is offline   Reply With Quote
Reply

Tags
crash, ioftpd, iogui2, iolimittransfers, logging

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:20 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)