Go Back   FlashFXP Forums > > > >

ADDiCT's scripts sitewho.exe, ioGroups, ioGui, ioLimitTransfers, ioSecureAdduser

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-05-2003, 10:51 AM   #1
Kublai
Junior Member
 
Join Date: Sep 2003
Posts: 25
Default ioGroups problem

I get this error everytime i try one of the commands with ioGroups. I have set up the ini-files just as it should be.

500 'SITE LUSERS': command not understod

In mirc I get this:

ERROR: "user_file" is not a valid file
Kublai is offline   Reply With Quote
Old 11-05-2003, 10:52 AM   #2
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

Quote:
1. edit ioGroups.ini !

2. put these lines in your ioftpd.ini configfile:

[Scripts]

; for ioFTPD 5.1.* and newer
lgroups = EXEC ..\scripts\ioGroups.exe listgroups
lusers = EXEC ..\scripts\ioGroups.exe listusers
grpstats = EXEC ..\scripts\ioGroups.exe groupstats
usrstats = EXEC ..\scripts\ioGroups.exe userstats
traffic = EXEC ..\scripts\ioGroups.exe sitestats
user = EXEC ..\scripts\ioGroups.exe userinfo
owngroup = %EXEC ..\scripts\ioGroups.exe listgroups %[$group]
myinfo = %EXEC ..\scripts\ioGroups.exe userinfo %[$user]


3. don't forget to rehash!
?


500 'SITE LUSERS': command not understod --> ioftpd.ini file was not configured correctly

ERROR: "user_file" is not a valid file --> ioGroups.ini file was not configured correctly
ADDiCT is offline   Reply With Quote
Old 11-05-2003, 11:08 AM   #3
Kublai
Junior Member
 
Join Date: Sep 2003
Posts: 25
Default

Here is what i post in my ioftpd.ini

lgroups = ..\scripts\ioGroups.exe listgroups
lusers = ..\scripts\ioGroups.exe listusers
grpstats = ..\scripts\ioGroups.exe groupstats
usrstats = ..\scripts\ioGroups.exe userstats
traffic = ..\scripts\ioGroups.exe sitestats
user = ..\scripts\ioGroups.exe userinfo
owngroup = %..\scripts\ioGroups.exe listgroups %[$group]

And ioGroups.ini

; for ioFTP beta 4 :
; user_file = C:\ioFTPD\etc\passwd
; group_file = C:\ioFTPD\etc\group

users_dir = C:\ioFTPD\users
groups_dir = C:\ioFTPD\groups

template_path = C:\ioFTPD\scripts\template

sysop_logfile = C:\ioFTPD\logs\SysOp.log
ioftpd_logfile = C:\ioFTPD\logs\ioFTPD.log
Kublai is offline   Reply With Quote
Old 11-05-2003, 11:10 AM   #4
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

what ioFTPD version are u using ?
ADDiCT is offline   Reply With Quote
Old 11-05-2003, 11:13 AM   #5
Kublai
Junior Member
 
Join Date: Sep 2003
Posts: 25
Default

Beta 4.9.4
Kublai is offline   Reply With Quote
Old 11-05-2003, 11:16 AM   #6
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

user_file = C:\ioFTPD\etc\passwd
group_file = C:\ioFTPD\etc\group

remove the leading ; 's
ADDiCT is offline   Reply With Quote
Old 11-05-2003, 11:19 AM   #7
Kublai
Junior Member
 
Join Date: Sep 2003
Posts: 25
Default

thx a lot Now its working in mirc

But it didnt solve the 500 command not understod error.
Kublai is offline   Reply With Quote
Old 11-05-2003, 11:41 AM   #8
Kublai
Junior Member
 
Join Date: Sep 2003
Posts: 25
Default

Found the error, my bad. Hadn`t restartet ioftpd after adding the new commands in the ini file.

Thx for the help
Kublai is offline   Reply With Quote
Old 11-29-2004, 08:06 PM   #9
freak
Guest
 
Posts: n/a
Default

Hey i get similar error like Kublai

[L] site lusers
[L] 550 Command failed.

i have added these entries in ioftpd.ini like it was in readme file
im using ioftpd 5.8.5 +dzsbot + php psio

I wonder what can be wrong any1 got a clue ?

Tnx for help
  Reply With Quote
Old 11-29-2004, 08:24 PM   #10
freak
Guest
 
Posts: n/a
Default

now i get
[L] site lusers
[L] 500 SITE lusers: Command not understood.

  Reply With Quote
Reply

Tags
500, command, error, iogroups, lusers

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash hangs during transfers slatts General Discussion 5 01-14-2005 07:50 PM


All times are GMT -5. The time now is 06:47 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)