Old 02-10-2005, 01:21 PM   #1
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default Service

Type: Utility / Application

Make ioFTPD running as a service

Put this in ioFTPD system dir (where ioftpd.exe is located).
To install service (Automatic Start), type "ioservice -i" (to uninstall: "ioservice -u").
Then start first time service with: "net start ioftpd" (or reboot computer).
The program is warned when ioFTPD crashed or was killed and immediatly restart it.

If you want to use secure connections (SSL/TLS), you have to do this (Thanks to oldino and gpyfsk):
first U have to run ioftp as a service

You must have this in etc\ioftpd.env:
SYSTEMDRIVE=%[environment(SYSTEMDRIVE)]
SYSTEMROOT=%[environment(SYSTEMROOT)]

If they weren't there you have to restart ioftpd

Extract makecert.exe and rsa.bat in scripts\cert

in ioftpd.ini, add this line under FTP_Custom_Commands:
rsa = EXEC ..\scripts\cert\rsa.bat
don't forget to do a SITE CONFIG REHASH

Edit rsa.bat and replace the 2 NAME by your ip/host and then execute command under ioftpd then
u will have new cert under system dir. Double click it and voilà .

Of course don't forget to edit ioftpd settings for SSL/TLS and restart it
If U want 168bit 3DES as in glFTPD, set Encryption_Protocol to TLS and Min_Cipher_Strength and Max_Cipher_Strength to 168


Script page:
makecert and rsa.bat: http://esibruxelles.free.fr/ioservice/ioServiceSSL.zip
http://esibruxelles.free.fr/ioservice/
http://www.inicom.net/pages/en.ioftpd-scripts.php?id=77


Changelog:
0.1: First version
0.2: Bug found (crashes after 150 sec). Just replace exe
0.3: Automatically delete ioftpd.crash.log if exist. Just replace exe
0.4:
* Now instataneously restart ioftpd process if crashed or killed
* There's 2 versions: one that deletes ioftpd.crash.log and another without
Mr_X is offline   Reply With Quote
Old 02-11-2005, 07:42 AM   #2
oldhouse80
Member
ioFTPD Foundation User
 
Join Date: May 2003
Posts: 37
Default

If u have shareDB and install ioftp as a service with this nice script, u must be careful about how u install odbc service, otherwise ioftp will crash everytime ioservice runs it.

When u add odbc service to listen to sharedb, instead of adding it in the first tab (user dsn), choose to add the sql odbc server under system dsn, otherwise your ioftpd will not be able to look at user db and obviously will crash.

Certificate trick has already been tested on 3 sites and works great so u shouldn't have problems anymore with ioftp as a service!!!

Enjoy
oldhouse80 is offline   Reply With Quote
Old 07-19-2005, 07:22 AM   #3
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

New URL for the script (cause moving forum lost most scripts):
http://esibruxelles.free.fr/ioservice/
Mr_X is offline   Reply With Quote
Old 08-14-2005, 07:09 AM   #4
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

I just reuploaded ioServiceSSL.rar and made download link
Mr_X is offline   Reply With Quote
Old 08-14-2005, 01:28 PM   #5
leeson
Member
ioFTPD Foundation User
 
leeson's Avatar
 
Join Date: Apr 2004
Location: 127.0.0.1
Posts: 31
Default

looks great
i'll try it
leeson is offline   Reply With Quote
Old 08-15-2005, 02:26 AM   #6
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

hmm..
when i do
site rsa
i get this

R] site rsa
[R] 200-
[R] 200-C:\ioFTPD\system>makecert.exe -r -n "CN=10.0.0.2" -b 01/01/2004 -e 01/01/2010 -eku 1.3.6.1.5.5.7.3.1 -ss my -sr CurrentUser -sk 10.0.0.2 -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 ioftpd.cer
[R] 200-Error: Save encoded certificate to store failed => 0x3 (3)

any ideas ??

btw, i followed the readme.. so why does it say C:\ioFTPD\system>makecert.exe when its placed in c:\ioFTPD\scripts\cert
?
but i copied it so its both places..

Still dont work.. :/
zOrP is offline   Reply With Quote
Old 08-15-2005, 05:31 AM   #7
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

Put makecert.exe in ioftpd system dir and retry "site rsa".

Webpage and first post edited.
Mr_X is offline   Reply With Quote
Old 08-15-2005, 07:15 AM   #8
zOrP
Senior Member
 
Join Date: Jan 2005
Posts: 282
Default

i tried that.. and also tried copying the bat to system dir..

the ioftpd.cer pops up
but same error..
and auth ssl not supported.. :x
zOrP is offline   Reply With Quote
Old 08-15-2005, 10:56 AM   #9
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

I succeded creating and installing cert on windows then modifying ioftpd.ini then a restart ioftpd.
Meet me on irc, i'll try to help you: I have nick Mister_X
Mr_X is offline   Reply With Quote
Old 11-08-2005, 10:52 AM   #10
InvisiGod
Member
ioFTPD Foundation User
 
Join Date: Aug 2004
Posts: 32
Default

hmm, tried to install io as a service and i followed ur tut, but when i try to net start ioftpd i get an error which says that ioftpd could not be startet...

i'm using io 5.8.6r

what went wrong?
InvisiGod is offline   Reply With Quote
Old 11-29-2005, 03:48 PM   #11
ekke
Junior Member
 
Join Date: Nov 2005
Posts: 1
Default

in rsa.bat , if you are behind NAT should you enter the "private" ip that the ioftp servar actually running on ( ie 192.168.0.10 ) or the public IP från ur isp that you are using and portforwaring to the private ip ?
ekke is offline   Reply With Quote
Old 11-29-2005, 05:13 PM   #12
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

it's not very important (it's what i think). And i used my computer's name for the certificate. You can use everything you want, it's just a name.
Mr_X is offline   Reply With Quote
Old 01-28-2006, 11:20 AM   #13
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

I updated instructions to install SSL/TLS to ioftpd running as a service.
Mr_X is offline   Reply With Quote
Old 03-07-2006, 01:42 AM   #14
void4ever
Junior Member
 
Join Date: Nov 2005
Posts: 27
Default

I'm having an issue with certain scripts (namely alcobot) not seeing the messagewindow when ioFTPD is run as a service.

I tried adding WindowName = ioFTPD::MessageWindow to my INI hoping it wouldn't get lost in the mix but it still does.

I can only assume that because it's running as a service it's taking on ioservices window name? Because if i remove the service and run ioFTPD by itself it works just fine.

So my question, is it possible ioftpd is taking on ioservices window name, and if it is, what is that window name so i can modify the alcobot settings.

If thats completely off base does anyone have any ideas?
void4ever is offline   Reply With Quote
Old 03-07-2006, 04:10 AM   #15
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

Make sure the eggdrop and the ioFTPD are running from the same account.
You'll prolly find ioFTPD is running as SYSTEM and the bot as [USERNAME].
They're in a different shared memory space so cant see each other if using different accounts.
EwarWoo is offline   Reply With Quote
Reply

Tags
ioftpd, replace, restart, service, start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FlashFXP Behind Uni Proxy Problems... Idyll General Discussion 1 02-07-2005 06:11 PM
site msg in ioA peorth WarC's scripts 5 01-22-2003 09:22 PM


All times are GMT -5. The time now is 12:59 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)