Old 03-07-2006, 01:00 PM   #16
void4ever
Junior Member
 
Join Date: Nov 2005
Posts: 27
Default

yes it is running as SYSTEM because it's a service. I was unaware that they couldn't see eachothers memory space in that respect. I appreciate the info, looks like the bot is turning into a service tonight as well :P

Thanks again!

Void4ever
void4ever is offline   Reply With Quote
Old 04-02-2006, 05:25 PM   #17
whocarez2k5
Senior Member
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 147
Default

@MR X
I followed your SSL guide and i did't everything like said in readme but when i logon i get this msg:

[1] 220 FTP Server ready.
[1] AUTH SSL
[1] 504 AUTH SSL unsupported.

I have set ioftpd.ini like this

Require_Encrypted_Auth = *
Require_Encrypted_Data = *
Certificate_Name = my.ip.stands.here
Explicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 256

What have i done so far:
Installed io as service --> working perfect
Added lines to ioftpd.env
Created cert
Installed cert
Changed ioFTPD.ini (see above)
Changed SSL/TSL settings ftp program (AUTH SSL)
Started io and nothing happends

What am i doing wrong?

:update:
After alot of reading i noticed that for many a system reboot solved problem and it did for me also

Only problem atm is that some 1 connects to server there isn't any msg displayed when he is not on a SSL connection.
Any ideas?

instead off error msg to use ssl i get this

[2] PASS (hidden)
[2] 530 Login failed: Invalid password.
whocarez2k5 is offline   Reply With Quote
Old 04-03-2006, 12:44 PM   #18
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by whocarez2k5
Only problem atm is that some 1 connects to server there isn't any msg displayed when he is not on a SSL connection.
Any ideas?

instead off error msg to use ssl i get this

[2] PASS (hidden)
[2] 530 Login failed: Invalid password.
i don't believe there is a cookie indicating whether the connection is encrypted or not.
_panic_ is offline   Reply With Quote
Old 04-12-2006, 02:19 PM   #19
g00dwin
Junior Member
 
Join Date: Apr 2006
Posts: 3
Default

can i make ioFTPD and eggdrop working as one service with this script? i was make ioFTPD and eggdrop run as one single service, i.e. i had service called "ioFTPD - Service" and when i run it it runs ioFTPD and eggdrop together and SSL worked fine, but now i cant remember how i did that hehe
g00dwin is offline   Reply With Quote
Old 04-16-2006, 12:32 PM   #20
Mr_X
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 142
Default

g00dwin, you can, just start eggdrop with "OnServerStart" event.
Another thing. I think i'll post source code of Service (in GPL), I don't have so much time to improve it, i'm working on a project that takes all my time
Mr_X is offline   Reply With Quote
Reply

Tags
ioftpd, replace, restart, service, start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FlashFXP Behind Uni Proxy Problems... Idyll General Discussion 1 02-07-2005 06:11 PM
site msg in ioA peorth WarC's scripts 5 01-22-2003 09:22 PM


All times are GMT -5. The time now is 01:05 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)