Old 02-29-2004, 11:00 PM   #1
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default ioACTIVE

ioACTIVE to see activity of users on your ftp ...

1) Add This to Your ioFTPD.ini

[Events]
OnFtpLogIn = EXEC ..\scripts\ioACTIVE.exe login

[FTP_Custom_Commands]
activity = EXEC ..\scripts\ioACTIVE.exe activity

[FTP_SITE_Permissions]
activity = 1M

Your Done ...

ohh if you want to display last users on ftp message just add this
%[execute(EXEC ..\scripts\ioACTIVE.exe)(activity 10)] to your Welcome message.... (do this oldino )

Code:
## Display Activity for All Users on FTP

site activity all
200-/------------------------------------------\
200-| user         | date     | time  | logins |
200-|------------------------------------------|
200-| ioFTPD       | 08/03/04 | 17:48 | 103    |
200-| fuscao       | 08/03/04 | 17:39 | 1      |
200-\------------------------------------------/

## Display Activity for a Certain User

site activity ioFTPD
200-/------------------------------------------\
200-| user         | date     | time  | logins |
200-|------------------------------------------|
200-| ioFTPD       | 08/03/04 | 17:48 | 103    |
200-\------------------------------------------/

## User not Found on Activity DB

site activity SomeDude
200-/------------------------------------------\
200-| User not Found                           |
200-\------------------------------------------/

## Display Last X Users Logged in (chronologic order)

site activity 2
200-/------------------------------------------\
200-|      last 2 users loggend in . . .       |
200-|------------------------------------------|
200-| user         | date     | time  | logins |
200-|------------------------------------------|
200-| ioFTPD       | 08/03/04 | 17:48 | 103    |
200-| fuscao       | 08/03/04 | 17:39 | 1      |
200-\------------------------------------------/

## Display Help for ioACTIVE

site activity
200-/--------------------------------\
200-|          ioACTIVE v1.1         |
200-|--------------------------------|
200-| Usage : site activity all      |
200-| Usage : site activity <user>   |
200-| Usage : site activity <number> |
200-\--------------------------------/
download it here : http://www.ioftpd.com/scripts/script.php?id=50
hot_pit is offline   Reply With Quote
Old 03-01-2004, 02:49 AM   #2
sCry
Member
 
Join Date: Oct 2003
Posts: 79
Default

why not display user's IP address or hostname? we have some common account, so need ip to tell who login.
sCry is offline   Reply With Quote
Old 03-01-2004, 10:55 AM   #3
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default

Quote:
Originally posted by sCry
why not display user's IP address or hostname? we have some common account, so need ip to tell who login.
depends on what you will use it ... if you use to display on welcome message last 10 users to login ... you will display users ip aswell ..

edit : btw i dont think it would work for multiple account cause it logs only 1 date/time for ip ... otherwise db will be bigger everyday ... this way as stormACTIVE the max line of DB is the max users on site
hot_pit is offline   Reply With Quote
Old 03-01-2004, 01:15 PM   #4
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default

v 1.6 Out .

Fixed - timespamps were not used to show last 10 users (now it is)
Add - ini support for not showing activity of certains users

see 1th post for thread to download
hot_pit is offline   Reply With Quote
Old 03-01-2004, 01:22 PM   #5
rAWfOX
Senior Member
 
Join Date: Aug 2003
Posts: 148
Default

nice one....
rAWfOX is offline   Reply With Quote
Old 03-08-2004, 06:38 PM   #6
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default

v1.2 fixed some bugs and add number of logins
hot_pit is offline   Reply With Quote
Old 03-13-2004, 02:33 PM   #7
r0adrunn3r
Junior Member
 
Join Date: Nov 2003
Posts: 10
Default

seems not to work on my system, doesnt create entries in the login.dat
my ioftpd.ini looks like:

[Events]

OnFtpLogIn = EXEC ..\scripts\ioactive\ioACTIVE.exe login

[FTP_Custom_Commands]
activity = EXEC ..\scripts\ioactive\ioACTIVE.exe activity

it always says empty login.dat

any suggestions about that?

thx a lot!

greetz

r0adrunn3r
r0adrunn3r is offline   Reply With Quote
Old 03-13-2004, 02:35 PM   #8
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default

Quote:
Originally posted by r0adrunn3r
seems not to work on my system, doesnt create entries in the login.dat
my ioftpd.ini looks like:

[Events]

OnFtpLogIn = EXEC ..\scripts\ioactive\ioACTIVE.exe login

[FTP_Custom_Commands]
activity = EXEC ..\scripts\ioactive\ioACTIVE.exe activity

it always says empty login.dat

any suggestions about that?

thx a lot!

greetz

r0adrunn3r
yeah ... go dl 1.6 and it should work fine
hot_pit is offline   Reply With Quote
Old 03-13-2004, 02:50 PM   #9
r0adrunn3r
Junior Member
 
Join Date: Nov 2003
Posts: 10
Default

damn....that was easy :banana:
works perfect now, didnt read the changelog so i thougt the 1.2 is the newer.
thanx for your work

greetz

r0adrunn3r
r0adrunn3r is offline   Reply With Quote
Old 03-13-2004, 03:49 PM   #10
_rage_ thegod
Member
 
Join Date: Jan 2004
Posts: 40
Default

nice script, i like it
_rage_ thegod is offline   Reply With Quote
Old 03-14-2004, 04:51 PM   #11
Sersen
Junior Member
 
Join Date: Jan 2004
Posts: 25
Default

yeah,nice script but i´m confused a bit about the version numbers here

Version 1.6 is the latest release but doesn´t include logins
Version 1.2 isn´t working because it does not create any entries in login.dat but should have logins in the logfile

so how can i get logins logged with ioactive with a working release ?? :banana: :banana:

please give me a hint

hehe

bye
Sersen is offline   Reply With Quote
Old 04-02-2004, 06:08 AM   #12
odd
Senior Member
ioFTPD Registered User
 
Join Date: Sep 2003
Posts: 273
Default

Any working release of this script?

None of them seem to work (1, 1.2)
Looks like a handy script hope there will be a proper update soon
odd is offline   Reply With Quote
Old 04-02-2004, 07:28 PM   #13
hot_pit
Member
ioFTPD Registered User
 
Join Date: Nov 2003
Posts: 78
Default

Quote:
Originally posted by odd
Any working release of this script?

None of them seem to work (1, 1.2)
Looks like a handy script hope there will be a proper update soon
go try last packet ... dunno what maybe causin this ...
will do some changes on it when i got some time ..
but i tested it (1 , 1.1 , 1.2) on 5.6.3r and 5.8.4r , and its working ok here ...
maybe you deleted Login.Dat
hot_pit is offline   Reply With Quote
Old 04-03-2004, 08:18 AM   #14
odd
Senior Member
ioFTPD Registered User
 
Join Date: Sep 2003
Posts: 273
Default

Ok been testing them both (1.2 and 1.6 tho 1.6 was only called ioActive which is confuseing for me, as I thought it was the first version out of ioactive). And 1.2 is uploaded to script page some days after 1.6 so I thought 1.2 was the newest update.

Well Ive tested them both and 1.2 doesnt work for me. Its seems like it cant write to the Login.Dat file.

Tho I got 1.6 working and it works fine(5.8.4r).
Like it alot


Edit: nevermind...
odd is offline   Reply With Quote
Old 04-30-2004, 06:23 PM   #15
odd
Senior Member
ioFTPD Registered User
 
Join Date: Sep 2003
Posts: 273
Default

Think ive found a bug in your greate script. It doesnt show this user in "site activity 1".
This user "test" is not listed in ioActivity.ini "hide users".

Look at the SITE CMD and the date/time



Code:
site activity test
200-/---------------------------------\
200-| user         | date     | time  |
200-|---------------------------------|
200-| test         | 02-05-04 | 03:51 |
200-\---------------------------------/
200 Command successful.

site activity 1
200-/---------------------------------\
200-| last 1 users loggend in . . .   |
200-|---------------------------------|
200-| user         | date     | time  |
200-|---------------------------------|
200-| test2       | 04-04-30 | 07:38 |
200-\---------------------------------/
200 Command successful.

Ive done some more research and found that login.dat continues to log users but somehow the program cant read it, strange.

This is my login.dat file:
Code:
a|27-04-04|23:10
b|27-04-04|23:14
c|11-04-04|14:16
d|29-04-04|06:16
e|26-04-04|05:12
f|01-05-04|16:18
g|12-04-04|00:37
h|01-05-04|23:02
i|26-04-04|16:23
j|06-04-04|01:20
k|27-04-04|22:37
l|01-05-04|21:40
m|30-04-04|07:38
Wonder why it just stoped to show SITE IOACTIVITY 1" last X users loggend in . . . |
odd is offline   Reply With Quote
Reply

Tags
200-|, activity, download, ftp, site

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:35 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)