Old 04-14-2014, 12:38 PM   #1
Saiph
Junior Member
 
Join Date: Oct 2010
Posts: 23
Default first zip file uploaded error

04-13-2014 22:46:36 "..\scripts\ioNiNJA\ioNiNJA.itcl" terminated abnormally
--- ErrorInfo ---
can't read "zip_files": no such variable
while executing
"llength $zip_files"
(procedure "::ioNiNJA::ZipScript::ZipScript" line 119)
invoked from within
"::ioNiNJA::ZipScript::ZipScript 0 [lindex $args 1] [lindex $args 2] [lindex $args 3] "
("CHECK" arm line 1)
invoked from within
"switch -- [lindex $args 0] {
SYMCLEAN { ::ioNiNJA::symlink_clean }
RESCAN { ::ioNiNJA::ZipScript::rescan }
RESOR


when the first zip file is uploaded it is deleted
any ideas on fixing this ? thanks

Last edited by Saiph; 04-14-2014 at 12:39 PM. Reason: using ioFTPD-v7.7.2 + ioNiNJA.1.0.Beta4.2012-10-02 + nxTools-v1.2.1
Saiph is offline   Reply With Quote
Old 04-14-2014, 11:30 PM   #2
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Is it reproducible with a particular file all the time? Is the .zip file valid and without error/warnings? If so you might want to PM odog with details since it really helps to debug if you can reproduce the problem locally.
Yil is offline   Reply With Quote
Old 04-15-2014, 01:18 AM   #3
Saiph
Junior Member
 
Join Date: Oct 2010
Posts: 23
Default

Quote:
Originally Posted by Yil View Post
Is it reproducible with a particular file all the time? Is the .zip file valid and without error/warnings? If so you might want to PM odog with details since it really helps to debug if you can reproduce the problem locally.
yes the zip files are valid always the first file uploaded from every 0DAY release
after i upload, i need to upload the file that got deleted to complete the release
and the only error i get is the one i first posted
Saiph is offline   Reply With Quote
Old 04-16-2014, 02:53 AM   #4
TeRRaNoVA
Junior Member
 
Join Date: Apr 2014
Posts: 26
Default

He Saiph i got same error,

cant the first xx0.zip file be uploaded? only excepts the second file xx1.zip, afther re-upload the first file xx0.zip its being accepted.
its being deleted afther the site extract die file_id.diz.

is there something wrong with the NiNJALiB.tcl

useing the beta4
TeRRaNoVA is offline   Reply With Quote
Old 04-17-2014, 09:28 AM   #5
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Try re-installing ioNiNJA in the scripts directory and use the default settings just to see if it works.

My guess is some option/configuration setting is causing an error to show up that most users aren't seeing. Whenever there is an error returned to ioFTPD the server deletes the file because a non-success return code means something was wrong with the uploaded file.

If it works with the default settings, go ahead and re-apply some of the settings until it breaks again so you can figure out which option is causing the problem.
Yil is offline   Reply With Quote
Old 04-22-2014, 12:04 PM   #6
Saiph
Junior Member
 
Join Date: Oct 2010
Posts: 23
Default fixed the zip file delete

had to carefully read the config

## No diz files required in zipfiles in theese dirs in order for it to be counted as complete
## seperated by |
set ioNJ(no_diz_required) "/APPS/"

previously had it set to "/0DAY/" which was deleteing the file
seems sort of odd tho but it works
and ty for replying
Saiph is offline   Reply With Quote
Reply

Tags
$args, invoked, ioninjazipscriptzipscript, line, [lindex

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:22 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)